Clavier à l'écran surgissant chaque fois que je touche l'écran

13

Je suis en 17.10. Chaque fois que je touche l'écran, que ce soit pour modifier des fenêtres / applications, faire défiler un navigateur ou appuyer sur un bouton, le petit clavier stupide apparaît dans le coin inférieur gauche.

Je n’ai jamais laissé le clavier d’écran activé dans Universal Access, mais si je le active, c’est le même clavier qui apparaît dans le coin inférieur gauche.

Dans cette capture d'écran, je touche simplement l'écran dans une vidéo YouTube en plein écran. Vous pouvez voir le menu apparaître à droite, sous le point où je touche.

Je n’ai pas de photo d’avant, mais il était similaire au clavier / couleur, mais il était plus petit, peut-être deux fois moins large et seulement dans la partie inférieure gauche de l’écran, au lieu de s’étirer sur toute la largeur. . Ce changement de clavier gauche à clavier pleine largeur est intervenu après avoir suivi les conseils de @pomsky ci-dessous.

Ceci est un bogue confirmé . Vous pouvez vous marquer comme affecté pour, espérons-le, augmenter son attention reçue.

    
posée Tom Mercer 16.10.2017 - 02:19
la source

3 réponses

19

Caribou a également continué à faire face à ma grande contrariété, alors j'ai écrit une extension de gnome que monkey patches gnome-shell pour arrêter de faire éclater le clavier lorsque l'écran tactile est appuyé. ( lien ). Ce n'est que quelques lignes de js, mais le dépôt git est ici: lien

Comment utiliser des extensions

  1. Pour gérer les extensions gnome, téléchargez gnome-tweak-tool avec

    sudo apt install gnome-tweak-tool

  2. Les extensions Gnome sont téléchargées via le site Web officiel de gnome-extensions, qui nécessite un connecteur natif pour communiquer avec gnome-shell. Installez ce connecteur natif (même si vous exécutez Firefox) avec

    sudo apt install chrome-gnome-shell

  3. Enfin, pour installer l’extension, accédez à la page de l’extension et appuyez sur l’interrupteur dans le coin supérieur droit. Gnome vous invitera à installer l'extension. Ces extensions peuvent être gérées via l’outil gnome tweak. Cependant, pour les désinstaller, vous devez utiliser la page Web.

réponse donnée Keringar 23.10.2017 - 03:06
la source
0

J'utilise Ubuntu 16.04 et j'ai rencontré un problème similaire lors de l'exécution de Synergy. Parfois, le clavier à l'écran apparaîtrait sans raison et je ne pouvais pas le faire disparaître. J'ai finalement décidé de supprimer Caribou:

sudo dpkg --remove --force-depends caribou
ps -eF | grep caribou | awk "{print }" | xargs kill -9 {}+ 

Cela a laissé le clavier toujours bloqué sur l'écran, mais j'ai verrouillé l'écran ( crtl+alt+L ) et me suis reconnecté, puis le clavier est tombé.

    
réponse donnée Karl Wilbur 29.05.2018 - 14:52
la source
-1

J'ai eu ce problème sur mon Lenovo Yoga 300 après la mise à niveau du 17.04 au 17.10, le clavier apparaissant sur tout quand je tapais sur quelque chose à l’écran ou même lorsque je tapais sur le clavier matériel normal.

La solution consistait à ouvrir l’application Accès universel et à désactiver l’option Clavier d’écran (dans la section Saisie).

Contre-intuitivement, le clavier à l’écran s’affiche quand je touche un champ de texte à l’écran. Cependant, il ne s'affiche plus lorsque je commence à taper sur le clavier matériel ou lorsque je tape sur d’autres éléments à l’écran.

J'espère que c'est aussi simple qu'un correctif pour les autres.

    
réponse donnée Thesle Williams 20.10.2017 - 23:28
la source

Lire d'autres questions sur les étiquettes