Desktop ne s'affiche pas lorsque j'ai installé les pilotes nvidia!

69

Le bureau ne s'affiche pas après l’installation des pilotes expérimentaux nvidia. J'ai essayé les pilotes propriétaires simples nvidia, et ils ne fonctionnaient pas non plus.

Voici à quoi ça ressemble. Ce n'est pas recadrée ou quoi que ce soit. Voici comment cela a l'air, après l'installation des pilotes, la résolution du bureau est passée de 1440x900 à 1024x768

Le bureau affiche uniquement desh et des panneaux lorsque j'utilise les pilotes open source.

Y a-t-il un moyen de résoudre ce problème pour obtenir de meilleures performances?

    
posée Levan 18.10.2012 - 19:59
la source

10 réponses

79
J'ai eu la même chose. Voici comment je l'ai corrigé:

  1. Passer à un terminal Ctrl + Alt + F1 .

  2. Connectez-vous en tant que nom d'utilisateur.

  3. Installer les en-têtes linux:

    sudo apt-get install linux-headers-generic
    
  4. Désinstaller le pilote nvidia - cela dépend de la version installée:

    sudo apt-get remove nvidia-current
    

    ou

    sudo apt-get remove nvidia-current-updates 
    

    ou

    sudo apt-get remove nvidia-experimental-304
    
  5. Réinstallez le pilote nvidia

    sudo apt-get install nvidia-current-updates
    

    Lorsque vous faites cela, il doit dire quelque chose comme:

    Building initial module for 3.5.0-17-generic
    Done.
    

    Si ça se dit

    Module build for the currently running kernel was
    skipped since the kernel source for this kernel
    does not seem to be installed.
    

    alors le problème ne sera pas résolu. Ne croyez pas le message. Il ne demande pas que linux-source soit installé, il ne veut que les en-têtes, mais vous devez installer les en-têtes spécifiques -generic pour votre noyau. Exécuter:

    sudo apt-get install linux-headers-'uname -r'
    

    Cela ne va pas fonctionner avec juste linux-headers-generic ou linux-headers-3.5.0-17 (par exemple).

  6. Si l'installation réussit, redémarrez l'ordinateur:

    sudo shutdown -r now
    

Cela devrait permettre au module du noyau de compiler et d’installer correctement. C'est fait pour moi!

    
réponse donnée rft183 18.10.2012 - 20:39
la source
9

Si le bureau ne s'affiche toujours pas, cela peut provenir de la carte graphique Nvidia Optimus . J'ai un ordinateur portable avec GT 650M et c'est aussi une carte Optimus. Les cartes Optimus se comportent un peu différemment et il n’ya pas de support Linux par défaut. Plus d'infos sur Optimus sous Linux: lien

Mais il est possible de le faire fonctionner avec Bumblebee . Voici comment je l'ai fait sur une nouvelle installation d'Ubuntu 12.10 (aucun pilote nvidia n'est installé):

sudo add-apt-repository ppa:bumblebee/stable 
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic 

Puis redémarrez ou reconnectez-vous.

Cela n'a pas fonctionné en premier lorsque j'ai laissé cette deuxième commande. Ensuite, exécutez quelque chose avec le type de carte graphique optirun avant la commande. Par exemple: optirun glxspheres ou optirun ./executable-file . Une bonne façon de tester la différence entre les graphiques intégrés et votre carte graphique consiste à exécuter glxspheres avec et sans optirun .

lien

Cela économise de l’énergie lorsque vous activez votre carte graphique uniquement lorsque cela est nécessaire. J'espère que j'ai aidé quelqu'un, car j'ai passé des heures à découvrir le problème avec ma carte graphique (oui, je suis assez nouveau avec ces pilotes graphiques Linux).

    
réponse donnée Arttu 04.12.2012 - 15:18
la source
5

Après s’être mêlé à cela pendant quelques soirées (disparition du bureau d’unité, résolution de 640x480 uniquement, artefacts étranges sur mon écran) sur ma Geforce GT 630, c’est ce qui a fonctionné pour moi:

  1. Nouvelle installation d'Ubuntu 12.10
  2. Immédiatement après l'installation, exécutez le programme de mise à jour du logiciel. Télécharger & amp; Installez toutes les mises à jour
  3. Redémarrer
  4. sudo apt-get install linux-sources && sudo apt-get install linux-headers-generic (je ne suis pas tout à fait sûr de savoir pourquoi / pourquoi cette étape est nécessaire, mais je l'ai vu dans ce fil et j'ai pensé l'essayer)
  5. Ouvrir des "sources de logiciels" à partir du tableau de bord
  6. Cliquez sur l'onglet "Pilotes supplémentaires".
  7. Activer le pilote xorg binaire NVIDIA (propriétaire, testé)
  8. Redémarrer

jusqu'ici tout va bien - j'ai le panneau de configuration NVIDIA (sans le message d'erreur Xconfig), deux moniteurs et une haute résolution.

Remarque spéciale: n'installez PAS le package "drivers supplémentaires" (Jockey). Ce paquet semble effectivement disparaître après l’étape 2 (mises à jour logicielles) - la méthode d’ajout de pilotes semble avoir été déplacée vers l’application "sources logicielles".

    
réponse donnée Jim Keller 22.11.2012 - 03:00
la source
3

Je viens d'installer Ubuntu 12.10 aujourd'hui, et j'ai eu ce problème avec nvidia driver.

J'ai essayé de suivre les instructions ci-dessus, mais tout cela a échoué à cause de deux mots très importants: "générique" et "-17".

J'ai finalement constaté que la meilleure façon d’installer le pilote NVidia était d’utiliser réellement le programme d’installation de nvidia. Donc je suis allé à:

lien

et version téléchargée pour Linux-64bit (installez synaptic sudo apt-get install synaptic et regardez dans le menu Paramètres - & gt; Repository - & gt; Pilotes supplémentaires pour connaître le nom exact de votre carte nvidia)

Ensuite, vous exécutez l’outil et vous dites qu’il vous faut des en-têtes de noyau, mais lisez-le attentivement car il nécessite des en-têtes "génériques".

Vous devez vérifier la version de votre noyau, la mienne était la version 3.5.0-17 (ceci est "-17" à la fin du problème), donc dans mon cas je l'ai fait:

sudo apt-get install linux-headers-3.5.0-17-generic

(découvrez la version de votre noyau en tapant ina terminal uname -r )

Vous devez tuer le démon d’identification par interface graphique:

killall lightdm

et après cela vous pouvez courir:

sudo sh NVIDIA-Linux-x86_64-310.19.run

Le programme d'installation vous dira probablement que le module du noyau Noveau est chargé et suggérera d'ajouter un script modprobe. Vous devriez dire Ok / Yes à tout ce qu’il vous dit, puis redémarrer et exécuter NVIDIA-Linux-x86_64-310.19.run à nouveau.

Je ne sais pas si une autre approche pourrait aussi bien fonctionner, mais celle-ci est sûre.

    
réponse donnée Radek 21.12.2012 - 13:14
la source
2

Cela fonctionne également pour les cartes Nvidia 7400. Mais si le noyau se met à jour, vous devez changer la ligne d'installation pour la dernière version maintenant:

sudo apt-get install linux-headers-3.5.0-18-generic

au lieu de cela:

sudo apt-get install linux-headers-3.5.0-17-generic
    
réponse donnée Daniel Zippert 20.10.2012 - 19:19
la source
0
sudo apt-get install nvidia-current nvidia-settings
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo nvidia-xconfig

Redémarrez le système!

    
réponse donnée BlitzkriegBop 19.10.2012 - 18:08
la source
0

J'ai essayé presque tout, mais voici celui qui a vraiment fonctionné pour moi:

exécutez les commandes suivantes:

sudo add-apt-repository ppa:amith/ubuntutools
sudo apt-get update
sudo apt-get install unity-reset

puis réinitialisez l'unité avec cette commande:

unity-reset

reboot et Unity est de retour !! J'espère que cela fonctionne pour vous.

    
réponse donnée camilo garcia 12.11.2012 - 00:27
la source
0

J'ai résolu le problème ce soir. J'ai installé le dernier noyau 3.7.1 après l'avoir compilé comme je le fais toujours. Ensuite, j'ai installé les pilotes nVidia de Synaptic. Cela a entraîné la disparition des menus Unity comme vous l’avez montré dans votre capture d'écran. La solution pour moi est la suivante:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Maintenant, non seulement le problème est résolu par les derniers pilotes nVidia!

    
réponse donnée Joel Frese 09.01.2013 - 05:16
la source
0

Si votre installation ne fonctionne pas (module initial non généré), vous devez vous assurer qu'un seul jeu d'en-têtes est installé.

dpkg --get-selections | grep linux-headers

Cela ne fonctionne pas

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install
linux-headers-generic               install

Cela fonctionne

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install

Dans ce cas, simplement

apt-get remove linux-headers-generic

L'installateur nvidia fonctionnera maintenant.

    
réponse donnée Nate Symer 07.04.2013 - 04:02
la source
-1

J'ai fait ceci:

sudo apt-get autoremove fglrx --purge

A bien fonctionné.

    
réponse donnée Shaun 06.12.2012 - 05:10
la source

Lire d'autres questions sur les étiquettes