Résolution d'écran supérieure dans VirtualBox?

138

Je viens d'installer Ubuntu 10.04 dans VirtualBox sur Windows 7.

Malheureusement, les seules options affichées pour la résolution de l’écran sont 640x480 et 800x600 et l’écran affiche «Inconnu».

Comment pourrais-je aller pour augmenter la résolution à 1280x1024 (je suis sur un moniteur 1600x1200)?

Mise à jour
J'ai essayé de monter l'ISO de VirtualBox 'Guest Additions' (à partir du menu 'Devices' de VBox) et de faire sudo sh ./VBoxLinuxAdditions-x86.run du lecteur monté, qui a donné 2 nouvelles résolutions répertoriées après un redémarrage (1024x768 et la version 16: 9 de cette résolution). Celles-ci ont fonctionné lorsque je les ai sélectionnées mais ont disparu lorsque je suis revenu à une autre résolution. J'ai essayé de redémarrer et de lancer VBoxLinuxAdditions-x86.run à nouveau, mais sur les deux options de basse résolution répertoriées cette fois.
Je pense que je vais réinstaller ...

Semble être un problème VBox plutôt qu’un problème Ubuntu, car après avoir réinstallé 10.4 en écrasant la partition virtuelle originale, sudo sh ./VBoxLinuxAdditions-x86.run n’a plus d’effet du tout.

    
posée pelms 28.08.2010 - 04:18
la source

20 réponses

105

Vous devez installer les utilitaires invités VBox pour prendre en charge le matériel graphique virtualisé.

sudo apt-get install virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

Auparavant, vous aviez peut-être besoin des versions "ose":

sudo apt-get install virtualbox-ose-guest-utils virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms
    
réponse donnée maco 28.08.2010 - 04:25
la source
44

Modifier:

http://www.linuxformat.com/forums/viewtopic.php?p=103289
  1. Lancez la boîte virtuelle et connectez-vous à Ubuntu.

  2. Appuyez sur la touche Ctrl droite pour pouvoir placer le pointeur de la souris en dehors de la machine virtuelle.

3.Allez en haut de la fenêtre virtuelle, cliquez sur les périphériques puis sélectionnez "Installer les ajouts d'invité" Vous verrez une fenêtre apparaître dans Ubuntu vous montrant que de nouveaux fichiers sont montés dans un lecteur de CD-ROM virtuel. L'un de ces fichiers devrait être VBoxLinuxAdditions.run

Vous devez exécuter le fichier avec certaines autorisations d’administrateur, faites-le de cette façon ...

  1. Cliquez à nouveau sur l’écran Ubuntu puis allez à Applications - Accessoires puis Terminal. La fenêtre du terminal est l'endroit où vous exécuterez le fichier, mais nous devons d'abord accéder au répertoire approprié.

  2. tapez ceci ... cd /media/cdrom0 (puis appuyez sur Entrée, il y a un espace après cd!)

  3. type suivant ... dir (Vous devriez voir parmi les fichiers affichés VBoxLinuxAdditions.run)

  4. maintenant tapez ... sudo sh ./VBoxLinuxAdditions.run (oui, c'est un arrêt complet avant la barre oblique!)

Une fois que vous avez appuyé sur Entrée et que vous avez terminé, les fichiers sont désormais accessibles depuis Ubuntu.

  1. Vous devez maintenant redémarrer la machine virtuelle ou appuyer sur Ctrl+Alt+backspace .

  2. Connectez-vous au bureau Ubuntu et cette fois, allez dans Système - Préférences puis Résolution d'écran. Vous devriez maintenant avoir plus d'options que les trois options de basse résolution que vous aviez au début de la journée!

Si la résolution que vous souhaitez n’est pas l’une des nouvelles, suivez ces étapes ...

  1. Ouvrez à nouveau la fenêtre terminal (Applications - Accessoires puis Terminal)

  2. Tapez ... sudo gedit /etc/X11/xorg.conf (espace après gedit et X11 doit être majuscule X)

  3. Il vous demandera un mot de passe identique à celui avec lequel vous vous connectez.

  4. L'éditeur de texte se charge et vous devriez voir beaucoup de texte dans la fenêtre. Faites d'abord une sauvegarde de ce fichier en allant dans "fichier" puis "enregistrer sous" et en changeant le nom du fichier en xorgbak.conf

  5. Vous devez maintenant parcourir le texte jusqu’à ce que les résolutions affichées soient affichées. Ceux qui vous préoccuperont seront listés sous 24 bits ou 16 bits (car ces profondeurs sont celles qui vous donnent une grande quantité de couleurs).

  6. L'idée ici est d'avoir votre résolution d'écran préférée incluse dans cette liste. Faites-le soit en l'insérant avant les autres résolutions listées exactement de la même manière, soit en le tapant sur l'une des autres. (il vous suffira de faire cela uniquement pour les bits de profondeur 24 et 16)

  7. Vous devez maintenant faire un "enregistrer sous" mais faites attention ici car nous avons besoin d'appeler à nouveau le fichier xorg.conf. Si vous appuyez simplement sur Enregistrer ici, vous auriez enregistré les modifications sur le fichier de sauvegarde que vous avez créé!

  8. Vous avez terminé. Cliquez sur Ctrl+Alt+Backspace pour redémarrer votre boîte virtuelle, connectez-vous et profitez de vos nouvelles options de résolution d'écran!

réponse donnée Siamore 28.08.2010 - 11:20
la source
13

J'ai eu le même problème et ensuite découvert que si vous lancez la machine virtuelle & gt; cliquez sur "view" dans la barre d'outils & gt; Cliquez sur "redimensionnement automatique de l’écran invité, puis votre machine virtuelle aura la même résolution d'écran que votre propre écran.

    
réponse donnée XtremlyGeeky 29.12.2012 - 23:38
la source
11

Périphériques & gt; Installez les ajouts d'invité, laissez-le s'exécuter puis déconnectez-vous.

Lorsque vous êtes retourné à l’écran de connexion, vous verrez qu’il s’agit de la taille maximale de votre moniteur. Connectez-vous et vous êtes prêt à partir.

    
réponse donnée ben_nuttall 29.04.2012 - 15:04
la source
9

Une fois les ajouts de la Vbox installés (et redémarrer l’hôte invité), appuyez sur Hôte + H, puis agrandissez la fenêtre, ce qui devrait faire l'affaire.
Si ce n'est pas le cas, vous utilisez peut-être une ancienne version de vbox (par conséquent, les compléments Vbox pourraient avoir une incompatibilité ..)

    
réponse donnée Axel 28.09.2010 - 14:21
la source
7

Essayez d’augmenter la quantité de RAM allouée à la Virtual Box. Travaillé pour moi.

Pour ce faire, arrêtez la machine virtuelle, puis dans VirtualBox, accédez aux paramètres de la machine virtuelle. Allez dans la section Affichage. Vous pouvez y augmenter la mémoire vidéo. Le mien était 1MB; Je l'ai augmenté à 32 Mo et cela m'a permis d'utiliser pleinement mon moniteur 24 pouces.

    
réponse donnée anon 26.04.2014 - 01:32
la source
4
  • Paramètres & gt; Vidéo & gt; Mémoire vidéo = 128 Mo , Activer l’accélération 3D = true .
  • Installer GuestAdditions
  • Sur la machine hôte, dans cmd / bash , exécutez

    VBoxManage setextradata global GUI/MaxGuestResolution any
    
  • créer un fichier /etc/X11/xorg.conf contenant du contenu:

    Section "Device"
      Identifier      "Configured Video Device" 
    EndSection
    Section "Monitor" 
      Identifier      "Configured Monitor"
    EndSection 
    Section "Screen"  
      Identifier      "Default Screen" 
      Monitor         "Configured Monitor"
      Device          "Configured Video Device" 
      SubSection "Display"
        Modes "1920x1080" 
      EndSubSection
    EndSection
    
  • Pour exécuter la machine virtuelle:

    Host Key Right Ctrl par défaut + Home = afficher en plein écran.

J'ai essayé d'exclure chaque étape, à l'exception de l'installation GuestAdditions . Vous avez besoin de chacun d'eux.

    
réponse donnée Gangnus 30.06.2014 - 13:31
la source
3

Je peux vous dire comment je fais cela avec Mac OS X en tant que système hôte. Peut-être que cela fonctionnera aussi sous Windows.

  • Je lance ubuntu dans VirtualBox
  • J'ouvre le terminal sous Mac OS X
  • et exécutez "VBoxManage controlvm [name] setvideomodehint 1280 1024 24" (remplacez [name] par le nom de votre ubuntu vm)
réponse donnée user142 01.09.2010 - 17:20
la source
3

J'ai eu le même problème et j'ai pu résoudre le problème en utilisant l'utilitaire xrandr. J'ai suivi cet article pour résoudre le problème.

lien

Parfois, cela peut vous aider. Essaie.

    
réponse donnée aneeshep 10.12.2010 - 06:45
la source
3

J'ai pu résoudre ce problème en fermant mes machines virtuelles VirtualBox, en quittant VirtualBox et en exécutant cette commande dans un terminal:

VBoxManage setextradata global GUI/MaxGuestResolution any

Ensuite, lancez la sauvegarde de VirtualBox et le problème devrait être résolu!

    
réponse donnée hto 20.01.2013 - 08:14
la source
2

La commande suivante a fonctionné pour moi
Ouvrez Terminal et tapez:
sudo apt-get install dkms

Source: lien
Redémarrez VirtualBox

    
réponse donnée waghso 03.01.2016 - 15:07
la source
1

Quel pilote est spécifié dans ur xorg.conf? AFAIK, après l'installation des ajouts d'invité, le 'vboxvideo' doit être utilisé:

Section "Device"
    Identifier   "Configured Video Device"
    Driver     "vboxvideo"
EndSection
    
réponse donnée Alexey Nedilko 28.08.2010 - 22:21
la source
1

Après avoir installé les ajouts d'invité: Aller aux paramètres & gt; Afficher Augmentez la mémoire vidéo et activez l'accélération vidéo 2D et 3D.

    
réponse donnée mnrl 25.02.2014 - 14:22
la source
1

Il est probable que votre toute nouvelle installation d'une distribution Linux sur votre Virtualbox soit encore récente et qu'il reste encore beaucoup à faire pour configurer votre environnement, dont le moindre n'est pas d'activer le système X Window. vous voyez des paramètres d’affichage pour un rapport d’aspect 4: 3 et l’entrée de «startx» à l’invite de commande ne fait rien.

.. à l'invite de votre terminal, entrez les informations suivantes:

sudo apt-get install dkms
sudo apt-get update
sudo apt-get install linux-headers-'uname -r'
sudo apt-get install --reinstall xorg
startx

Si vous avez configuré votre machine virtuelle en mode plein écran avant d’entrer dans «startx», l’écran s’ajustera automatiquement au format 16: 9, avec les barres d’outils et de tâches à leur place.

    
réponse donnée baudrunner 12.05.2014 - 23:18
la source
1

Outre l’installation du plug-in Guest Additions, notez que la taille d’affichage maximun peut être limitée dans le panneau VirtualBox préférences générales :

Vérifiez également l’option autoResize et VirtualBox définira automatiquement la taille de l’affichage lorsque vous redimensionnez ou agrandissez la fenêtre.

    
réponse donnée Agustí Sánchez 01.09.2016 - 11:29
la source
0

Cela a peut-être déjà été résolu mais j'ai eu ce problème et je l'ai corrigé très simplement, j'ai simplement mis à jour VirtualBox vers la dernière version, puis réinstallé les ajouts d'invité.

    
réponse donnée Steven Rice 08.09.2014 - 02:02
la source
0

VirtualBox 4.3.12 empêchait les solutions ci-dessus de fonctionner sur mon système Windows. 4.3.18 a été publié vers le 10/10/2014 (10 octobre 2014), tout fonctionne depuis l'installation.

La commande "VBoxManage setextradata global GUI / MaxGuestResolution any" semble avoir fonctionné précédemment, c’est-à-dire qu’elle ne contient aucune erreur.

L'installation des ajouts d'invités s'était déjà plaint que les fichiers d'en-tête n'étaient pas installés, mais ils étaient absolument WERE (et restaient intacts), comme en témoigne l'installation des ajouts d'invités sous 4.3.18 le module de dossiers partagés.

    
réponse donnée user341448 23.10.2014 - 04:08
la source
0

Voici une réponse mise à jour pour 2016 qui a fonctionné pour moi.

Pour commencer, je suis sur Mac 10.11 (El Capitan), et mon VirtualBox est 5.0.26. J'exécute Ubuntu 14.04 LTS dans cet exemple (je dois éventuellement mettre à jour mon Ubuntu).

  1. Démarrer votre VM
  2. Sélectionnez "Périphériques - & gt; image du CD Insérer des ajouts d'invité ..." (non, vous n'avez pas vraiment besoin d'un CD, c'est virtuel)
  3. Cela ouvrira une fenêtre demandant votre mot de passe root
  4. Une fenêtre de terminal s’ouvrira. Si vous vous posez des questions sur la réinstallation par rapport à une version précédente des ajouts d'invité, tapez "yes" et appuyez sur la touche
  5. Redémarrez votre VM
  6. Une fois que la machine virtuelle est à nouveau opérationnelle, accédez à "Afficher - & gt; écran virtuel 1 - & gt; [quelle que soit la résolution souhaitée]" .

Mes options étaient comprises entre 640x480 et 1920x1200. Une fois que j'ai sélectionné une nouvelle résolution, je ne suis plus obligé de redémarrer l'ordinateur virtuel, il a été automatiquement mis à l'échelle.

    
réponse donnée Josh Beam 29.08.2016 - 20:19
la source
0

J'ai fait ce réglage et tout allait bien: Pilotes supplémentaires

    
réponse donnée Jan Vavra 13.04.2017 - 14:57
la source
0

Si aucune des réponses ne vous aide à résoudre le problème (comme c’était le cas avec moi), vérifiez sur votre OS hôte que dans la fenêtre "Résolution d'écran" ( Panneau de configuration & gt; Apparence et personnalisation & gt; Afficher ) les affichages sont alignés et pas comme dans l'image du lien suivant:

Aperçu des paramètres sur Système d’exploitation hôte qui m'a causé un problème avec une résolution maximale sur le système d’information invité

Si quelqu'un est confus à cause de la valeur du champ Display affiché, la raison en est que je n'utilise pas Windows 7 comme système d'exploitation hôte. Je l'ai donc utilisé sur VirtualBox pour simuler un problème.

Si vous souhaitez utiliser une résolution différente sur chaque moniteur et que vous n'êtes pas sûr de savoir comment aligner les affichages dans la fenêtre précédente, cliquez sur le bouton "Détecter" pour faire les choses correctement. Vous ne vous douteriez probablement pas que cela pose problème car, si vous utilisez Windows 7 (ou toute nouvelle version de Windows) en tant que système d’exploitation hôte, il restituera l’image sur vos moniteurs, même si le positionnement défini est déformé comme indiqué.

J'ai rencontré ce problème sur de nombreux systèmes d'exploitation invités testés comme Ubuntu, Windows XP et Windows 7 (le problème dans mon cas n'était donc pas lié à Ubuntu ni à Linux) et après avoir configuré correctement ce paramètre, j'ai a été en mesure de choisir la plus grande résolution souhaitée dans mon OS invité (bien sûr, vous devez auparavant installer les ajouts invités VBox comme indiqué dans plusieurs réponses).

    
réponse donnée zeko868 06.03.2018 - 05:03
la source

Lire d'autres questions sur les étiquettes