Comment installer Adobe Acrobat Reader à partir du référentiel?

56

Comment installer Adobe Acrobat Reader sous Ubuntu 14.04 à l'aide d'un référentiel Trusty apt ?

Ceci n'est PAS une copie du Comment installer le package deb Adobe Acrobat Reader téléchargé à partir du site Web d'Adobe? . Dans Synaptic > Repositories > Other software , j’ai activé "Partenaires canoniques", mais je ne peux toujours pas installer acroread car il n’est pas disponible sur mon système 64 bits.

Voici le résultat de la console:

[email protected]:/home/liv# apt-get install acroread
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package acroread
[email protected]:/home/liv# apt-get install acroread:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package acroread
    
posée landroni 25.04.2014 - 13:07
la source

8 réponses

66

C’est un peu plus manuel d’installer Adobe Acrobat Reader dans Ubuntu 14.04, mais ce n’est pas compliqué.

Ouvrez un terminal.

Type:

cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

Cela télécharge le fichier DEB d'Adobe et le place dans votre dossier Téléchargements. Type suivant:

sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

Cela installera Adobe Acrobat Reader.

Si vous utilisez une machine 64 bits, vous devrez peut-être ajouter les bibliothèques manquantes mentionnées par Nim:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386

Si vous souhaitez utiliser Acrobat Reader comme application par défaut pour les fichiers PDF, tapez:

mimeopen -d *.pdf

Il affichera une liste de programmes (il en affiche 3 pour moi). Sélectionnez le numéro comportant Acrobat Reader. Il ouvrira Acrobat Reader et indiquera qu'il ne peut pas ouvrir '* .pdf'. Ignorez cette erreur et fermez Adobe Reader. Vous devriez être prêt maintenant.

    
réponse donnée G Trawo 03.05.2014 - 13:46
la source
25

Au lieu de lister explicitement toutes les dépendances, vous pouvez simplement faire ceci:

sudo apt-get install -f

Cela résoudra automatiquement toutes les dépendances non résolues.

Donc, toute la séquence de commandes doit être comme ceci:

cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install -f
    
réponse donnée Undespairable 17.08.2014 - 23:32
la source
4

Vous pouvez voir le lien suivant: ubuntu-updates (voir la colonne de publication) ce package acroread n'est pas encore disponible pour 14.04 (digne de confiance).

Attendez donc que votre nom soit ajouté aux référentiels des partenaires Canonical. Sinon, vous pouvez installer l'ancienne version. Voir une question similaire : question similaire pour awn.

Dans ce cas, la même erreur se produit pour awn: E: Unable to locate package avant-window-navigator

    
réponse donnée Pandya 25.04.2014 - 13:26
la source
4
  1. Téléchargez Adobe Reader à partir de: lien .

Sélectionnez le système: Linux, votre langue, Reader 9.5.5 pour Linux (.deb)

  1. Installez gdebi:
sudo apt-get install gdebi
  1. Installez Adobe Reader via gdebi et acceptez les dépendances:
sudo gdebi PACKAGENAME.deb
  1. Installer les bibliothèques requises:
sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386

Enfin, démarrez Adobe Reader à partir du menu contextuel des fichiers Menu, Dash ou PDF.

via: ubuntuhandbook.org

    
réponse donnée Nim 28.04.2014 - 12:17
la source
1

depuis le 2014-10-23, la réponse est toujours "vous ne faites pas" (ou ne pouvez pas)

Il est peu probable que cela arrive jamais aussi.

La dernière version d'Acrobat Reader pour Unix / Linux est 9.5.5

Cela a fonctionné pour moi (la réponse imparable du 17 août n'a pas permis d'installer certains paquets nécessaires) sur Xubuntu 14.04

# as root (prefix with sudo if you are running as an unprivileged user)
apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386
apt-get install --reinstall gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386
cd /tmp && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

après le test:

rm -rf /tmp/acroread_1000_1000
rm /tmp/AdbeRdr9.5.5-1_i386linux_enu.deb
    
réponse donnée Derek Shaw 24.10.2014 - 22:49
la source
0

Essayez d’utiliser le terminal:

sudo apt-get install acroread

et si cela ne fonctionne pas - utilisez:

sudo apt-get install acroread:i386

Éditer: utilisez d'abord les commandes suivantes:

sudo apt-add-repository multiverse
sudo apt-get update
    
réponse donnée aastefanov 25.04.2014 - 13:12
la source
0

Aujourd'hui, j'ai testé les éléments suivants avec succès dans une nouvelle installation de kUbuntu 14.04.4 (une version officielle de Ubuntu).

Ajouter un PPA canonique

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"

Mettre à jour et installer

sudo aptitude update  
sudo aptitude install acroread  

Fonctionne sur kUbuntu 14.04 LTS
Au 30 avril 2016, ne fonctionne pas sur le nouveau kUbuntu 16.04 LTS

    
réponse donnée jtlindsey 19.02.2016 - 17:58
la source
-1

Comment j'ai finalement installé Acrobat Reader sur Ubuntu 14.04 sur une machine 64 bits:

  1. J'ai téléchargé la version .deb d'Adobe.com;

  2. Installez le package à l'aide de gedbi ;

  3. Installez les bibliothèques:

    sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 
    

Fait!

    
réponse donnée ionelf 04.05.2014 - 10:28
la source

Lire d'autres questions sur les étiquettes