Comment supprimer Kernel / LTS Enablement Stack?

11

Cette question concernant la pile d'activation LTS comporte en fait deux parties:

  1. J'ai installé Linux 3.5.0-x sur Precise 64bit via sudo apt-get install linux-generic-lts-quantal xserver-xorg-lts-quantal . En réalité, VirtualBox ne fonctionne pas encore sur le nouveau noyau (EDIT: ceci est maintenant corrigé). Par conséquent, je veux le supprimer du système. Comme prévu, la suppression des méta-packages via sudo apt-get install linux-generic-lts-quantal xserver-xorg-lts-quantal ne suffit pas. Quels paquets dois-je supprimer manuellement? Pour le noyau je le ferais (pour le moment): sudo apt-get remove linux-image-3.5.0-25-generic . Cependant, en ce qui concerne xserver-org, je suis perdu. Comment puis-je revenir au serveur d'origine xserver?
  2. J'ai installé un système avec le support d'installation 12.04.2. Là, j'ai aussi le noyau 3.5.0-x, car c'est le valeur par défaut pour cette version . Comment puis-je rétrograder vers le noyau (et xserver?) Vers la série 3.2.0-x?

Merci!

    
posée Andre 09.03.2013 - 21:44
la source

3 réponses

5

Important: les instructions ci-dessous ne fonctionnent que si l'un des noyaux de pile de pré-activation est encore installé, par ex. 3.2.0-38.

Avec la pile d’activation installée, exécutez «uname -r» pour vérifier la version actuelle du noyau. Remplacez-le par la commande ci-dessous:

sudo apt-get purge linux-generic-lts-quantal xserver-xorg-lts-quantal linux-headers-generic-lts-quantal linux-image-generic-lts-quantal linux-image-3.5.0-25-generic linux-headers-3.5.0-25

Réinstallez les composants importants (y compris X lui-même!) qui sont supprimés en raison des dépendances des commandes ci-dessus:

sudo apt-get install xserver-xorg xserver-xorg-input-synaptics

Corrigez le client Steam:

sudo apt-get install libgl1-mesa-glx:i386

Enfin, redémarrez votre ordinateur.

À mon humble avis, la pile d'activation n'est pas prête pour la publication. D'après mon expérience, Virtualbox, Samba et le client Steam sont tous en rupture avec la pile d'activation installée. Il existe une solution de contournement pour Virtualbox, mais aucune pour Samba ou Steam (mars 2013).

    
réponse donnée happyskeptic 14.03.2013 - 15:37
la source
2

Dans Trusty / 14.04, il reste quelques paquets à supprimer ou apt-get se plaindra.

sudo apt-get remove linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic

Ensuite, installez xserver-xorg s'il n'est pas installé, redémarrez à l'ancienne version du noyau, supprimez le (s) noyau (s) 3.16 et vous êtes prêt à partir.

Si vous utilisez Steam, vous devez installer deux packages:

sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
    
réponse donnée otus 24.02.2015 - 12:57
la source
0

Une procédure à votre disposition:

  1. Désinstallez les packages suivants:

    linux-generic-lts-quantal
    xserver-xorg-lts-quantal
    
  2. Installez les packages suivants:

    linux-generic
    linux-headers-generic
    linux-image
    linux-image-generic
    linux-libc-dev
    linux-tools
    
  3. Reboot to 3.2.0-38 kernel

  4. Désinstallez les packages linux-headers-3.5.0-x et linux-image-3.5.0-x .

Bonne chance et amusez-vous.

    
réponse donnée cogitoergosum 10.03.2013 - 22:13
la source

Lire d'autres questions sur les étiquettes