Accélération adaptative pour le pavé tactile sur Ubuntu 17.10

11

J'ai récemment mis à jour depuis Ubuntu 16.04 sous Unity vers 17.10 sous GNOME. Depuis la mise à niveau, je manque la fonctionnalité d'accélération adaptative sur mon pavé tactile. Je l'ai absolument aimé car il était plus précis pour des distances plus courtes.

En creusant un peu, j'ai découvert que 17.10 utilise GNOME avec libinput au lieu de synaptics , mais que libinput utilise par défaut un profil d'accélération flat pour les pavés tactiles ( lien ).

J'ai aussi essayé d'installer xserver-xorg-input-synaptics le 17.10. Cela fonctionne bien, sauf qu'il est trop lourd d'activer le "défilement naturel" à partir de la ligne de commande ( lien ). Un autre problème est que GNOME n'affiche pas les paramètres du pavé tactile avec synaptics installé ( lien ).

J'ai également essayé de remuer avec gnome-tweak-tool dans le sous-menu "Clavier et souris" de la barre latérale, mais il a la possibilité de sélectionner "Profil d'accélération" uniquement pour une souris, pas pour les pavés tactiles (voir la capture d'écran Quels sont les profils d'accélération de la souris dans l'outil gnome-tweak? ).

Y a-t-il un moyen d'activer l'accélération adaptative pour les pavés tactiles avec libinput qui n'a aucun des effets secondaires ci-dessus?

    
posée nikhilweee 24.10.2017 - 13:30
la source

3 réponses

3

Pour cela, essayez de modifier la clé speed à partir du schéma org.gnome.desktop.perihperals.touchpad . La description de la clé est la suivante:

Pointer speed for the touchpad. Accepted values are in the [-1..1] range (from "unaccelerated" to "fast"). A value of 0 is the system default.

qui indique fortement que la clé gnome a quelque chose à voir avec l’accélération du pavé tactile. Utilisez l'éditeur ou les gsettings dconf via la ligne de commande et vérifiez si la modification de cette clé a un effet.

    
réponse donnée Nicholas Stommel 26.11.2017 - 00:23
la source
4

Au 17.10, vous pouvez également définir directement le profil d'accélération et désactiver l'accélération de la souris en définissant accel-profile sur 'flat'

gsettings set org.gnome.desktop.peripherals.mouse accel-profile 'flat'

Vous pouvez également utiliser dconf-editor :

    
réponse donnée Simon A. Eugster 02.12.2017 - 21:34
la source
2

Edit: Désolé, cela ne sert que si vous utilisez Xorg, pas Wayland selon Wiki Arch Linux :

  

Pour Wayland, il n'y a pas de fichier de configuration libinput. Les options configurables dépendent de la progression de la prise en charge de votre environnement de bureau; voir # Outils graphiques.

     

Pour Xorg, un fichier de configuration par défaut pour le wrapper est installé dans /usr/share/X11/xorg.conf.d/40-libinput.conf. Aucune configuration supplémentaire n'est nécessaire pour détecter automatiquement les claviers, les pavés tactiles, les trackpointers et les écrans tactiles pris en charge.

Pour Xorg:

Selon sa page de manuel , libinput prend également en charge l’accélération adaptative:

Vous devriez pouvoir l’ajouter en tant qu’option dans xorg.conf, par ex. /usr/share/X11/xorg.conf.d/40-libinput.conf :

Option "AccelProfile" "adaptive"
    
réponse donnée benebun 26.11.2017 - 17:02
la source

Lire d'autres questions sur les étiquettes