Single core toujours près de 100% de charge sur Ubuntu 16.04 (sans aucun travail en cours)

11

Ma machine Ubuntu 16.04 possède 4 cœurs de processeur, et l’un d’eux (dont la taille varie exactement) a toujours une charge de 90% à 100%.

Cela est vrai, peu importe ce que je fais, et même lorsque je ne fais rien du tout, sans fenêtre ouverte. Cela se passe juste après le démarrage ou les heures de travail.

J'ai lu les deux questions connexes les plus populaires: ici et ici , mais cela n'a pas aidé, malheureusement.

Pendant la majeure partie de mon temps de travail, ma productivité n’est pas affectée par ce problème. La seule raison pour laquelle je connais le problème est que les ventilateurs travaillent toujours à leur puissance maximale et que la surveillance du système d’Ubuntu indique que l’un des cœurs est fortement chargé.

Mais peut-être que 10% de mon temps de travail est affecté par une réactivité incroyablement mauvaise, en tant que manifestation supplémentaire.

Surtout l’interface utilisateur (lors des animations et lors de la réaction aux clics) est très lente. Cela m'a conduit à l'idée que le processeur fait peut-être aussi bien le travail du GPU. Mais c'était probablement une croyance non fondée seulement, et les données ci-dessous semblent contredire également.

Ma préoccupation est de savoir si ce problème, si je ne peux pas le réparer, aura un impact (significatif) sur la durée de vie de mon ordinateur ou non. Je ne sais pas quelle est la charge constante de & gt: 90% pour un CPU pendant des mois ou des années.

Quoi qu’il en soit, voici les données que je pourrais collecter sur ma machine, qui peuvent être liées ou utiles:

top :

 PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND  
 415 root      20   0       0      0      0 R  97,3  0,0   1:39.30 kworker/2:2                                                                                       
2442 john      20   0  663828  38704  29852 S   3,3  0,5   0:00.90 gnome-terminal-                                                                                   
1194 root      20   0  335728  69900  48392 S   2,3  0,9   0:08.36 Xorg                                                                                              
1821 john      20   0 1423440 114660  77600 S   1,3  1,5   0:03.77 compiz                                                                                            
6 root         20   0       0      0      0 D   0,3  0,0   0:00.84 kworker/u8:0                                           

grep . -r /sys/firmware/acpi/interrupts/ :

/sys/firmware/acpi/interrupts/sci:        36
/sys/firmware/acpi/interrupts/error:       0
/sys/firmware/acpi/interrupts/gpe00:       0   invalid
/sys/firmware/acpi/interrupts/gpe01:       0   invalid
/sys/firmware/acpi/interrupts/gpe02:       0   invalid
/sys/firmware/acpi/interrupts/gpe03:      36   enabled
/sys/firmware/acpi/interrupts/gpe04:       0   invalid
(...)
/sys/firmware/acpi/interrupts/gpe1F:       0   disabled
/sys/firmware/acpi/interrupts/sci_not:     0
/sys/firmware/acpi/interrupts/ff_pmtimer:  0   invalid
/sys/firmware/acpi/interrupts/ff_rt_clk:   0   disabled
/sys/firmware/acpi/interrupts/gpe_all:    36
/sys/firmware/acpi/interrupts/ff_gbl_lock: 0   enabled
/sys/firmware/acpi/interrupts/ff_pwr_btn:  0   enabled
/sys/firmware/acpi/interrupts/ff_slp_btn:  0   invalid

uname -a :

Linux my-host-name 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

cat /proc/cmdline :

BOOT_IMAGE=/vmlinuz-4.8.0-28-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7

lspci -v :

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1576
    Subsystem: Hewlett-Packard Company Device 81f9
    Flags: bus master, fast devsel, latency 0

00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 1577
    Subsystem: Hewlett-Packard Company Device 81f9
    Flags: bus master, fast devsel, latency 0, IRQ 24
    Capabilities: <access denied>

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo (rev ca) (prog-if 00 [VGA controller])
    DeviceName: ATI EG BROADWAY
    Subsystem: Hewlett-Packard Company Carrizo
    Flags: bus master, fast devsel, latency 0, IRQ 227
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0800000 (64-bit, prefetchable) [size=8M]
    I/O ports at 4000 [size=256]
    Memory at f0500000 (32-bit, non-prefetchable) [size=256K]
    Expansion ROM at f0580000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: amdgpu
    Kernel modules: amdgpu

...

00:08.0 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1578
    Subsystem: Hewlett-Packard Company Device 81f9
    Flags: bus master, fast devsel, latency 0, IRQ 255
    Memory at f0540000 (64-bit, prefetchable) [size=128K]
    Memory at f0300000 (32-bit, non-prefetchable) [size=1M]
    Memory at f0570000 (32-bit, non-prefetchable) [size=4K]
    Memory at f056a000 (32-bit, non-prefetchable) [size=8K]
    Capabilities: <access denied>

...

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
    Subsystem: Hewlett-Packard Company RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
    Flags: bus master, fast devsel, latency 0, IRQ 225
    I/O ports at 3000 [size=256]
    Memory at f0400000 (64-bit, non-prefetchable) [size=4K]
    Memory at f0100000 (64-bit, prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: r8169
    Kernel modules: r8169

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
    DeviceName: Sanji2
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 231
    I/O ports at 2000 [size=256]
    Memory at f1000000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be

Quelqu'un peut-il aider?

    
posée caw 25.11.2016 - 11:25
la source

1 réponse

4

J'ai pu localiser la cause précise de ce problème, même si ce n’est pas vraiment une solution au problème:

En procédant à une nouvelle réinstallation, en modifiant les paramètres un par un et en installant les packages un par un, il est apparu que je pouvais systématiquement reproduire (et même "basculer") le problème en définissant "Built-in dans Display "à" Off "dans les paramètres système.

J'ai eu un moniteur externe connecté via HDMI, et pour économiser de l’énergie, je voulais éteindre complètement l’écran intégré (ce qui fonctionnait mais entraînait une charge CPU élevée et une interface utilisateur ralentie) au lieu de simplement le mettre en miroir ( qui a fonctionné sans aucun inconvénient).

Outre le problème de la charge élevée du processeur, l’ordinateur (portable) émettait un son continu, aigu mais discret, lorsque l’affichage intégré était désactivé.

    
réponse donnée caw 10.02.2017 - 17:32
la source

Lire d'autres questions sur les étiquettes