Ubuntu Gnome 14.10 - Les performances du bureau se dégradent lorsque certaines applications sont en cours d'exécution

11

J'ai passé d'Ubuntu Gnome 14.04 à 14.10 hier en utilisant l'interface graphique standard Software Updater. La mise à niveau s'est bien déroulée, mais une fois la mise à niveau terminée, j'ai remarqué une dégradation significative des performances des postes de travail uniquement lorsque certaines applications sont en cours d'exécution. Les opérations bureautiques de base, telles que la commutation entre les espaces de travail, s'accompagnent d'un retard et d'un bégaiement visibles, ce qui est extrêmement gênant et perturbateur dans le flux de travail quotidien.

J'ai enregistré un screencast démontrant ce problème - j'ai utilisé l'application standard Image Viewer (version 3.12.2) et Google Chrome comme exemples d'applications à l'origine de ce problème - ce qui ne veut pas dire que ces applications sont SEULEMENT .

La vidéo screencast: lien

J'ai essayé de contourner ce problème et essayé plusieurs solutions de contournement liées à l’accélération matérielle du processeur graphique, mais aucune de ces tentatives n’a résolu le problème.

Toute aide ou pointeur serait très apprécié.

EDIT:

Comme suggéré dans le commentaire ci-dessous, j'ai exécuté glxinfo pour collecter des données graphiques / d'accélération supplémentaires, mais je ne sais pas comment lire ceci: lien

En outre, j'ai déposé un rapport de bogue dans Launchpad: lien

    
posée Dawid Lorenz 25.10.2014 - 00:38
la source

2 réponses

1

Si vous avez des graphiques Intel intégrés, vous pouvez essayer

sudo apt-get install xserver-xorg-video-intel

puis redémarrage. Cela a fonctionné pour moi sur un ordinateur portable Dell XPS - tout est redevenu fluide. Source: lien

Si vous avez par la suite des problèmes avec

optirun glxgears

donner "Ne peut pas ouvrir secondaire" ...

Essayez,

 sudo apt-get install nvidia-331-updates

alors

 gksudo gedit /etc/bumblebee/bumblebee.conf

Dans la section [bumblebeed] , modifiez le pilote: Driver=nvidia

Sous [driver-nvidia] , changez les références dans cette section de nvidia-current à nvidia-331-updates . Cela se trouve dans KernelDriver , XorgModulePath et LibraryPath .

Puis redémarrez et essayez

optirun glxgears

Source: lien

    
réponse donnée Chrisky 20.12.2014 - 10:26
la source
0

J'ai résolu un problème similaire en passant de la méthode d'accélération GPU de 'sna' à 'uxa'. Voir lien

Si vous rencontrez des problèmes avec SNA, essayez plutôt d'utiliser UXA, ce qui peut être fait en créant un fichier de configuration X contenant les éléments suivants: /etc/X11/xorg.conf.d/20-intel.conf Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "uxa" EndSection
    
réponse donnée user3113723 22.03.2015 - 23:10
la source

Lire d'autres questions sur les étiquettes