Eclipse ne travaille pas en 16.04

58

Eclipse fonctionnait aussi bien que le 14.04. J'ai fait une installation propre de 16.04 et installé Eclipse. Mais il exécute un programme Java une seule fois, après quoi il se bloque lors des tentatives suivantes avant de le supprimer et de le réinstaller. J'ai essayé beaucoup de choses, car au début j'avais aussi besoin de CDT. En ce moment, je veux juste supprimer tout ce qui concerne eclipse et faire une nouvelle installation (supprimer toutes les configs et dépendances). S'il vous plaît noter que j'ai utilisé le programme d'installation Eclipse pour installer Eclipse et l'image de l'icône éclipse n'apparaît pas non plus (l'ubuntu par défaut apparaît).

    
posée Ankur Lathwal 24.04.2016 - 05:55
la source

7 réponses

114

J'ai eu la même chose avec 16.04 et Eclipse Mars. Je pensais que ça avait gelé mais en fait ça fonctionnait très, très lentement. Le problème est la version de GTK + 3, livrée avec 16.04. Heureusement, la solution est très facile. Ouvrez un terminal, puis tapez export SWT_GTK3=0 , puis démarrez Eclipse à partir du terminal. Si cela fonctionne, alors un correctif plus persistant consiste à placer les 2 lignes ci-dessous, telles qu’elles apparaissent dans votre eclipse.ini :

--launcher.GTK_version
2

avant la ligne:

--launcher.appendVmargs

Le bogue est classé avec Ubuntu à bug 1552764

    
réponse donnée NickT 24.04.2016 - 09:50
la source
5

Merci pour le conseil.

Je devais changer la version requise de Java à partir de:

-Dosgi.requiredJavaVersion=1.7

dans

-Dosgi.requiredJavaVersion=1.8

et supprimez également cette ligne:

-XX:MaxPermSize=256m

Heureux codage!

    
réponse donnée staplr 30.04.2016 - 15:54
la source
3

Modifiez eclipse.desktop comme suit:

Exec=env SWT_GTK3=0 eclipse
    
réponse donnée Haozhe Xie 30.04.2016 - 05:58
la source
1

Ma recommandation est d’installer Eclipse Mars à partir de la page Web: lien

Mais vous devez d’abord installer java8 (pas java9 car Eclipse Mars ne fonctionne pas avec cette version). Dans Ubuntu, vous pouvez le faire avec: sudo apt-get installer openjdk-8-jre openjdk-8-jdk

Et puis .. et juste si vous avez une autre version java, vous devez sélectionner java8 avec cette commande: sudo update-alternatives --config java

Voilà! Cela a fonctionné pour moi! :)

    
réponse donnée Gonzalo 16.05.2016 - 05:30
la source
0

En démarrant l'application à partir de la ligne de commande (le terminal), il est parfois possible d'obtenir plus d'informations sur les raisons pour lesquelles le programme ne parvient pas à démarrer. Par exemple (en supposant que l'éclipse est sur votre chemin, sinon, lancez-le depuis le dossier où il est installé / décompressé):

[email protected]:~$ eclipse
Unrecognized VM option 'MaxPermSize=256m'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Dans ce cas, cela ressemble à la ligne

-XX:MaxPermSize=256m

dans le fichier eclipse.ini est le problème. Supprimez simplement cette ligne (créez d'abord une sauvegarde du fichier eclipse.ini ) et essayez de redémarrer le programme.

La solution ci-dessus a fonctionné sur Eclipse Version: Mars.2 Release (4.5.2) sur une machine mise à niveau de 15.10 à 16.04

    
réponse donnée Ronny Andersson 02.05.2016 - 00:44
la source
0

Apparemment, il s’agit d’un bogue connu dans Ubuntu 16.04. Cela affecte non seulement l'éclipse mais aussi plusieurs autres applications.

Avant la publication du correctif, voici une solution rapide qui fonctionne. Terminal ouvert et tapez

$ initctl restart unity-panel-service

Cela ramènera les menus pour la session en cours. Mais vous voudrez peut-être recommencer si vous redémarrez votre ordinateur.

    
réponse donnée Anonymous Platypus 29.11.2016 - 10:57
la source
0

Si vous obtenez une erreur pour libjavascriptcoregtk-4.0 ou WTFCrash , essayez d'installer libwebkitgtk-3.0-0 :

sudo apt install libwebkitgtk-3.0-0

    
réponse donnée wisbucky 26.01.2018 - 01:45
la source

Lire d'autres questions sur les étiquettes