Comment désactiver le déplacement de la fenêtre avec alt + bouton gauche de la souris dans Shell GNOME?

69

Il y a lots de posts à ce sujet concernant Unity, il s'agit de gnome-shell .

Comme avec d’autres posters, j’utilise des applications (Inkscape en particulier) qui utilisent Alt-Click et Alt-glisser. Gnome-shell m'empêche et désactive ainsi les fonctionnalités de l'application.

J'ai essayé

  • utiliser le plug-in Move de ccsm - vous pouvez désactiver cette option et vous pouvez toujours faire glisser la fenêtre Alt.

  • utiliser l'éditeur gconf pour changer / apps / metacity / general / mouse_button_modifier - cela n'a aucun effet AFAICS.

Ça me gêne vraiment. Sinon, je trouve gnome-shell un environnement vraiment productif.

    
posée artfulrobot 02.04.2012 - 13:02
la source

8 réponses

103

Tout d’abord, installez dconf-tools .

Pour ce faire, exécutez la commande suivante:

sudo apt-get install dconf-tools

Ensuite, ouvrez-le, Alt + F2 dconf-editor .

Faites défiler jusqu'à orggnomedesktopwmpreferencesmouse-button-modifier → Réglez-la sur la clé de votre choix.

Ou, de manière équivalente,

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"

dans le terminal. (Cela ne nécessite ni dconf-editor , ni dconf-tools )

Avertissement: Ne rien définir signifie que tous les clics déplacent les fenêtres, au lieu de les désactiver!

    
réponse donnée jokerdino 02.04.2012 - 14:34
la source
8

Pour résoudre le problème de déplacement de la fenêtre de déplacement Alt + Clic:

sudo gconftool-2 --set /org/gnome/desktop/wm/preferences/mouse-button-modifier --type string '<Super>'

Fait la même chose, vraiment, avec un outil de configuration différent, et moins de recherche et de clic.

Pour les nouvelles versions utilisant dconf / gsettings, utilisez ceci:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"
    
réponse donnée cajhne 18.05.2012 - 20:03
la source
7

Utilisez l’outil Tweak ( gnome-tweak-tool ):

Windows & gt; Clé d'action de fenêtre

    
réponse donnée simplegamer 21.02.2017 - 00:34
la source
6

Je mets Alt + Super comme une solution temporaire. Je peux donc utiliser la clé Alt dans Inkscape et Super pour les activités.

    
réponse donnée KEIII 19.04.2012 - 03:34
la source
3

Dans UBUNTU 14.04 LTS, utilisez la syntaxe dconf comme

<Alt><Super>

Fonctionne bien pour moi.

BTW: Si vous définissez quelque chose de mal, il commence à déplacer la fenêtre à chaque clic. Utilisez pour naviguer jusqu'au bouton "Définir par défaut". Et frappe.

    
réponse donnée Matěj Kříž 31.03.2015 - 10:05
la source
2

Dans Mint, cela peut être modifié ou désactivé dans system settings & gt; windows & gt; behavior & gt; 'Special key to move and resize window'

    
réponse donnée charsi 29.01.2018 - 12:11
la source
1
  1. Aller aux paramètres du système
  2. Sélectionner le clavier
  3. En bas à gauche, cliquez sur "Paramètres de mise en page"
  4. Sélectionnez votre langue et cliquez sur le bouton "Options" en bas à droite
  5. Sélectionnez le comportement de la touche Alt / Win
  6. Changez-le en celui que vous aimez. J'utilise 'Left Alt est échangé avec Left Win'.
réponse donnée user143321 25.03.2013 - 17:32
la source
0

dans CentOS 7, je devais utiliser

 gsettings set org.gnome.desktop.wm.keybindings activate-window-menu "['<Alt>F10']"

Ce paramètre n’était pas spécifié, ce qui signifiait que le bouton central de la souris activait le menu de la fenêtre. Même réglage

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'

n'a pas déplacé cette action sur Alt-middle; Je devais lier activate-window-menu .

    
réponse donnée djb 19.04.2017 - 21:54
la source

Lire d'autres questions sur les étiquettes