Desktop ne retient pas les paramètres de luminosité après un redémarrage

55

Chaque fois que je redémarre ma machine, la luminosité revient à 100% dans Gnome. Je souhaite qu'il conserve le dernier réglage. Y a-t-il de toute façon?

    
posée Decio Lira 08.09.2010 - 03:53
la source

11 réponses

11

Ceci est supposé être configurable dans les options énergétiques, réglez la luminosité au niveau souhaité et il sera toujours utilisé. Si vous utilisez un ordinateur portable, vous devrez également configurer le niveau pour le mode batterie.

J'ai trouvé que Gnome avait quelques problèmes avec la luminosité de l'écran LCD, par ex. Si je passe en mode batterie et que je règle manuellement la luminosité à un niveau donné et que l'ordinateur portable reste sans surveillance pendant 10 secondes, il reviendra à la luminosité préréglée lorsque je reprendrai le contrôle. Même chose en mode climatisation, mais cela prend plus de temps et passe plus facilement inaperçu. Je crois que tous ces paramètres doivent être enregistrés quelque part et restaurés - du moins pour le mode A / C.

EDIT: Pour gnome3, cela ne fonctionne pas (du moins pour moi).

    
réponse donnée levesque 08.09.2010 - 04:06
la source
21

Le fichier /etc/rc.local devrait ressembler à ceci:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
echo 0 > /sys/class/backlight/acpi_video0/brightness
exit 0

Per @zerdo: Dans mon studio Dell 1558, le paramètre de luminosité est stocké dans /sys/class/backlight/intel_backlight/brightness . Changez simplement le chemin si votre ordinateur n'utilise pas le dossier acpi_video0.

Aussi, par @Nick: S'il s'agit de la seule réponse que vous avez lue, notez que le 0 dans echo 0 sera votre paramètre de luminosité par défaut. Je l'avais configuré et cela me rendait fou depuis longtemps: chaque fois que je démarrais, cela le mettrait au réglage de luminosité le plus bas. Je préfère que le mien commence à la luminosité maximale, donc j'ai utilisé echo 10 à la place. La luminosité de votre matériel peut varier.

    
réponse donnée dolhow 17.10.2011 - 15:59
la source
13

Cette fonction, le contrôle de rétro-éclairage, dépend de votre bios et de la version du noyau.

Essayez ces quatre choses.

Options du noyau (démarrage)

Lorsque vous démarrez, à l’écran grub, appuyez sur e pour modifier. Ajoutez à la ligne du noyau nomodeset acpi_backlight=vendor Certains matériels peuvent fonctionner avec des options différentes.

Intel - nomodeset acpi_backlight=intel Acer - acpi_backlight=acer_acpi ou même acpi_osi=Linux acpi_backlight=legacy .

Comme vous pouvez le voir, vous devrez peut-être effectuer une recherche Google pour vos paramètres.

quiet splash nomodeset acpi_backlight=vendor

Si cela fonctionne, éditez /etc/default/grub et ajoutez ces options aux options par défaut.

# command line
sudo -e /etc/default/grub

# graphical
gksu gedit /etc/default/grub

Modifiez la ligne "GRUB_CMDLINE_LINUX_DEFAULT" pour qu'elle ressemble à ceci

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

Enregistrez vos modifications, mettez à jour grub

sudo update-grub

Ligne de commande

Si cela ne fonctionne pas, vous pouvez essayer de régler manuellement la luminosité.

Remarque: Le chemin peut varier en fonction de la version du matériel / du noyau. Il peut s'agir de /proc/acpi/video0 ... , il peut être nécessaire de parcourir le répertoire / proc / acpi pour trouver

cat /proc/acpi/video/VGA/LCD/brightness

La sortie de cette commande varie un peu avec le matériel, 1 - & gt; 10, 1 - & gt; 12, 1 - & gt; 100 ??? Choisissez une valeur et définissez-la (choisissez la valeur de votre matériel).

sudo echo 80 > /proc/acpi/video/VGA/LCD/brightness

Si cela fonctionne, ajoutez-le à /etc/rc.local

# command line
sudo -e /etc/rc.local

# graphical
gksu gedit /etc/rc.local

Ajoutez dans votre configuration ci-dessus "exit 0"

echo 80 > /proc/acpi/video/VGA/LCD/brightness

xbacklight

Vous pouvez également essayer xbacklight

sudo apt-get install xbacklight

Vous ajustez ensuite avec la ligne de commande

# For 80 % brightness
xbacklight -set 80

Encore une fois, ajoutez cela à /etc/rc.local

# command line
sudo -e /etc/rc.local

# graphical
gksu gedit /etc/rc.local

Ajouter, au-dessus de "exit 0"

xbacklight -set 80

setpci

Vous pouvez essayer de régler votre luminosité avec setpci

La syntaxe générale est

sudo setpci -s <address> f4.B=your_setting

Vous identifiez votre adresse de bus PCI avec

sudo lspci | grep VGA

Exemple

00:02.0 VGA compatible controller: Cirrus Logic GD 5446

setpci -s 00:02.0 F4.B=80

Si votre configuration est incorrecte, il est fort probable que vous perdriez simplement votre affichage et que vous deviez redémarrer. Comme il s'agit d'un paramètre matériel, vous devez vraiment identifier votre matériel et rechercher d'abord les paramètres.

Exemples

Intel - lien

Toshiba - lien

Acer extensa - lien

setpci de la page de manuel Ubuntu

    
réponse donnée Panther 21.12.2011 - 23:54
la source
7

Voici une solution rapide à ce problème: -

Essayez de tester le paramètre en tapant cette commande dans le terminal

echo 0 > /sys/class/backlight/acpi_video0/brightness

si la luminosité change au minimum, vous avez raison!

Modifiez le fichier /etc/rc.local en tapant

sudo -H gedit /etc/rc.local    

dans le terminal

Commentez le exit 0 en ajoutant # au début pour qu'il ressemble à ceci: -

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#exit 0

cela est nécessaire sinon ça ne marchera pas!

après cela, ajoutez la ligne suivante dans le fichier

echo 0 > /sys/class/backlight/acpi_video0/brightness

telle qu’elle ressemble à ceci: -

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#exit 0
echo 0 > /sys/class/backlight/acpi_video0/brightness

remplacez 0 par la valeur de luminosité requise (comprise entre 0 et 10)

enregistrez le fichier et quittez.

Redémarrez pour voir les modifications.

Remarque: - vous devrez peut-être remplacer acpi_video0 par le code de votre appareil si vous en avez un différent (il s'agit principalement de acpi_video0 ). La plupart des utilisateurs n'auront pas besoin de le faire.

    
réponse donnée vasishath 16.10.2011 - 11:44
la source
4

Pour régler la luminosité de l'écran en 11.10, vous devrez accéder aux "Paramètres système":

  1. Cliquez avec le bouton droit de la souris directement à droite de votre nom d'utilisateur dans la barre d'outils située dans le coin supérieur droit de votre écran.

  2. Sélectionnez "Paramètres système".

  3. Sélectionnez "Écran".

  4. Faites glisser le curseur avec la souris pour régler la luminosité de l'écran.

Si Ubuntu ne se souvient pas de votre ajustement, vous pouvez utiliser une application ou utiliser la solution de contournement pour GNOME: Paramètre de luminosité non enregistré dans Ubuntu 11.10

    
réponse donnée KaitlinM 24.10.2011 - 04:39
la source
3

Voici un excellent travail autour de ce que j'ai trouvé, crédit et merci à thaelim sur le forum Ubuntu Comment obtenir une gestion efficace de la luminosité de l'écran sous Unity / Gnome Shell : téléchargez le script, éditez les périmètres au début du script et enregistrez-le lorsque vous avez terminé dans votre dossier personnel. Voici le téléchargement du script intégral brightmanager.py

Ce sont les périmètres variables à modifier pour les paramètres souhaités, comme vous pouvez voir que j'aime le mien à 20 tout le temps sans délai d'inactivité.

IDLE_DIM_TIME = 0
IDLE_DIM_AC = False
IDLE_DIM_BATTERY = False
IDLE_BRIGHT = 20
BRIGHT_BATTERY = 20
BRIGHT_AC = 20

Après la sauvegarde, ouvrez un terminal et entrez

chmod +x brightmanager.py

Ouvrez ensuite les applications de démarrage à partir du tableau de bord, cliquez sur le bouton Ajouter, nommez votre application de démarrage et entrez votre commande en tant que:

python /home/david/brightmanager.py

remplacer "david" par le nom de votre dossier personnel, puis ajouter une description et cliquer sur Ajouter, Déconnecter, et de nouveau, et vous avez terminé, vous avez maintenant des paramètres de luminosité pour la batterie, CA et inactif.

Vous souhaiterez le faire pour chaque utilisateur et chaque utilisateur devra avoir sa propre copie du script dans son dossier de base avec ses propres paramètres souhaités au début du script.

    
réponse donnée dginsd 11.11.2012 - 18:24
la source
1

L'option "Écran" de "Paramètres système" fonctionne correctement, et dans /sys/class/backlight/acpi_video0/brightness , l'option change également en conséquence, mais le problème est que rien ne se produit avec la luminosité réelle.

J'ai trouvé la solution à mon problème:

Ajoutez la prochaine option sous votre section "Périphérique" dans /etc/X11/xorg.conf et redémarrez:

Option "RegistryDwords" "EnableBrightnessControl=1"

Cela a fonctionné pour ma carte NVIDIA (Ubuntu 11.10 x64 sur Toshiba Satellite L745-SP4142CL)

    
réponse donnée Jorge 04.04.2012 - 18:44
la source
1
  • Si vous utilisez nVidia, ouvrez simplement dash home et tapez "Paramètres du serveur NVIDIA X".
  • Cliquez ensuite sur "Correction de couleur du serveur X" sous X Screen O.
  • Réduisez le niveau de luminosité.
  • Cliquez sur "Confirmer les modifications en cours" avant la fin du délai imparti.
  • Choisissez Quit pour enregistrer la modification.

Cela a fonctionné pour moi avec les spécifications suivantes:

  • Toshiba Satellite L745
  • Intel Core i3
  • NVidia GeForce avec CUDA
  • RAM 6 Go
réponse donnée Chuaka 13.04.2012 - 20:32
la source
1

Il semble y avoir un rapport de bogue à ce sujet:

lien

Pour moi, cela a fonctionné pour placer:

echo 0 > /sys/class/backlight/acpi_video0/brightness

dans /etc/rc.local.

Ou, comme d’autres l’ont suggéré,

echo 5 > /sys/class/backlight/*/brightness

pourrait fonctionner.

    
réponse donnée duli 29.12.2011 - 23:06
la source
0

J'ai trouvé une solution sur webupd8: Correction de la réinitialisation de la luminosité (à une valeur très faible ou maximale au redémarrage sous Ubuntu

  
  1. La première chose à faire est de savoir quelle interface ACPI (acpi_video) contrôle la luminosité. Cela peut être fait en regardant dans votre fichier journal Xorg pour voir quel acpi_video a été chargé. Pour ce faire, via la ligne de commande, utilisez simplement la commande suivante:

    grep acpi_video /var/log/Xorg.0.log
    
         

    La commande ci-dessus devrait afficher une sortie similaire à celle-ci:

    [     7.385] (--) intel(0): Found backlight control interface
    acpi_videoX (type 'firmware') for output LVDS1
    
         

    acpi_videoX est acpi_video0 ou acpi_video1 . C'est le module acpi_video qui contrôle la luminosité, alors souvenez-vous de cela pour les prochaines étapes.

         

    Si la commande ci-dessus n'affiche aucune sortie et que vous avez un dossier nommé intel_backlight sous /sys/class/backlight/ , utilisez intel_backlight comme interface ACPI pour les étapes suivantes.

  2.   
  3. Ensuite, réglez (via les touches de clavier Fn + luminosité) la luminosité de votre ordinateur portable au niveau que vous souhaitez que Ubuntu utilise après son démarrage.

  4.   
  5. Maintenant, nous devrons obtenir la valeur de luminosité réelle définie à l’étape 2. Pour ce faire, exécutez la commande suivante:

    cat /sys/class/backlight/acpi_videoX/brightness
    
         

    acpi_videoX est l'interface ACPI qui contrôle la luminosité de votre ordinateur portable, que vous avez trouvée à l'étape 1.

         

    N'oubliez pas cette valeur pour l'étape suivante.

  6.   
  7. L'étape suivante consiste à créer un fichier (en tant que root) appelé fixbrightness.conf dans votre répertoire /etc/init/ , par exemple:

    gksu gedit /etc/init/fixbrightness.conf
    
         

    Dans ce fichier, collez ceci:

    description "Sets brightness after graphics device is loaded"
    
    start on graphics-device-added
    
    task
    
    exec /bin/echo BRIGHTNESS_VALUE > /sys/class/backlight/acpi_videoX/brightness
    
         

    ici, vous devez

         
    • remplacez BRIGHTNESS_VALUE par la valeur de luminosité obtenue à l’étape 3

    •   
    • remplacez acpi_videoX par l'interface ACPI qui contrôle la luminosité de votre ordinateur portable, que vous avez découverte à l'étape 1.

    •   

    Enregistrez ensuite le fichier.

  8.   
  9. Redémarrez et le problème de luminosité faible ou maximale après le redémarrage / déconnexion doit être résolu.

  10.   
    
réponse donnée evergreen 05.12.2014 - 17:20
la source
-1

Exécuter

echo 2 > /sys/class/backlight/acpi_video0/brightness

    
réponse donnée Suresh Kumar Pakalapati 20.10.2011 - 15:20
la source

Lire d'autres questions sur les étiquettes