apt-get update très lent, bloqué à "Waiting for headers"

54

J'ai examiné des questions similaires:

Coincé à 0% [en attente d'en-têtes]

apt-get update bloqué sur "Waiting for Headers" lors de l'utilisation de Windows XP ICS

Cependant, aucun d’entre eux ne répond à mon problème.

J'utilise 12.04 AMD64 et j'ai récemment commencé à avoir un problème: lorsque je mets à jour mes mises en pension à partir de ma connexion à domicile via un terminal, en utilisant sudo apt-get update, cela prend une éternité ), mais lorsque je cours depuis un endroit différent, cela prend moins de 5 minutes.

J'ai tenté de changer le miroir que j'utilise mais cela ne résout pas le problème. J'ai également réduit la liste de mes sources, mais cela ne fait aucune différence. Il n'y a pas de défauts sur ma ligne ADSL car j'ai déjà contacté mon FAI pour vérifier cela. Cela ne fait aucune différence si j'utilise une connexion par câble WiFi ou réseau.

Quel pourrait être mon problème?

Un test de vitesse (www.speedtest.net) est en baisse d’environ 0,9 Mbps et 0,42 Mbps (ce qui est une nuance sous la vitesse de ligne annoncée), je réside en Afrique du Sud et utilise le serveur UCT LEG. Mais j'ai aussi essayé les autres miroirs disponibles dans SA… aucun ne fait la différence.

    
posée Liam 27.06.2012 - 11:54
la source

8 réponses

40

Cela peut sembler être un problème avec les mises en pension de tiers. Je sais que le dépôt de Google prend plusieurs minutes pour répondre ici parfois. Si vous avez configuré des mises en attente tierces, ouvrez Update Manager, cliquez sur Paramètres, puis sur l'onglet "Autre logiciel". Décochez toutes les cases, puis appuyez sur Fermer.

Maintenant, lancez un terminal et utilisez la commande suivante pour voir si elle est meilleure avec la commande suivante:

sudo apt-get update

Si c'est mieux, revenez en arrière et activez chaque repo et revérifiez un par un jusqu'à ce que vous trouviez le repo de problème.

Si cela ne fonctionne pas, vous pouvez demander au responsable de la mise à jour de sélectionner les meilleurs référentiels principaux à utiliser automatiquement. Pour ce faire, ouvrez Update Manager, puis cliquez sur Paramètres. Sélectionnez l'onglet Logiciel Ubuntu, puis dans le menu déroulant "Télécharger depuis:", sélectionnez Autre ...

Maintenant, dans la fenêtre qui apparaît, cliquez sur "Select Best Server"

Il effectuera ensuite plusieurs tests pour sélectionner le meilleur serveur pour vous. Une fois terminé, cliquez simplement sur Choisir un serveur.

Maintenant, lancez le terminal et vérifiez à nouveau.

    
réponse donnée reverendj1 28.06.2012 - 16:14
la source
32

J'ai trouvé une solution qui m'a aidé ici: lien

Vous pouvez laisser apt-get régénérer le cache des listes en utilisant:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update 
    
réponse donnée Chronos 24.04.2015 - 11:55
la source
4

Cela est principalement dû à la "taille MTU", ayant ce problème depuis un certain temps et après une inspection approfondie, j'ai découvert que mon ISP avait une taille MTU de 1440 alors que l'interface par défaut était 1500.

pour connaître la taille maximale de MTU, veuillez voir ici .

pour définir la taille de vos paquets MTU, vous pouvez soit utiliser l’option de connexion réseau depuis l’icône réseau, soit utiliser le terminal comme dans ce lien .

    
réponse donnée Eslam Shapsough 06.10.2014 - 00:27
la source
2

J'ai rencontré ce problème sur l'ordinateur portable de quelqu'un d'autre qu'on m'a demandé de mettre à niveau. Après une heure de grattage, l’inspection de / etc / environment a révélé qu’un anon-proxy était installé sur le système. Le supprimer a résolu le problème.

Vérifiez donc vos paramètres de proxy dans / etc / environment

    
réponse donnée Marek T 23.08.2013 - 11:38
la source
1

Si synaptic est installé, essayez de déclencher apt-get update dans synaptic en cliquant sur "Recharger". Bien sûr, cela va également se bloquer, mais quand vous l’annulez, il affichera le nom du référentiel arrêté, par exemple:

Failed to fetch http://debian.sur5r.net/i3/dists/quantal/InRelease  
Some index files failed to download. They have been ignored, or old ones used instead.

Désactiver temporairement les référentiels signalés ici devrait résoudre le problème. Dans synaptic , vous pouvez les désactiver sous "Paramètres - & gt; Autres logiciels".

    
réponse donnée Philipp Claßen 31.12.2012 - 20:01
la source
1

J'ai trouvé cette mise à jour de apt-get bloquée sur "Waiting for Headers" en utilisant Windows XP ICS très perspicace.

Vous souhaiterez peut-être installer et exécuter netselect et copier les sources.list générées dans /etc/apt/sources.list

J'espère que ça aide.

    
réponse donnée Carlos 18.01.2013 - 19:10
la source
0

Parfois, il vous suffit de passer au serveur principal pour les mises à jour. Les mises à jour, selon votre zone géographique, ne proviennent parfois pas des serveurs principaux pour accélérer les livraisons.

Pour quelque raison que ce soit, les serveurs relais ne répondent peut-être pas aussi rapidement que possible à certaines requêtes. Par conséquent, le passage temporaire au serveur principal pour les mises à jour devrait résoudre le problème.

Lorsque vous ouvrez votre logiciel et ses mises à jour, sélectionnez "Serveur principal" dans l’option Télécharger depuis.

Vous devriez être prêt à partir. Passer au serveur principal fonctionne toujours pour moi. :)

    
réponse donnée Rexford 16.10.2014 - 08:39
la source
0

Ouvrez le terminal et tapez:

cd /etc/apt/apt.conf.d/

Maintenant, créez un nouveau fichier sudo nano 99self et tapez:

Acquire::http::Pipeline-Depth "0";
    
réponse donnée Pieter Eikelboom 24.03.2018 - 11:02
la source

Lire d'autres questions sur les étiquettes