Ubuntu prend-il en charge l'USB 3.0?

60

J'ai un disque dur externe de bureau USB 3.0 My Digital 3.0 - 1 To de Western Digital, et je voulais savoir si cela fonctionnerait sur Ubuntu 10.10 Maverick Meerkat.

    
posée sudobash 08.11.2010 - 19:25
la source

10 réponses

60

Oui, Ubuntu prend en charge USB 3.0.

Linux a commencé à supporter l’USB 3.0 dans la version de septembre 2009 du noyau 2.6.31, et Ubuntu 9.10 Karmic Koala était la première version d’Ubuntu à supporter l’USB 3.0.

Dans les versions d'Ubuntu plus anciennes qu'Ubuntu 11.04, Natty Narwhal, il y a un bogue dans le module du noyau XHCI (USB 3.0) qui empêche la suspension: Bogue n ° 522998 .

    
réponse donnée Sid 08.11.2010 - 19:29
la source
11

apparemment, il y a un problème: ( 522998 )

Lorsque le module XHCI est chargé pour une opération USB 3.0, le système ne peut pas être suspendu. Le déchargement manuel de XHCI permettra à la suspension de se terminer normalement.

Pour éviter de futurs problèmes de suspension, la solution consiste à ajouter SUSPEND_MODULES="xhci-hcd" à /etc/pm/config.d/unload_module , le système peut alors être suspendu normalement.

    
réponse donnée hhlp 08.11.2010 - 19:34
la source
5

Oui, ça va. Le noyau actuel prend en charge USB 3.0, vous ne devriez donc pas avoir de problèmes pour utiliser votre disque.

Au fait, linux a été le premier à avoir le support USB 3.0: lien

    
réponse donnée Rafał Cieślak 08.11.2010 - 19:31
la source
2

Il peut être utile de noter que le démarrage USB 3.0 n'est pas encore pris en charge.
Référez-vous à bug 565047 .

    
réponse donnée nik 29.04.2011 - 11:55
la source
1

Oui, il prend en charge usb 3.0 voir le lien ci-dessous, j'ai connecté deux via USB 2.0, il fonctionne parfaitement.USB 3.0 est en panne avec 2.0.Mes ports USB sont 2.0 mais le disque dur est 3.0 compatible.

lien

    
réponse donnée karthick87 08.11.2010 - 19:34
la source
1

J'ai Ubuntu 11.10 en cours d'exécution dans VMware Player 4.0, et après de nombreuses recherches, j'ai trouvé les informations suivantes dans les notes de version de VMware:

  

Le support USB 3.0 est disponible pour les invités Linux exécutant la version 2.6.35 ou ultérieure du noyau (Ubuntu 10.10) via un nouveau contrôleur virtuel xHCI USB. Pour activer cette fonctionnalité, ajoutez la ligne suivante au fichier .vmx: usb_xhci.present="true". N'activez pas cette fonctionnalité pour les invités Windows. Windows n’ayant pas actuellement de pilote générique xHCI, cette fonctionnalité ne fonctionnera pas sous Windows.

Après avoir ajouté cette ligne à mon fichier .vmx, le système détecte maintenant le disque dur USB 3.0 que j'ai branché.

    
réponse donnée lsoutar 17.12.2011 - 15:19
la source
1

Je pense que le problème est lié au matériel et n’a rien à voir avec (k) ubuntu. J'ai un nouveau PC avec 2 ports USB3 configurés pour un double démarrage entre Windoze 7 et Kubuntu 13.10. Les ports fonctionnaient bien sous Windoze mais pas du tout sous Kubuntu.

Parcourir les forums pour trouver une solution Je suis tombé sur la réponse dans un forum Linux Mint (dérivé d'Ubuntu). Apparemment, les ports USB3 internes connectés à l’en-tête de la carte mère ne seront pas reconnus par Linux.

La solution consiste à acheter une carte d'extension PCI-E vers USB 3. J'ai acheté la carte Inateck Superspeed d'Amazon, l'ai branchée dans le connecteur d'extension PCI-E de ma carte mère (DOIT être un emplacement PCI-E, ne fonctionnera pas avec un PCI standard). (Windoze a dû attendre d'avoir installé le pilote fourni).

    
réponse donnée David Broom 18.02.2014 - 03:04
la source
0

Outre les articles ci-dessus, je dois également ajouter que Linux est le premier système d'exploitation à prendre en charge l'USB 3.0 grâce au hacker d'Intel, Sarah Sharp. Ce qui en fait l’une des premières étapes pour faire une petite suggestion sur la manière dont Linux sera dans un proche avenir par rapport aux autres "systèmes".

    
réponse donnée Luis Alvarado 03.01.2011 - 22:26
la source
0

Il semble que le système recherche un lecteur USB 2.0 pendant la séquence de démarrage, même s’il a démarré à partir d’un lecteur USB 3.0. C'est ce que j'ai fait:

J'ai un lecteur Western Digital MyPassport (USB 3.0) et un ordinateur HP Elitebook 8540W avec 2 ports USB 3.0 et 2 ports USB 2.0. Lorsque je démarre à partir d'un port USB 2.0, tout va bien. Lorsque je démarre à partir d'un port USB 3.0, le démarrage démarre, mais s'arrête quelque part au milieu pour signaler une erreur (aucun système actif trouvé ou quelque chose - je peux envoyer le code spécifique si nécessaire)

J'ai donc créé un autre disque dur HD: Lacie 300 Go (USB 2.0 et la même version d'ubuntu: Ubuntu 10.10 i386 (mon PC est un processeur 64 bits, mais j'utilise aussi les disques USB amorçables sur d'autres PC)

Étrange:

Lorsque je connecte le Lacie à un port USB 2.0 ET le Western Digital à un port USB 3.0 EN MÊME TEMPS et que je démarre le PC, je parviens à démarrer à partir d’USB 3.0 (via la séquence de démarrage Bios de mon PC) ) mais j'obtiens le bureau du système qui se trouve sur le lecteur Lacie USB 2.0. J'ai utilisé un arrière-plan de bureau différent pour être sûr à 100% de distinguer les deux systèmes. En dehors du bureau, ils sont identiques.

Donc, je pense que quelque part pendant la séquence de démarrage, le système recherche un lecteur connecté au port USB 2.0 et non celui connecté au port USB 3.0, même s'il a démarré à partir de l'USB 3.0.

    
réponse donnée hvanmunster 16.01.2011 - 11:18
la source
0

eu le même problème. C'était une carte d'expantion. Après une heure de fouillis, je pensais regarder à nouveau la carte à l'intérieur. et bien sûr j'ai oublié de brancher le câble d'alimentation sur la carte. Correction simple.

    
réponse donnée Daniel O'Brien 14.12.2016 - 04:23
la source

Lire d'autres questions sur les étiquettes