Comment restaurer le comportement de combinaison Unity 7 Ctrl-Alt-Numpad sur Gnome 3?

12

Par défaut, au lieu de faire quelque chose d’utile, la combinaison de touches Ctrl-Alt-Numpad dans Gnome 3 déplace une fenêtre dans la direction spécifiée sur l’ensemble de l’espace de travail. Ces raccourcis n'apparaissent pas dans le panneau de configuration du clavier de Gnome 3; ils sont juste là et ils sont sur le chemin.

Comment puis-je récupérer ce comportement dans Ubuntu 17.10?

    
posée badp 17.08.2017 - 19:09
la source

2 réponses

8

J'ai essayé d’installer l’extension gnome de Put Windows sur Ubuntu 17.10, et cela semble fonctionner. bien.

  1. Installez le plug-in de navigateur pour lien
  2. sudo apt-get install chrome-gnome-shell
  3. Visitez la page Windows et installez l’extension
  4. Actualiser la page
  5. Cliquez sur le symbole bleu de la clé / du tournevis sur la page
  6. Allez dans "Raccourcis clavier" et modifiez les actions en Ctrl + Alt + 9, etc.

J'ai d'abord suivi les instructions de l'utilisateur3325563 sur la façon de désactiver les raccourcis "déplacer vers le coin" avec dconf- éditeur. Je ne sais pas si c'est une étape nécessaire ou non.

Vous avez mentionné dans une version de votre question que vous aviez essayé cette extension et après avoir redémarré l'ordinateur, vous deviez reconfigurer manuellement les raccourcis. J'ai testé le redémarrage de ma machine sans avoir de tels problèmes.

    
réponse donnée tttppp 01.11.2017 - 17:40
la source
6

J'ai compris, vous devez changer les paramètres en utilisant dconf:

Dans dconf, recherchez org & gt; desktop & gt; wm & gt; keybindings et cliquez sur le champ à côté de move-to-corner-se et changez-le en ['disabled'] :

et répétez pour tous ceux que vous souhaitez désactiver, c’est-à-dire move-to-corner-sw , etc.

Sinon, vous pouvez le faire depuis la ligne de commande comme ceci: gsettings set org.gnome.desktop.wm.keybindings move-to-corner-se "['disabled']" et le restaurer comme ceci: gsettings set org.gnome.desktop.wm.keybindings move-to-corner-se "['<Primary><Alt>KP_Next']"

Voir aussi org.gnome.desktop.wm.keybindings dans lien

  

org.gnome.desktop.wm.keybindings

  

Les raccourcis clavier gérés par le gestionnaire de fenêtres sont conservés dans la section org.gnome.desktop.wm.keybindings de dconf. Les catégories de raccourcis "Navigation" et "Windows" sont stockées ici. Dans le passé, chaque gestionnaire de fenêtres était chargé de stocker ses propres raccourcis sous son propre schéma. Les gestionnaires de fenêtres metacity et compiz utilisent désormais cet ensemble de liaisons central et unifié. Il existe des fichiers de mappage dans / usr / share / gnome-control-center / keybindings / qui montrent comment ces raccourcis clavier sont utilisés par chaque gestionnaire de fenêtres.

Si vous utilisez encore compiz d’une manière ou d’une autre avec gnome3, voyez ci-dessous:

De ici , j'ai pu désactiver les clés de mon ordinateur portable Ubuntu 16.04 (unité 7.4.0). Les étapes ci-dessous sont ce que vous recherchez.

  

Avertissement

  

CompizConfig Settings Manager ( ccsm ) est un outil avancé, et toutes ses options ne sont pas entièrement compatibles avec Unity.   En tant que tel, CCSM a été connu pour parfois casser les utilisateurs   ordinateurs de bureau . Veuillez faire preuve de prudence et   sachez que vous prenez un risque en suivant cette réponse ou tout autre   réponse qui recommande l'utilisation de CCSM. Dans le cas où suite   ce conseil ne fonctionne pas, s'il vous plaît voir cette   question pour savoir comment   pour le réinitialiser.

Vous devez installer compizconfig-settings-manager , sous le logiciel Ubuntu:

exécutez-le et sous la section "Gestion des fenêtres" sélectionnez "Grille":

Dans le menu de la grille, cliquez sur le crayon d’édition et décochez la case "Activer":

    
réponse donnée user3325563 23.08.2017 - 18:39
la source

Lire d'autres questions sur les étiquettes