Puis-je désactiver updatedb.mlocate?

57

Sur le serveur Ubuntu ici et j'essaye de décompresser les fichiers image 300M à partir d'un format de fichier compressé utilisant Java.

Mon taux de décompression est de 0,5 Mo / s, abyssal (34 jours pour décompresser 1,5 To à ce rythme).

J'essaie de comprendre pourquoi, et la seule curiosité que je remarque est que updatedb.mlocate fonctionne toujours lorsque je fais le processus de décompression. Je veux l'éteindre pour voir si cela fait obstacle, mais je ne comprends pas grand chose de ce que c'est.

top

top - 05:16:52 up 1 day,  5:15,  3 users,  load average: 2.00, 2.01, 1.83
Tasks:  83 total,   1 running,  82 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.4%us,  0.8%sy,  0.0%ni,  8.4%id, 90.2%wa,  0.0%hi,  0.0%si,  0.2%st
Mem:   1737420k total,  1722680k used,    14740k free,  1241260k buffers
Swap:   917500k total,      160k used,   917340k free,   165448k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
22901 davidpar  20   0 1051m  56m 4992 S    3  3.3   0:47.84 java
 2221 root      20   0 32348  26m  268 D    1  1.6  27:57.86 updatedb.mlocat
   25 root      20   0     0    0    0 S    0  0.0  10:10.77 kswapd0
  678 root      20   0 15864  444  268 S    0  0.0   0:19.45 irqbalance
  849 davidpar  20   0 26560 1676  332 S    0  0.1  17:17.49 screen

iotop

Total DISK READ: 4.07 M/s | Total DISK WRITE: 789.62 K/s
  TID  PRIO  USER     DISK READ  DISK WRITE  SWAPIN     IO>    COMMAND
 2221 idle root     1556.98 K/s    6.36 K/s  0.00 % 99.61 % updatedb.mlocate
22902 be/4 davidpar    2.54 M/s  671.93 K/s  0.00 % 96.96 % java -cp /home/davidparks21/fruggutils/lib/FruggMapreduceJobs.~educe.UnpackImages /mnt/local/imagebinaries-r-00010 /mnt/ebs1/
  547 be/3 root        0.00 B/s   87.47 K/s  0.00 %  0.30 % [jbd2/xvdf-8]
  177 be/3 root        0.00 B/s    3.98 K/s  0.00 %  0.15 % [jbd2/xvda1-8]
    
posée David Parks 15.03.2013 - 13:18
la source

3 réponses

60

Il peut être tué avec:

sudo killall updatedb.mlocate

Ou:

sudo kill -9 <PID>

Il tourne tous les jours par cron. Désactivez-le avec:

sudo chmod -x /etc/cron.daily/mlocate

Et si vous voulez le réactiver:

sudo chmod +x /etc/cron.daily/mlocate
    
réponse donnée Eric Carvalho 15.03.2013 - 13:51
la source
16

Je ne voulais pas éliminer totalement le processus, mais je voulais que cela se produise moins fréquemment, alors j'ai trouvé comment le faire fonctionner chaque semaine plutôt que chaque jour. Ceci est basé sur la réponse acceptée ci-dessus , mais il est probablement préférable de la répertorier comme sa propre réponse car elle ne la désactive pas.

Cela dit ... C'est plutôt simple et semble fonctionner correctement.

sudo chmod -x /etc/cron.daily/mlocate
sudo cp /etc/cron.daily/mlocate /etc/cron.weekly/mlocate
sudo chmod +x /etc/cron.weekly/mlocate

Le premier désactive le job cron. Le second le déplace vers les tâches hebdomadaires. La troisième commande définit les autorisations pour qu'elle soit activée. Toutes les options sont quotidiennes, horaires, hebdomadaires et mensuelles.

    
réponse donnée KGIII 20.12.2015 - 14:03
la source
9

Je n'ai jamais utilisé locate , alors je l'ai enlevé. sudo dpkg -P mlocate Voir aussi: lien

    
réponse donnée ant-san 10.08.2015 - 18:03
la source

Lire d'autres questions sur les étiquettes