Gnome 3.16 La mise à l'échelle HiDPI n'accepte que les entiers

13

J'ai récemment mis à niveau vers Ubuntu 15.04 avec Gnome 3.16, qui fonctionne très bien sur ma machine (malgré ce que j'ai trouvé sur de nombreux forums sur le Web). Ayant un écran PPP élevé (13.3 "avec 1920x1080), je dois mettre à l'échelle l'ensemble du système pour l'utiliser. Il y a un paramètre pour cela dans TweakTool, mais il semble accepter uniquement les entiers comme facteur d'échelle.

Quelqu'un connaît-il une solution de contournement pour cela? La mise à l'échelle par deux est beaucoup trop grande pour mon écran. La valeur que je veux est plus proche de 1,2

Toute aide sera grandement appréciée!

    
posée Severin 21.05.2015 - 08:53
la source

3 réponses

0

J'ai vérifié avec l'installation de Fedora 21 où se trouve Gnome 3.14.2 et il ne semble pas possible de définir la valeur souhaitée:

[[email protected] ~]$ gsettings set org.gnome.desktop.interface scaling-factor 1.2
invalid character in number:
  1.2
   ^
[[email protected] ~]$ gsettings set org.gnome.desktop.interface scaling-factor 1,2
expected end of input:
  1,2
   ^

Mes hypothèses:

  • Il y a un autre paramètre pour réaliser ce que vous voulez. La seule chose qui me vient à l'esprit est le rendu des polices, bien que ce ne soit pas exactement ce que vous recherchez.
  • C'est une erreur que la clé accepte uniquement des entiers comme type de données et que vous devez déposer un bogue.
réponse donnée LiveWireBT 21.05.2015 - 09:25
la source
0

Je ne sais pas si cela a été résolu ou non, mais Gnome dispose de deux options de dimensionnement pour y parvenir. L'attribut "window scaling" que vous utilisez accepte 1 ou 2 (ou 0, mais ceci est "indéfini" je pense). Si vous le souhaitez, vous pouvez effectuer la mise à l'échelle du texte, qui accepte les nombres flottants.

Dans Gnome Tweak Tool, il est disponible sous la section police. Alternativement, vous pouvez accéder à tous les deux dans l'éditeur dconf sous org.gnome.desktop.interface . J'ai remarqué que cette option fonctionnait mieux, car Gnome Tweak Tool peut parfois ne pas mettre à jour correctement les paramètres, entraînant des problèmes de mise à l'échelle bizarres.     

réponse donnée Mylan Connolly 31.05.2015 - 18:44
la source
-1

La mise à l’échelle non entière n’est pas (encore) prise en charge par Gnome et donc par Ubuntu. Bien qu'il soit possible de réaliser avec certaines solutions de contournement utilisant xrandr, qui implique une mise à niveau et une réduction d'échelle ultérieure, je ne peux pas le recommander car il est très gourmand en CPU / GPU et s'accompagne d'autres problèmes. . Il y a beaucoup de débats en cours et des arguments sur r / linux sur reddit si cela vous intéresse et voici aussi un article de l'un des devs élémentaires (une distribution basée sur Ubuntu) qui parle un peu plus en profondeur du DPI élevé: lien . J'espère que cela aide un peu.

    
réponse donnée Wiggles 10.08.2018 - 15:26
la source

Lire d'autres questions sur les étiquettes