Comment désactiver baloo dans KDE 4.13?

52

J'ai Kubuntu 14.04 et je viens d'installer les dernières mises à jour. En regardant la liste des processus, je vois baloo indexer en cours d'exécution.

Je n'ai pas trouvé de case à cocher dans les paramètres de Baloo pour désactiver l'indexation.

    
posée warvariuc 22.03.2014 - 06:35
la source

8 réponses

23

Vous pouvez demander à votre gestionnaire de fichiers d’afficher des fichiers cachés, puis de passer à $HOME/.kde/share/config/baloofilerc . Il suffit de l’éditer et de changer d’option

Indexing-Enabled=true 

à (ou ajoutez s'il n'y a pas une telle option)

Indexing-Enabled=false

désactiver le baloo.

Je sais que c'est trop facile mais ça a fonctionné pour moi et aussi pour le gars qui a posté cette solution simple page .

Désactiver le serveur Akonadi et le plug-in de recherche Nepomuk peuvent considérablement améliorer les performances dans un environnement KDE.

    
réponse donnée Taz D. 23.04.2014 - 18:27
la source
15

Baloo est responsable de la recherche sur le bureau.

Citant l’un des auteurs de Baloo :

  

Il n'y a plus de bouton "Activer / Désactiver" explicite. Nous voudrions   pour promouvoir l'utilisation de la recherche et sentir que Baloo ne devrait jamais avoir   à la manière des utilisateurs. Cependant, nous sommes intelligents et si vous ajoutez votre   Répertoire HOME à la liste des "dossiers exclus", Baloo changera   lui-même éteint puisqu'il n'a plus rien à indexer.

    
réponse donnée warvariuc 22.03.2014 - 06:35
la source
13

À partir du forum Gentoo: lien

Depuis KDE 4.13.0 (Kubuntu Trusty), il n’est plus possible de désactiver le bureau sémantique dans l’interface graphique. Bien qu'il y ait une applet "Desktop Search" dans les paramètres système, et que vous devriez pouvoir y mettre votre répertoire personnel sur la liste noire, cela n'a aucun effet et Baloo (qui a pris le relais de Nepomuk / Strigi) continue charge de mémoire et multi-gigaoctets utilisés sur le cœur du processeur dans lequel il s'exécute.

Vous pouvez vérifier la charge du processeur sur votre système en utilisant 'top':

top

Vérifiez la charge d’E / S sur votre système avec 'iotop':

sudo apt-get install iotop
sudo iotop

Pour définitivement désactiver baloo, créez un lien symbolique vers / bin / true:

sudo mv /usr/bin/baloo_file_extractor /usr/bin/baloo_file_extractor.orig
sudo ln -s /bin/true /usr/bin/baloo_file_extractor

et

sudo mv /usr/bin/baloo_file_cleaner /usr/bin/baloo_file_cleaner.orig
sudo ln -s /bin/true /usr/bin/baloo_file_cleaner

Cela l'empêchera de fonctionner à nouveau. Cela perdrait bien sûr la fonctionnalité de recherche, mais ne semble pas avoir d’effets négatifs au-delà de cela.

    
réponse donnée fman 19.04.2014 - 12:10
la source
9

Pour éviter de modifier manuellement $HOME/.kde/share/config/baloofilerc , cela fait la même chose pour vous:

kwriteconfig --file baloofilerc --group 'Basic Settings' --key 'Indexing-Enabled' false
    
réponse donnée warvariuc 06.05.2014 - 07:21
la source
6

Je ne l'ai pas encore essayé, mais apparemment , vous pouvez aussi le faire

$ cp /usr/share/autostart/baloo_file.desktop ~/.kde/share/autostart/
$ echo "Hidden=True" >> ~/.kde/share/autostart/baloo_file.desktop

(J'avais mon dossier personnel dans la section "ne pas chercher", probablement de nepomuk, et baloo_file utilisait toujours 100% d'un noyau.)

    
réponse donnée Sparhawk 05.04.2014 - 16:15
la source
3

L'ajout de $ HOME à la liste des chemins exclus excluait le baloo_file_extractor, qui utilisait 100% du processeur. Cependant, il a alors lancé baloo_file_cleaner qui détruisait mon disque dur.

S'assurer qu'il ne démarre pas automatiquement, semblait résoudre le problème:

sudo mv /usr/share/autostart/baloo_file.desktop /usr/share/autostart/baloo_file.desktop.orig
    
réponse donnée bcmpinc 19.04.2014 - 12:55
la source
3

Bien qu’il existe plusieurs moyens d’empêcher Baloo de indexer , mon intention est d’empêcher Baloo de lancer . Conformément à la documentation de KDE , il n’ya pas de moyen accessible à l’utilisateur pour le faire, alors j’ai combiné une solution trouvée sur les forums KDE avec < a href="https://askubuntu.com/a/450492/23087"> solution utilisateur à désactiver les exécutables :

sudo mv /usr/bin/baloo_file /usr/bin/baloo_file-orig
sudo ln -s /bin/true /usr/bin/baloo_file
sudo mv /usr/bin/baloo_file_cleaner /usr/bin/baloo_file_cleaner-orig
sudo ln -s /bin/true /usr/bin/baloo_file_cleaner
sudo mv /usr/bin/baloo_file_extractor /usr/bin/baloo_file_extractor-orig
sudo ln -s /bin/true /usr/bin/baloo_file_extractor

Je vais ensuite plus loin et je vérifie que baloo ne peut pas être mis à jour, remplaçant les liens symboliques ci-dessus:

$ sudo apt-mark hold  baloo libbaloocore4 libbaloofiles4 libbaloopim4 libbaloowidgets4 libbalooxapian4
$ sudo apt-get remove baloo

Pour une assurance supplémentaire, si le processus baloo trouve toujours le chemin du retour, ajoutez ce qui suit à ~/.kde/share/config/baloofilerc :

[Basic Settings]
Indexing-Enabled=false
    
réponse donnée dotancohen 04.12.2014 - 07:44
la source
1

Un post dans les forums KDE par Aaron Seigo suggère:

qdbus org.kde.baloo.file /indexer suspend

Le message est situé ici: lien

Utilisez ce qui suit pour reprendre:

qdbus org.kde.baloo.file /indexer resume

Utiliser ce qui suit pour vérifier que baloo est suspendu ou non:

qdbus org.kde.baloo.file /indexer isSuspended

ASTUCE : lorsque je tape qdbus org.kde.baloo.file /indexer et que vous appuyez plusieurs fois sur Tab dans Kubuntu 14.04 avec l'activation de bash-complété (généralement activée par défaut) commandes pour baloo.

    
réponse donnée Vangelis Tasoulas 23.04.2014 - 01:27
la source

Lire d'autres questions sur les étiquettes