Comment résoudre mes "icônes de chargement" dans compizconfig lors du chargement d'Ubuntu 14.04 sur Virtualbox?

10

Je suis en train de parcourir le post à propos de unity-doesnt-load -no-launcher-no-dash-apparaît pour que mon 14.04.1 soit chargé sur VirtualBox.

Je suis arrivé à l’étape où j’exécute ccsm , mais il reste sur "Loading Icons ...", comme illustré ici:

ccsm
compizconfig - Info: Backend     : ini
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : default
Loading icons...

Des idées sur la façon de le décrocher?

    
posée knuckles 11.12.2014 - 02:07
la source

2 réponses

0

Vérifiez d'abord que vous essayez d'exécuter ccsm avec export DISPLAY=:0 ccsm ou que vous exportez correctement l'affichage cible.

Si se bloque encore pendant le chargement, abandonnez ( Ctrl + C ) , accédez à GUI avec Ctrl + Alt + F7 et essayez d'appuyer sur Alt + F2 pour obtenir le shell unity , s'il fonctionne, tapez unity et appuyez sur Entrée.

Si cela ne fonctionne pas, toujours à partir de l'interface graphique ( tty7 ) , essayez d'ouvrir un terminal avec Ctrl + Alt + T . Vous pouvez également cliquer avec le bouton droit de la souris sur le bureau et sélectionner l'option "Ouvrir le terminal ici". Si l'un des cas ci-dessus fonctionne, essayez de générer unity sur votre terminal, cela devrait démarrer / redémarrer la session shell d'unité.

Si l'un des éléments ci-dessus a fonctionné, appuyez sur Ctrl + Alt + F1 pour accéder à tty1 et essayez d'exécuter unity à partir de là. Si ne lance toujours pas une session d'unité, essayez ce qui suit:

dconf reset -f /org/compiz/

unity --reset-icons &disown

Enfin, après avoir accédé à votre session, accédez à Gestionnaire de paramètres de configuration de Compiz et vérifiez que le plug-in Unity est activé, etc. Fermer ccsm . Redémarrez.

J'espère que ça aide.

    
réponse donnée dgonzalez 27.12.2016 - 03:58
la source
0

ccsm ne semble pas détecter correctement votre session en cours. Votre sortie:

Backend     : ini
Profile     : default

où il devrait être:

Backend     : gsettings
Profile     : unity

Voir /etc/compizconfig/config

  1. Vérifiez la variable d'environnement de session en cours

    env | grep -i session

    DESKTOP_SESSION=ubuntu
    JOB=gnome-session
    GDMSESSION=ubuntu
    SESSIONTYPE=gnome-session
    
  2. S'ils ont tort: ​​

    • Déconnexion puis connexion avec la session correcte
    • Ou réinstallez sudo apt-get install --reinstall ubuntu-session , déconnexion / connexion
    • Ou définissez ces variables manuellement, puis exécutez ccsm

      export DESKTOP_SESSION=ubuntu
      export GDMSESSION=ubuntu
      
      ccsm
      
      ## you can try also
      compiz --replace
      ## or
      unity
      

Si elles sont correctes, faites le moi savoir pour chercher une autre idée.

    
réponse donnée user.dz 27.12.2016 - 10:32
la source

Lire d'autres questions sur les étiquettes