Skype et VLC semblent grésiller / distordus / mauvais

51

J'ai le même problème que décrit dans les questions les sons de notification Skype grésillent et mauvais son lors de la connexion à skype . Mais ce n'est pas seulement la connexion, la notification, mais aussi lorsque vous parlez à quelqu'un. J'ai essayé la solution pour supprimer / réinstaller Skype et la plupart des solutions dans cette question, par exemple vérification du mixeur, réglages du son et installation de alsa-hda-dkms (y compris le redémarrage du système).
Après l'installation de skype (et même après la mise à niveau vers skype 4.0) dans Ubuntu 12.04 (AMD 64), il n'y avait aucun son. J'ai suivi la première étape de la procédure de résolution des problèmes sonores et au moins, il y a maintenant du son:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-'uname -r' libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-'uname -r' libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG 'cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print }' | tr '\n' ',' | sed 's:,$::g'' 'whoami'

Le son instable disparaît parfois, par ex. sur l'écho-test après avoir rejoué la partie enregistrée. Et j'ai remarqué que si je laissais jouer de la musique dans le rythme, puis lancer Skype, le son est correct. J'ai donc une solution faible, mais je serais heureux que cela fonctionne sans ce détour.

Dans VLC, lorsque je joue, redémarrer après une pause, je dois avoir le même son tremblant.

Sur demande: ma carte son est un "périphérique audio haute définition AMD" appelé contrôleur Hudson Azalia (rev01) de type Advanced Micro Devices (AMD), sous-système Lenovo Device 21ea (selon sysinfo) sur un Lenovo Thinkpad Edge 525.

    
posée Filbuntu 30.06.2012 - 09:03
la source

9 réponses

92

Ce n’est pas seulement un problème avec Skype, je pense que c’est un problème avec, vous l’avez deviné, PulseAudio.

Solution de contournement? En effet il y en a.

La désactivation de PulseAudio Glitch Free Audio semble avoir résolu le problème pour moi (qui est devenu insupportable sur Ubuntu 12.10 Beta 2)

Pour ce faire, modifiez le fichier /etc/pulse/default.pa dans votre éditeur de texte préféré.

Recherchez la ligne suivante:

load-module module-hal-detect

et ajoutez " tsched=0 " à la fin:

load-module module-hal-detect tsched=0

redémarrer l'impulsion (ou simplement redémarrer votre système), et le craquement devrait avoir disparu.

Je ne sais pas quels sont les effets secondaires en désactivant Glitch Free Audio, mais je n'arrive pas à en trouver.

MISE À JOUR: Si vous n'avez pas de ligne avec load-module module-hal-detect , recherchez la ligne suivante:

load-module module-udev-detect  

et ajoutez " tsched=0 " à la fin:

load-module module-udev-detect tsched=0

redémarrer l'impulsion (ou simplement redémarrer votre système), et le craquement devrait avoir disparu.

    
réponse donnée Robert Ian Hawdon 16.10.2012 - 16:28
la source
3

Si vous soupçonnez que vous rencontrez des problèmes avec pulseaudio, il pourrait y avoir une solution plus facile pour vous. J'ai posté un article avec des instructions étape par étape sur mon blog sur comment réparer un mauvais son dans Ubuntu . C'est un correctif pour Wine, mais comme il s'agit d'une modification d'un fichier de configuration pulseaudio, il peut être applicable à d'autres problèmes similaires.

    
réponse donnée Seven_Six_Two 11.07.2012 - 16:28
la source
3

La solution fournie ci-dessus par Robert a fonctionné pour moi. J'avais mis à jour vers 12.10 ubuntu et la nouvelle mise à niveau de skype 4.0 avait un son inutilisable (rayé et déformé). l'édition selon les instructions ci-dessus et en ajoutant la ligne suivante à: load-module module-hal-detect tsched = 0 dans le fichier /etc/pulse/default.pa a parfaitement résolu le problème.

Par souci de clarté, la mise à niveau vers la version 12.10 a entraîné l'échec de la reconnaissance de ma carte Soundblaster. Pour une raison quelconque, il était maintenant impossible de penser que ma carte graphique NVIDIA était la carte son par défaut. Skype commencerait par rendre aucun son .
Cela peut être corrigé en suivant les instructions dans le post des forums Ubuntu par billesboelle le 27 juillet 2008. Ici répété pour l'inclusivité: Je ne peux pas obtenir Ubuntu pour sélectionner par défaut la carte PCI, après avoir essayé les paramètres du guide complet soundprob comme ci-dessous:
Il semble que la fonction index = 0 ne veut pas m'aider. Peut-être que c'est dû au fait que ma machine enregistre 2 pilotes sonores avec le même nom? cat /proc/asound/modules donne cette réponse:

0 snd_hda_intel  
1 snd_hda_intel  
2 snd_cmipci  

Des idées ou quelque chose que vous voulez voir avant de pouvoir m'aider. Btw, j'ai oublié de mentionner. Si j'essaie l'option d'index, mon pci peut être supprimé de aplay -l et de cat / proc / asound / modules.

Configuration des cartes son par défaut / arrêt de plusieurs cartes son de la commutation Remarque: cette section suppose que vous avez correctement installé chaque carte son.

Dans un shell, tapez

    cat /proc/asound/modules 

Cela donnera le nom et l'index de chaque carte son que vous avez actuellement. Notez les noms et décidez lequel vous voulez être la carte par défaut.

Maintenant, tapez

    sudo nano /etc/modprobe.d/alsa-base

À la toute fin du fichier, ajoutez ce qui suit (en supposant que vous ayez 3 cartes avec les noms de module A, B et C et que vous voulez les avoir dans l’ordre CAB)

options snd-C index=0  
options snd-A index=1  
options snd-B index=2
    
réponse donnée Coop999 23.11.2012 - 16:39
la source
2

Correctif pour ubuntu 16.04

sudo vim /etc/pulse/daemon.conf find default-fragment-size-msec , dans mon cas il était désactivé, donc supprimez ; au début de la ligne, il devrait donc ressembler à default-fragment-size-msec = 5 (j'ai remplacé la valeur par défaut 25 par 5 ). Ensuite, tuez le service pulseaudio --kill et ubuntu redémarrera pulseaudio, si cela n'a pas eu lieu, redémarrez simplement le système.

Maintenant, je peux entendre la voix de Skype très clairement.

    
réponse donnée Viktor 26.02.2018 - 22:31
la source
1

J'ai eu le même problème sur Archlinux. Il s'est avéré que pulseaudio causait cela. Se débarrasser de pulseaudio restauré un son clair dans Skype pour moi. Pour les distributions basées sur Gnome comme Ubuntu sur la ligne principale, il est probablement impossible de supprimer pulseaudio car c'est une dépendance pour la plupart des fichiers gnome, y compris gdm, mais sur kubuntu, xubuntu et lubuntu, cela peut fonctionner et le gnome bloatware, et s’il est installé, il est fort probable qu’il s’agisse d’une dépendance pour un autre paquet qui dépend de gnome ou de ses bibliothèques.

    
réponse donnée ccpizza 30.06.2012 - 10:00
la source
1

Je viens de supprimer pulseaudio d'ubuntu 12.04 sur mon toshiba p875-s7200 et il a corrigé joliment Skype! le son est passé de la merde à génial :) note: j'ai dû installer alsa-hda-dkms pour obtenir du son sur cet ordinateur portable

    
réponse donnée dave 13.07.2012 - 01:31
la source
0

Cela a fonctionné pour moi, Ubuntu 12.10 / 64, mb asus m4a785tdv-evo amd64 (audio VIA VT1708S)

édité le /etc/pulse/default.pa ( sudo pico /etc/pulse/default.pa )

n'a pas pu trouver load-module module-hal-detect

donc je viens d'éditer la ligne load-module module-udev-detect , pour avoir:

load-module module-udev-detect tsched=0

sauvegardé les modifications et redémarré le système. Maintenant, Skype semble bien. Jusqu'à présent, j'avais des problèmes pour utiliser Skype avec des craquements / échos / bruits qui parfois ajustaient / s'arrêtaient pendant la conversation (parfois corrigés lors de la fermeture du navigateur Web) mais parfois continuaient à compromettre gravement la conversation. Skype était apparemment la seule situation avec des problèmes audio pour moi.

    
réponse donnée user119773 08.01.2013 - 18:55
la source
0

Aucune des solutions affichées jusqu’à présent n’a fonctionné pour moi le 14.04, mais la définition du module audio sur alsa dans Preferences- & gt; Audio- & gt; Output a été corrigée sur vlc.

    
réponse donnée Chiel ten Brinke 28.03.2015 - 19:50
la source
-4

Vous devriez vérifier votre connexion Internet ( lien pour un test de vitesse).

En outre, comme cela fonctionne après RyhthmBox, vous pouvez également essayer de mettre à jour les pilotes (pour la carte son).

Cela pourrait aussi aider d'autres répondeurs si vous nous avez dit quel type de carte son vous avez sur votre ordinateur.

    
réponse donnée Farid 30.06.2012 - 09:08
la source

Lire d'autres questions sur les étiquettes