Comment désactiver le comportement Alt-Hotkey sur le terminal gnome?

55

Ce n’est pas juste un terminal gnome, mais à peu près toutes les fenêtres gnome: lorsque vous maintenez la touche "alt" enfoncée, vous pouvez appuyer sur la première lettre d’un des éléments du menu. Cela vous permettra de faire défiler ce menu sans cliquer dessus directement.

C'est correct sur toute autre fenêtre, comme disons Firefox, mais sur le terminal gnome, il vole les clés que j'utilise pour emacs !! Il y a très peu de chance que j'apprenne un nouvel ensemble de combinaisons de touches si je peux éviter.

Si je ne peux pas isoler cela juste pour le terminal gnome, je suis d'accord avec ça.

    
posée farleyknight 13.03.2011 - 21:48
la source

5 réponses

53

Modifier & gt; Raccourcis clavier ... et décochez l'option "Activer les touches d'accès au menu".

    
réponse donnée geekosaur 13.03.2011 - 22:01
la source
4

Pour le terminal Gnome 3.14.1: Cliquez sur Modifier (dans la barre de menus) & gt; Préférences & gt; Enfin, sur l'onglet "Général", décochez "Activer les mnémoniques ...".

    
réponse donnée Santropedro 10.01.2016 - 02:16
la source
3

Cela me rend vraiment fou. Je voudrais utiliser Alt-V pour coller car il est beaucoup plus ergonomique que d'utiliser CTRL mais cela ne semble pas possible à cause de l'option de menu Affichage.

Dans l’ensemble, cela semble être un bogue car lorsque je désactive les raccourcis clavier dans les Préférences, je ne peux plus utiliser Alt-V pour accéder au menu Affichage, mais je ne peux pas non plus utiliser cette combinaison pour d’autres choses.

J'ai pu faire fonctionner Alt-Z car il n'y a pas de menu commençant par Z.

    
réponse donnée Fonnae 25.03.2013 - 13:13
la source
3

Si vous voulez le faire globalement, vous pouvez essayer cette méthode ( source ):

  

Pour désactiver les mnémoniques, vous devez créer (s’il n’existe pas déjà) ~ / .gtkrc-2.0.   Ce fichier doit contenir la ligne gtk-enable-mnemonics = 0 (vous pouvez   ajoutez d'autres paramètres GTK si vous le souhaitez). Ensuite, redémarrez pour les modifications   pour prendre effet (vous pourrez peut-être vous déconnecter puis vous connecter à la place).

     

La touche alt fera toujours apparaître les menus dans certains cas, mais la   Les mnémoniques sont maintenant désactivées. Hoorah!

EDIT: cette méthode ne fonctionne plus. J'ai déposé un rapport de bogue sur la question du programme d'exploitation afin que nous puissions voir son évolution.

    
réponse donnée metakermit 01.02.2013 - 23:10
la source
2

Dans Ubuntu 16.04, allez dans Paramètres système - & gt; Clavier - & gt; Raccourcis - & gt; Les lanceurs et désactivez la touche pour afficher le HUD (ou changez-la en une autre)

    
réponse donnée Peter 01.07.2016 - 06:17
la source

Lire d'autres questions sur les étiquettes