GNOME Mplayer: "Impossible d'ouvrir VDPAU backend libvdpau_nvidia.so" erreur

10

En utilisant GNOME Mplayer chaque fois que je lis une vidéo, j'obtiens la boîte de dialogue ennuyeuse dans la capture d'écran ci-dessous.

    
posée ok comp 16.11.2010 - 11:08
la source

10 réponses

7

J'utilise le pilote NVIDIA propriétaire et j'ai corrigé cela en créant un lien symbolique vers la librairie VDPAU:

ln -s /usr/lib/vdpau/libvdpau_nvidia.so.1 /usr/lib/libvdpau_nvidia.so

Cela présente l'avantage d'activer VDPAU plutôt que de revenir à XV ou X11. Bien sûr, vous avez besoin d'une carte vidéo prenant en charge l'accélération VDPAU.

    
réponse donnée exo_cw 24.10.2011 - 20:47
la source
4

Vous pouvez supprimer tous les dialogues de ce type dans les variantes de mplayer en éditant ~/.mplayer/config dans l'éditeur de votre choix et quelque part dans le fichier, y compris really-quiet="1" . J'utilise mplayer ordinaire (pas d'interface graphique du tout) mais cela ne devrait pas changer les choses, cela a aussi fonctionné pour moi dans GMplayer. Voici ma configuration:

[default]
vo=vdpau,xv,
vc=ffh264vdpau,ffmpeg12vdpau,

ao=pulse
really-quiet="1"
fs=1
xineramascreen=1
msglevel=all=0
showsubtitles=0

Vous ne voulez probablement pas les lignes vo et vc (je suis un utilisateur Nvidia) et vous ne voudrez peut-être aucun des autres paramètres. Si j'étais toi, je voudrais juste utiliser ceci:

[default]
ao=pulse
really-quiet="1"
    
réponse donnée Oli 16.11.2010 - 11:35
la source
2

Pour Intel VGA et x64, je l’ai résolu avec

sudo apt-get install i965-va-driver
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install libvdpau-va-gl1
cd /usr/lib/x86_64-linux-gnu/vdpau/
sudo ln -s libvdpau_va_gl.so.1 libvdpau_i965.so.1

Pour Nvidia, le paquet est

sudo apt-get install libvdpau1 vdpau-va-driver
    
réponse donnée Temak 06.03.2015 - 14:56
la source
2

Voici la solution à votre problème:

Essayez simplement de spécifier un pilote de sortie vidéo sur la ligne de commande lorsque vous lancez mplayer comme ceci:

mplayer -vo xv video.wmv

Vous pouvez obtenir la liste des "pilotes de sortie vidéo disponibles" avec la commande mplayer -vo help .

Le problème est que le pilote de sortie vidéo sélectionné (ou par défaut) était vdpau, et que personne ne travaillant sur les packages et logiciels mplayer ne se soucie suffisamment de faire fonctionner le progiciel avec votre configuration matérielle et logicielle. Mais ne vous inquiétez pas, vous avez maintenant cette réponse et le pilote de sortie vidéo peut être spécifié sur la ligne de commande (par exemple, -vo xv ).

L’ordre des options de configuration que mplayer va scrapper avant qu’il ne décide finalement d’essayer (seulement) le pilote vdpau (manquant) n’est pas si évident, mais je pense que ça va à peu près comme ça,

  1. Vérifiez le ~/.mplayer/config pour le pilote de sortie vidéo par défaut (spécifique à l'utilisateur), le cas échéant
  2. Vérifiez ensuite /etc/mplayer/mplayer.conf pour le pilote de sortie vidéo par défaut (spécifique au système), le cas échéant
  3. Ensuite, vérifiez les options de compilation avec lesquelles mplayer a été construit pour une valeur par défaut (spécifique à la version).

Si la commande mplayer que vous utilisiez a été compilée avec l’option vdpau et qu’aucun pilote de sortie vidéo par défaut n’est spécifié dans ~/.mplayer/config ou /etc/mplayer/mplayer.conf (qui est une occurrence courante ou la seule qui a déjà eu des problèmes avec une option de configuration sur un linux box), alors il reviendra à la valeur par défaut compilée qui, dans ce cas, était vdpau.

Un autre problème similaire est que mplayer peut fonctionner correctement alors que gmplayer donne la même erreur en utilisant les mêmes options que vous venez d’essayer avec mplayer. Bien devinez quoi? gmplayer utilise encore un autre fichier de configuration, ~/.mplayer/gui.conf , et il utilisera par défaut le dernier pilote vidéo spécifié (ou défini par défaut dans les options de compilation). Donc, encore une fois, il suffit de spécifier un pilote de sortie vidéo sur la ligne de commande, ou d’en placer un dans une des innombrables fichiers de configuration mentionnés ici.

    
réponse donnée karthick87 16.11.2010 - 11:13
la source
1

ajouter -vo xv

    
réponse donnée JerzyG 24.10.2011 - 21:29
la source
1

Cependant, un petit réglage peut résoudre le problème comme suit:

  • Ouvrir Edit → Préférences dans la barre de menus du lecteur GNOME
  • Sélectionnez l'onglet "Player"
  • Sélectionnez x11 pour la sortie vidéo
  • Fermez les préférences et essayez à nouveau d'ouvrir le fichier vidéo.

Votre problème aurait dû être résolu.

    
réponse donnée Sudhir Kumar 14.01.2011 - 08:50
la source
1

Remarque: tout ce qui était avant la mise à jour était inclus car il pouvait être utile à quelqu'un d'autre et avait été publié avant le test ou en l'absence d'informations sur la situation.

Si vous utilisez une carte nVidia, installez les pilotes propriétaires.

  

Fglrx est l’officiel (source fermée)   Pilote ATI / AMD, mais il y a aussi   pilotes open source officiels inclus   dans Ubuntu par défaut, et ceux-ci fonctionnent   aussi bien avec beaucoup (plus vieux,   généralement) des cartes. vdpau (désolé si je   mal orthographié plus tôt) est seulement actuellement   disponible sur nVidia et (à mon   connaissances) cartes Intel. MPlayer   prend en charge cette API pour la vidéo   accélération, mais il n'est pas nécessaire de   lire des vidéos. Comme je ne suis pas un passionné   Utilisateur MPlayer (j'utilise Totem ou VLC Media Player pour lire des vidéos et   DVD), je vais devoir faire plus   creuser pour la bonne entrée dans le   fichier de configuration.

     

Je ne suggère pas de compiler le   fichier libvdpau.so, comme il le ferait tout à fait   honnêtement être inutile dans votre   configuration, et si vous deviez obtenir   une carte nVidia avec le propriétaire   pilotes que vous n'auriez pas besoin d'installer   rien de plus quand même.

     

Une suggestion que je vous donnerais est de   installez MPlayer-gui   (temporairement) et voir si quand   lancer cela vous permet de désactiver   l'utilisation de vdpau à partir des options d'interface graphique.   Ensuite, vous pourriez revenir à la normale   MPlayer et il devrait fonctionner sans aucune   d'autres problèmes. Si ce n'est pas   travailler, alors vous devrez peut-être finir   compiler :( pour désactiver l'utilisation de   vdpau (et pour éviter d'avoir à acheter un   nouvelle carte graphique lol).

MISE À JOUR

Ne ris pas, (ok, rires de moi, vas-y;) - mais je viens d'ouvrir Gnome-MPlayer pour moi et dans les préférences, tu peux choisir ton module de sortie vidéo! Il ne vous reste plus qu'à choisir celui qui vous convient (vaapi devrait fonctionner sur votre carte graphique).

Sous l'onglet MPlayer ( non affiché ), vous pouvez également ajouter des paramètres de ligne de commande à transmettre à MPlayer au cas où.

  

     

Capture d'écran personnalisée:)

La page Wikipedia pour vaapi devrait vous aider à comprendre la plupart des méthodes d’accélération vidéo en détail ( si vous suivez les liens recommandés dans l'article).

    
réponse donnée RolandiXor 13.03.2011 - 20:22
la source
1

Cliquez avec le bouton droit de la souris sur l'icône Application et sélectionnez Modifier les menus , sélectionnez l'élément de menu pour mplayer et modifiez les Propriétés & gt; Commande

    
réponse donnée fragos 13.03.2011 - 03:48
la source
0

Cette ligne de commande m'a aidé: mplayer -demuxer mov filename.mov

    
réponse donnée user13186 28.03.2011 - 23:05
la source
0

L'installation de libvdpau-va-gl l'a résolu pour moi, mais c'était une solution logicielle. Essayez de définir export VDPAU_DRIVER=nvidia

    
réponse donnée michalzuber 10.02.2016 - 18:17
la source

Lire d'autres questions sur les étiquettes