Modifier la largeur par défaut des fenêtres gnome-terminal et terminator

51

Seulement une petite question mais est-il possible de définir la largeur (et la hauteur) par défaut des sessions de terminal dans gnome-terminal et terminator ?

Je trouve que je redimensionne toujours la fenêtre une fois qu’elle s’affiche et compte tenu de l’utilisation de terminator , il est logique (IMO) de modifier la valeur par défaut et de gagner du temps par la suite.

    
posée Oli 19.09.2010 - 16:53
la source

7 réponses

71

Terminator vous permet de définir une taille par défaut. :)

Ouvrez simplement le fichier ~/.config/terminator/config avec votre éditeur préféré. Vous devriez avoir une section intitulée [layouts] . Il vous suffit d'ajouter une ligne dans la sous-section nommée [[[window0]]] appartenant à la section [[default]] . Mon fichier de configuration, par exemple, ressemble à ceci:

[global_config]
  enabled_plugins = CustomCommandsMenu, InactivityWatch, ActivityWatch, TerminalShot, LaunchpadCodeURLHandler, LaunchpadBugURLHandler
[keybindings]
[profiles]
  [[default]]
    scrollbar_position = hidden
    visible_bell = True
    scrollback_lines = 1000000
    foreground_color = "#ffffff"
    copy_on_selection = True
    background_color = "#300a24"
[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
      profile = default
    [[[window0]]]
      type = Window
      parent = ""
      profile = None
      size = 900, 600
[plugins]

La partie pertinente est uniquement la ligne commençant par "size", bien sûr.

    
réponse donnée radioboy 21.11.2011 - 21:55
la source
8

Je ne connais pas terminator , mais dans gnome-terminal , il existe une option sous les paramètres de profil pour définir les dimensions de départ sur un nombre quelconque de lignes et de colonnes, en particulier Edit->Profile Preferences .

    
réponse donnée Robert Edward Danhof 19.09.2010 - 18:14
la source
7

Hey. En supposant que vous appeliez un terminal depuis un menu de panneau ou une icône de lanceur, vous pouvez simplement modifier les instructions de ce lanceur pour y inclure la géométrie souhaitée.

Par exemple, j'ai un lanceur pour gnome-terminal sur mon gnome-panel qui s'ouvre à 80x40. Clic droit - & gt; properties: commande - défini sur "gnome-terminal (ou terminator, peu importe) --geometry = 80x40"

Utile?

    
réponse donnée emf 19.09.2010 - 21:07
la source
6

Au terminateur, l’option d’interface graphique pour la taille n’est pas là. Une façon simple de configurer ceci est -

Commencez par ouvrir le terminateur et définissez la taille de la fenêtre en fonction de vos besoins et de votre confort.

Cliquez avec le bouton droit de la souris et passez à la préférence, puis à la mise en page.

Cliquez sur le nom du terminal sous la fenêtre, puis enregistrez la mise en page.

Voilà, cela ouvrira le terminateur de la même taille, comme vous l’avez configuré, la prochaine fois que vous l’ouvrirez.

    
réponse donnée hunch 23.11.2016 - 18:01
la source
2

essayez ceci pour gnome-terminal:

allez à modifier & gt; & gt; Préférences de profil

regardez en bas:

taille par défaut : 80 (vous souhaitez l’augmenter)
Colums : 24: (vous voulez augmenter cela aussi!)

désolé si ce ne sont pas les "bonnes étiquettes", j'utilise ubuntu en espagnol

    
réponse donnée Axel 20.09.2010 - 00:44
la source
2

Exemple: gnome-terminal --geometry=80x40+100+200

Pour le faire garder toujours ce paramètre:

sudo -H gedit /usr/share/vte/termcap/xterm 

Localisez quelque chose de similaire à:

:co#80:it#8:li#24:\

co est le numéro de la colonne et li est le numéro de la ligne. Ajustez comme bon vous semble.

Merci à privilège

    
réponse donnée Gerard 17.09.2013 - 17:12
la source
1

Cela a disparu dans la dernière version de gnome-terminal, 2.30.2-0ubuntu1. Mon installation de 10.04 LTS a récupéré le nouveau paquetage gnome-terminal hier, et il n'obéit plus aux paramètres de géométrie du profil.

Les champs permettant de définir la taille par défaut ont disparu de la boîte de dialogue des options. L'option reste toutefois définie dans gconf (dans / apps / gnome-terminal / profiles / Default / default_size_columns et default_size_rows).

Il y a un rapport de bogue ici:

lien

    
réponse donnée Ben Williams 25.09.2010 - 02:43
la source

Lire d'autres questions sur les étiquettes