Impossible d'utiliser un périphérique audio Bluetooth malgré les modules Pulseaudio chargés et le périphérique connecté

10

J'ai déjà passé des heures et des heures à faire fonctionner mon périphérique audio Bluetooth.

  • Système: Ubuntu 16.04 LTS Xenial, toutes les mises à jour installées sur un ordinateur portable Lenovo Y50

  • Appareil: récepteur Bluetooth MR230, avec sortie audio analogique. Il est destiné à se connecter à un ancien système hi-fi. L'appareil ne se connecte pas automatiquement, mais je peux le trouver, le coupler, le faire confiance et le connecter avec bluetoothctl sans problème. Le gestionnaire de bluetooth l'affiche comme un casque.

  • La commande pactl list short indique que les modules module-bluetooth-discover , module-bluez5-discover , module-switch-on-connect et module-bluetooth-policy sont tous en cours d'exécution (après leur démarrage manuel)

Mais quand même, je ne peux pas choisir le périphérique dans pavucontrol car il n’y apparaît pas. J'ai peut-être foiré certains de mes fichiers de configuration lors de ces tentatives, même si cela devrait toujours fonctionner car tous les modules nécessaires sont chargés et que le périphérique est connecté.

Des idées?

    
posée Florian 17.10.2016 - 14:40
la source

2 réponses

0

Pour moi, la raison pour laquelle je n'obtenais aucun évier dans pulseaudio était d'utiliser hcitool au lieu de bluetoothctl pour connecter le casque. Avec bluez5 , ce dernier est préférable et le premier n'est pas garanti pour fonctionner.

Mais même avoir un évier pavucontrol -selectable ne m'a pas donné de son. J'ai certainement entendu un changement de niveau de bruit entre le sommeil de l 'évier et les transitions sans suspension, mais aucun son ne finissait toujours par jouer (avec un son sans son au volume maximum). De plus, pulseaudio a refusé d'utiliser le profil A2DP en indiquant que module-bluez5-device.c: Profile 'a2dp' not valid or not supported by device eventhough bluetoothctl <<< "info 00:11:22:33:44:55" listait clairement Audio Sink UUID 0000110b-0000-1000-8000-00805f9b34fb . Donc, PA utilisait HSP / HFP ou autre, et cela signifie 8kHz mono en dur .

En fin de compte, la façon dont j'ai travaillé A2DP sur Ubuntu 16.04 était de compiler pulseaudio 9.0 depuis la source . Construction très prévisible; une courte transcription pour ceux qui connaissent la compilation:

git clone --branch master git://anongit.freedesktop.org/pulseaudio/pulseaudio \
    && cd pulseaudio
./autogen.sh
./configure \
  --enable-bluez5 \
  --enable-bluez5-native-headset \
  --with-speex \
  && make -sj3

Recherchez simplement et apt install ces -dev packages configure demande. make a pris environ 100 secondes pour terminer.

Puis test rapide sur place:

echo 'autospawn=no' > ~/.config/pulse/client.conf; killall pulseaudio

src/pulseaudio --daemonize=no --log-level=info -F /etc/pulse/default.pa

À ce stade, je l’ai fait fonctionner.

$ src/pulseaudio --version
pulseaudio 9.0-129-gf7b8

Pour finir, je mettrais ça dans un .deb , installez systemwide via dpkg -i et annulez la modification autospawn=no .

    
réponse donnée ulidtko 30.12.2016 - 01:11
la source
-1

J'ai trouvé cette réponse à Ici par Louis Gagnon

La solution permanente consisterait à ajouter le blueman PPA et à mettre à jour votre paquet avec la dernière version corrigée du bogue: lien

sudo add-apt-repository ppa:blueman/ppa
sudo apt-get update
sudo apt-get upgrade

De cette façon, vous ne devriez plus avoir à exécuter le

sudo -i pactl load-module module-bluetooth-discover

commande à chaque fois mais une seule fois. Fonctionne pour moi sur 14.04 LTS (Trusty)

Source: lien

    
réponse donnée Bhikkhu Subhuti 28.12.2016 - 01:30
la source

Lire d'autres questions sur les étiquettes