Son des écouteurs et des haut-parleurs

47

Je suppose que cette question avait déjà la réponse ici mais je ne peux pas la trouver. J'utilise 12.04.

Mise à jour:

Le problème est que je peux entendre le son des haut-parleurs de mon ordinateur portable, même si je branche mes écouteurs. Le casque est juste un casque stéréo standard. Et la chose la plus intéressante est que tout fonctionnait il y a juste une semaine.

J'ai essayé de jouer avec les paramètres pulseaudio et alsamixer - aucun résultat.

    
posée Ilay 14.06.2012 - 18:26
la source

16 réponses

23

Solution originale

  1. Accédez à Site officiel de Realtek , acceptez la clause de non-responsabilité, puis téléchargez le pilote audio pour Linux / Unix. Vous devez sélectionner la version 3 pour le noyau 3 ou une version ultérieure.

  2. Configurez les outils nécessaires pour compiler ce pilote.

    sudo apt-get install build-essential gcc make

  3. Extrayez le fichier téléchargé, exécutez le fichier sudo ./install depuis un terminal après être allé dans le dossier extrait pour compiler le pilote.

  4. Lisez le fichier Readme.txt pour plus d'informations.

  5. Installez gnome-alsamixer avec cette commande.

    sudo apt-get install gnome-alsamixer
    
  6. Ouvrez gnome-alsamixer en saisissant alsamixer dans le tiret.

  7. Sélectionnez le mode "Auto mute" dans la nouvelle fenêtre.

Redémarrez et voyez si cela a été corrigé maintenant. (les étapes 6 et 7 peuvent ne pas être nécessaires) . Automute sera automatiquement activé au redémarrage

Solution 2:

Je viens de trouver une autre solution:

(Cela a fonctionné pour moi uniquement avec le profil S / PDIF, le son à la fois du casque et du haut-parleur et la possibilité de changer de profil)

  1. Ajoutez ce ppa par la commande

     sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
    
  2. Mettre à jour la liste des packages. par

    sudo apt-get update
    
  3. Installez ensuite le paquet "alsa-hda-dkms":

     sudo apt-get install alsa-hda-dkms
    

Redémarrer, et voir le résultat!

    
réponse donnée Anwar 14.06.2012 - 22:07
la source
30

Suivez ces étapes pour mettre automatiquement vos haut-parleurs en sourdine lorsque vous branchez des écouteurs:

  1. Ouvrir un terminal ( Ctrl + Alt + T )
  2. Tapez: alsamixer et appuyez sur Entrez / Retour
  3. Sélectionnez le périphérique audio approprié en appuyant sur F6
  4. Naviguez vers la droite avec (touche fléchée droite) jusqu'à ce que vous mettiez en surbrillance Auto-Mute
  5. Appuyez sur (touche flèche haut) et sélectionnez Activé (ou Sortie ligne )
  6. Appuyez sur Esc pour quitter
réponse donnée user247077 11.02.2014 - 16:18
la source
6

J'ai aussi eu ce problème sur mon ordinateur portable HP. J'ai trouvé un post et j'ai suivi l'un des conseils, qui suggère d'ajouter deux lignes au bas de la page. le fichier /etc/modprobe.d/alsa-base.conf :

options snd-hda-intel model=laptop
options snd-hda-intel position_fix=1 enable=yes

enregistrez-le et redémarrez. Ça marche pour moi!

    
réponse donnée hiqhan 07.01.2013 - 08:55
la source
4

A eu ce problème sur XUbuntu 12.04, a examiné cette page, a installé gnome-alsamixer package , a exécuté gnome-alsamixer , a coché l'option "Headphone Jack Sense" dans l'écran de l'interface graphique de gnome-alsamixer qui a été corrigé. Merci!

    
réponse donnée Bob 28.09.2012 - 20:27
la source
2

Ce qui a fonctionné pour moi était de lancer alsamixer et d’activer l’option auto-mute. Je l'ai fait pendant que les écouteurs étaient connectés et que tout fonctionnait parfaitement.

    
réponse donnée Vishal 04.10.2013 - 22:09
la source
2

La commande sudo apt-get install gnome-alsa-mixer a fait le tour pour moi sur mon Compaq nw8000 .

Je pourrais activer l’option Prise casque et maintenant il bascule l’audio sur le casque lorsque je branche mes écouteurs.

    
réponse donnée crazygoda 10.12.2012 - 01:56
la source
2

J'ai eu le même problème le 13.04 avec un Asus X201E, et j'ai essayé la solution gnome-alsamixer mais cela a échoué car le gnome-alsamixer est tombé en panne avec " ! ". J'ai donc ouvert la ligne de commande alsamixer et navigué vers le mode Auto-Mute à l'aide des flèches (seul Auto-Mut est visible dans la fenêtre du terminal) et défini de Disabled à Enabled. Connecter maintenant le casque coupe le son des haut-parleurs internes.

    
réponse donnée asterx 27.08.2013 - 11:18
la source
1

après la mise à niveau de 15.04 - & gt; 15.10 et maintenant le 16.10 (où le problème a commencé)

la seule résolution qui a fonctionné pour moi était de faire une réinstallation complète

dpkg -l | grep 'alsa-'
apt-get install --reinstall  alsa-base alsa-utils
    
réponse donnée user3258557 19.10.2016 - 21:56
la source
1

Celui-ci a parfaitement fonctionné pour moi.

  1. Modifiez /etc/modprobe.d/alsa-base.conf en tant que superutilisateur avec votre éditeur de texte préféré, e. g.:

    sudo gedit /etc/modprobe.d/alsa-base.conf
    
  2. A la fin du fichier, collez les éléments suivants:

    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1 enable_msi=1
    
  3. Enregistrer et redémarrer.

Si cela ne fonctionne pas, modifiez dans la deuxième ligne la partie concernant model=dell-m4-1 à model=hp-m4 .

    
réponse donnée Ahmed Riad 07.07.2013 - 17:03
la source
0

Essayez de brancher correctement votre casque. Cela m'est arrivé une fois et après avoir réparé cette broche du casque correctement, cela a fonctionné correctement.

    
réponse donnée Pranit Bauva 14.06.2012 - 18:41
la source
0

J'ai eu le même problème avec une nouvelle installation de Xubuntu. J'ai essayé un tas de choses, y compris en tapant alsamixer dans le terminal. L'option n'était pas là pour que j'allume le casque Jack Sense. J'ai installé gnome-alsamixer et j'ai trouvé l'option Headphone Jack Sense.

    
réponse donnée Jason 28.06.2014 - 08:03
la source
0

Exécuter alsamixer in terminal a fonctionné pour moi, réglez-le sur Auto Mute et vous devriez trouver que votre machine jouera le son à travers l'un ou l'autre plutôt que les deux

    
réponse donnée Gordon Quinn 01.12.2014 - 14:09
la source
0

dans alsamixer, essayez d'utiliser la touche fléchée Up , puis tournez tout jusqu'à 100% et vous verrez que la barre de droite apparaît. Après cela, appuyez sur la touche fléchée pour% vous aimez. Maintenant, il devrait être ensemble et votre orateur droit travaillera des deux côtés.

    
réponse donnée Lazy Lee 11.01.2015 - 00:08
la source
0

Sur un Asus X551MA, je rencontrais ce problème dès que j'ai remplacé Windows par Ubuntu 14.04. Même si je coupais les haut-parleurs dans aslamixer , ils reviendraient de manière inattendue.

Quand je suis arrivé à la troisième étape de cette procédure de dépannage , il semble que tout ait été résolu. C'est une commande longue et compliquée qui a installé différents paquets, donc je ne suis pas sûr de la ou des parties qui étaient vraiment nécessaires:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-'uname -r' libasound2; sudo apt-get -y --reinstall install linux- sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-'uname -r' libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG 'cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse- access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print }' | tr '\n' ',' | sed 's:,$::g'' 'whoami'
    
réponse donnée Brian Z 12.01.2016 - 20:48
la source
0

Il vous suffit d'aller sur alsamixer (alsamixer in terminal) et d'utiliser les touches fléchées droite / gauche pour accéder aux paramètres des haut-parleurs et cliquer sur M. Cela désactivera les haut-parleurs, mais pas le casque.

    
réponse donnée Rhys 10.09.2016 - 02:37
la source
0

Cela a fonctionné pour moi (Ubuntu 14.04 LTS fonctionnant sur ordinateur portable Compaq NC6120):

  1. Ctrl + Alt + T (pour ouvrir le terminal)
  2. Tapez alsamixer
  3. Appuyez sur jusqu’à l’option "Headphone Jack Sense"
  4. Appuyez sur m pour activer (couper automatiquement les haut-parleurs lorsque le casque est branché)
réponse donnée XqRG 09.10.2016 - 04:26
la source

Lire d'autres questions sur les étiquettes