Résolution d'écran supérieure pour VirtualBox?

96

J'ai essayé ceci pendant un moment mais pas de chance. J'ai installé ubuntu-11.10-desktop-i386 deux fois. Également installé des ajouts d'invités. Cependant, je reçois toujours une résolution d’écran maximale de 1024 x 768 .

Dois-je changer quelque chose dans le fichier /etc/X11/xorg.conf ( exemple )? Actuellement, il n'y a pas de tel fichier dans ce chemin. De plus, seriez-vous en mesure de me dire quel devrait être le contenu du fichier pour la version 11.10?

    
posée iammilind 29.10.2011 - 20:25
la source

17 réponses

88

Cela a fonctionné pour moi et je cours VirtualBox 4.1.8 et Ubuntu 11.10.

sudo apt-get install virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

Vous l'avez trouvé sur ce site avec une question légèrement différente Résolution d'écran supérieure dans VirtualBox?

    
réponse donnée wfudge 09.03.2012 - 07:22
la source
31

J'ai pu reproduire ce problème à plusieurs reprises sur un hôte Windows 7 avec un invité Ubuntu 11.10. Installation d'ubuntu à partir d'une image iso.

Ce problème se produit lorsque les ajouts d'invité ne sont pas installés ou installés à partir de sources ubuntu.

Pour résoudre ce problème, installez les ajouts d'invité à partir des périphériques de la machine virtuelle; L'option Insérer une image du CD Additions invité et l'exécution du balayage automatique. Si les ajouts d'invités sont déjà installés à partir d'une autre source, il vous incitera à supprimer celui existant et à installer de nouveaux ajouts d'invités. Dites simplement «oui». Cela supprimera les ajouts d'invités s'ils sont déjà installés à partir de sources ubuntu et construits à partir de sources fournies avec votre installation virtualBox.

Cela devrait résoudre le problème.

    
réponse donnée Sai Puli 09.08.2012 - 17:35
la source
14

Je viens d'installer Ubuntu 12.04 sur VirtualBox 4.1.4, mais je ne pouvais pas le faire fonctionner avec une résolution plus élevée, même après avoir installé et réinstallé les additions VBOX. Désespéré, j'ai installé le VBOX 4.1.14 et réinstallé plusieurs fois les VBOXAdditions, mais sans succès. Enfin, la solution qui a résolu le problème, consistait à augmenter la mémoire vidéo (en configuration VBOX pour Ubuntu) de 12 Mo à 48 Mo (ce qui n’a toujours pas permis la résolution 1366x768) et à 128 Mo. Après avoir redémarré Ubuntu, tout fonctionne parfaitement, 1366x768 est ma résolution par défaut. J'espère que cela vous aidera dans vos problèmes. Cheers!

    
réponse donnée LowResolutionOnUbuntu12.04 28.04.2012 - 17:56
la source
10

J'ai été troublé par la résolution d'écran sur Virtual Box sur Windows 7 x64 en tant qu'hôte et sur le bureau Ubuntu 12.04 LTS en tant qu'invité. J'avais élevé la mémoire vidéo à 128 Mo, installé les compléments VirtualBox Linux, mais ce n'était pas encore possible. Lors de la vérification des paramètres d'affichage dans Ubuntu, je ne pouvais choisir qu'entre 800x640 (4: 3) et 1024x768 (4: 3).

Cochez la case Activer l’accélération 3D dans les paramètres de la machine virtuelle pour que cela fonctionne. Après cela, lorsque la fenêtre d'invité a été redimensionnée, la taille était reflétée dans les paramètres d'affichage d'Ubuntu. En tournant en mode plein écran, je pouvais utiliser la résolution 1600x900 complète dans Ubuntu.

Espère que cela pourrait sauver les cheveux de quelqu'un.

UPDATE: Après avoir activé l’accélération 3D, Ubuntu est devenu extrêmement lent. J'ai donc décoté l'accélération 3D et je pouvais encore profiter d'une résolution en plein écran.

    
réponse donnée John P 09.10.2012 - 17:12
la source
7

Mon système est Windows 7 SP 1 64 bits sous Ubuntu 12.04 LTS 32 bits (i386). Je devais presque tout faire pour que ça marche. Pour résumer:

  1. Lorsque la machine virtuelle est arrêtée, modifiez les paramètres de la machine virtuelle pertinente. Sous "Affichage" - & gt; "Vidéo" déplace le curseur de la mémoire vidéo sur "128mb" et coche également "Activer l'accélération 3D".

  2. Chargez maintenant votre machine virtuelle Ubuntu. Sous "Périphériques", cliquez sur "Insérer une image de CD des ajouts d'invités". Attendez qu'il fasse son truc.

  3. Redémarrez la machine virtuelle. Vous devriez maintenant pouvoir atteindre les résolutions les plus élevées. Sinon, cela peut être dû au fait que la fenêtre de la machine virtuelle n'est pas assez grande. Faites glisser le coin pour l'agrandir ou le faire simplement: 'View' - & gt; 'Passer en plein écran'

J'espère que cela aide quelqu'un. Merci à toutes les autres réponses pour m'aider.

    
réponse donnée Calleniah 04.12.2013 - 20:42
la source
7

Il s’agit probablement d’un problème VirtualBox , et non d’un problème Ubuntu .

J'ai eu le même problème à plusieurs reprises avant. Parfois, supprimer et réinstaller les ajouts résout ce problème. Ou simplement forcer VirtualBox à les charger, et pas seulement à les télécharger.

Malheureusement, ce problème se reproduit. J'ai constaté que la mise à jour de VirtualBox (vers une nouvelle version) rend parfois cette situation encore pire ET résout parfois ce problème. C'est un problème récurrent ..

    
réponse donnée david6 20.11.2011 - 00:24
la source
2

Entrer dans le jeu dernièrement, je ne suis pas sûr que cette réponse vous aidera, mais avec un problème de résolution similaire (hôte Mac, Ubuntu en vbox), et après avoir joué avec xrandr , xorg.conf etc ... / p>

  • fermer la boîte virtuelle
  • entrez la commande du terminal hôte VBoxManage setextradata Linux CustomVideoMode1 1152x680x32 Linux est le nom de la vbox, CustomVideoMode1 est un nom que vous attribuez à 1 pour une nouvelle résolution, 1152x680x32 pour une résolution couleur de 1152 x 680 x 32 bits (VBoxManage.exe sous Windows)
  • démarrer votre vbox
  • réinstallez les ajouts Guest

a fonctionné immédiatement après un redémarrage de vbox.

plus d’informations

    
réponse donnée Ring Ø 31.03.2013 - 12:47
la source
2

Utilisation de VirtualBox 4.3 sur Windows 8 et Ubuntu invité 12.04

J'ai installé des ajouts d'invités virtualbox à partir du fichier iso fourni dans le répertoire d'installation de virtualbox (autorun.sh utilisé) + redémarrage de l'invité.

J'ai d'abord pensé que cela ne fonctionnait pas: la résolution était toujours faible et les paramètres de l'écran ne montraient aucune résolution plus élevée

Puis je me suis rendu compte que l’écran des invités était en "mode échelle" (hôte + c), je suis passé en plein écran (hôte + F) et la résolution était correcte!

    
réponse donnée ceco 14.05.2014 - 16:25
la source
1

Lancez ubuntu sur une machine virtuelle et installez "VirtualBox Guest Additions" (Devices - & gt; Install Guest Additions). Après l'installation, redémarrez votre système invité.

Maintenant, la résolution changera automatiquement en fonction de la taille de la fenêtre.

* J'utilise Ubuntu 13.04 sur VirtualBox 4.2.12 pour Mac OS

Bonne chance.

    
réponse donnée Roman Shamritskiy 04.06.2013 - 13:33
la source
1

Problème avec l’écran non plein après les mises à jour. Lancer Ubuntu 12.04. Dans le média VBOXADDITIONS, j'ai simplement lancé autorun.sh - ceci a désinstallé et réinstallé les ajouts d'invité, puis j'ai redémarré et tout est revenu à la normale.

    
réponse donnée Richard 27.06.2013 - 07:43
la source
1

Avec Ubuntu 12.04 en tant qu'hôte et invité, j'ai suivi la réponse de wfudge.

Cela nécessite que d’autres packages soient installés:

sudo apt-get xserver-xorg-core

Après cela, a exécuté cette ligne modifiée de wfudge suggérée par apt-get:

sudo apt-get install virtualbox-ose-guest-utils virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms virtualbox-guest-x11

Après que l'invité d'Ubuntu n'ait pas démarré dans l'interface graphique, avec Ctrl + Alt + F1, connecté dans une console et exécuté:

sudo apt-get install ubuntu-desktop

Redémarrez et faites. Maintenant, je peux obtenir des résolutions supérieures à 1600x1200. Toujours pas 1920x1080 (hôte), donc ce n'est pas plein écran, mais au moins c'est beaucoup mieux que ce que j'avais avant.

Je suppose que c'est un problème de VirtualBox, mais lorsqu'il est utilisé, un hôte Windows ne rencontrait pas ce problème ...

    
réponse donnée Christian Vielma 25.09.2013 - 18:01
la source
1

Pour moi (hôte: Mac El-capitan, invité: Ubuntu 14.xx LTS, VirtualBox: 5.0.12) l’Ubuntu ne redémarrera pas (écran noir ou violet par défaut gelé) après l’installation d’invités via apt-get décrit dans la plupart des articles de ce fil.

Enfin, j'ai utilisé les instructions officielles de VirtualBox . Sur une nouvelle installation Ubuntu. Travaillé!

  

Installation d’additions invité sur Ubuntu

     
  1. Suivez ces étapes pour installer les compléments sur votre machine virtuelle Ubuntu:
  2.   
  3. Connectez-vous en tant qu'ubuntu;
  4.   
  5. Cliquez sur Applications / System / Terminal (ou sur Applications / Terminal, si vous utilisez la version 6.06.1 Dapper Drake);
  6.   
  7. Mettez à jour votre base de données APT avec la mise à jour sudo apt-get et saisissez votre mot de passe si nécessaire;
  8.   
  9. Installez les dernières mises à jour de sécurité avec sudo apt-get upgrade;
  10.   
  11. Installer les paquets requis avec sudo apt-get install build-essential module-assistant;
  12.   
  13. Configurez votre système pour construire des modules du noyau en exécutant sudo m-a prepare;
  14.   
  15. Cliquez sur Installer les ajouts d'invités ... dans le menu Périphériques, puis choisissez de parcourir le contenu du CD sur demande.
  16.   
  17. Exécutez sudo sh /media/cdrom/VBoxLinuxAdditions.run et suivez les instructions à l'écran.
  18.   

J'ai fait un sudo reboot now à la fin juste pour être en sécurité. Au redémarrage, il a commencé à modifier sa résolution en fonction de la taille de la fenêtre.

    
réponse donnée Kashyap 27.01.2016 - 16:22
la source
0

J'ai le même problème sur mon portable DELL M6600 avec Ubuntu 12.10. J'ai dû installer des ajouts de quêtes en mode sans échec de Windows. Après cela, la résolution de l'écran du bureau a été effectuée en fonction de la taille de la fenêtre avec l'OS invité.

    
réponse donnée jafan 29.01.2013 - 20:41
la source
0

Parfois, c'est très simple (voir 12.03 / 4) Sur la fenêtre de la machine virtuelle, cliquez sur le bouton Agrandir pour remplir l'écran et pour que Ubuntu détecte à nouveau la résolution d'écran de la VM.

Sinon, la réponse de Christian Vielma, qui fait les trois étapes l'une après l'autre, permettra cette option.

    
réponse donnée ppostma1 30.10.2013 - 16:57
la source
0
  1. Fermer VirtualBox.

  2. Collez ceci sur le terminal hôte:

    sudo VBoxManage setextradata NAME CustomVideoMode1 1152x680x32
    

    NAME se trouve dans Paramètres Général Basic Nom .

  3. Redémarrez VirtualBox.

réponse donnée Ajay 06.03.2014 - 17:00
la source
0

En utilisant plain X11 sans un client de bureau lourd, ratpoison dans mon cas, le package suivant est tout ce qui est nécessaire:

virtualbox-guest-x11

Je comprends que d’autres paquets peuvent faire prendre conscience à votre noyau qu’il fonctionne dans un environnement virtuel pour certains avantages, mais ce package semble gérer les problèmes de résolution.

    
réponse donnée Asad Hasan 08.03.2014 - 20:23
la source
0

La seule solution qui fonctionnait était le téléchargement des dernières ISO de VBoxAdditions sur le site Web d’Oracle, les anciens ne fonctionnant pas correctement avec DKMS.

    
réponse donnée Yatharth Agarwal 09.12.2015 - 21:43
la source

Lire d'autres questions sur les étiquettes