Comment désactiver le volume d'alerte à partir de la ligne de commande?

10

Il existe une option dans la boîte de dialogue Préférences son, onglet Effets sonores, pour basculer le volume d’alertes sur «muet». Cela fonctionne et suffit à mes besoins pour désactiver le bip / la sonnerie du système irritant.

Cependant, je réinstalle les systèmes LOT à des fins de test et je voudrais définir ce paramètre dans un script shell pour qu'il soit désactivé sans avoir à manipuler une interface graphique. Mais pour la vie de moi, je ne peux pas sembler trouver où cela peut être basculé via un outil de ligne de commande.

J'ai parcouru gconf-editor, pacmd de pulseaudio, grugé dans / etc, et même creusé dans le code source de gnome-volume-control, mais je ne vois pas comment cela peut être défini.

Je suppose que gnome-volume-control a changé depuis quelques versions.

Idées?

    
posée Bryce 09.02.2011 - 21:52
la source

2 réponses

6
  • Option 0: (cela pourrait être ce que vous cherchiez)

    sudo su gdm -c "gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false"
    
  • Option 1:

    Temporaire:

    sudo modprobe -r pcspkr  
    

    Permanent

    echo “blacklist pcspkr” >> /etc/modprobe.d/blacklist
    
  • Option 2:

    Recherchez "set bell-style" dans /etc/inputrc (les options sont none ou visible )

  • Option 3:

    sudo mv -v /usr/share/sounds/ubuntu/stereo/*.ogg {*.disabled}
    
  • Option 4:

    man xset
    
réponse donnée bumbling fool 09.02.2011 - 22:47
la source
9

Chassé pendant longtemps. Surtout que je n'utilise pas pulseaudio et que je ne peux pas couper le son d’alerte de l’UI (WTF!?)

Cela le fait. Oh la douce joie du silence!

# gsettings set org.gnome.desktop.sound event-sounds false
    
réponse donnée Philippe De Swert 21.08.2012 - 11:43
la source

Lire d'autres questions sur les étiquettes