Désactiver le pavé tactile pendant que la frappe ne fonctionne pas

52

J'ai déjà coché cette option dans les paramètres mais cela ne fonctionnera pas. J'ai également recherché des solutions sur ce site, mais aucune ne fonctionnait. Que dois-je faire?

    
posée Kirk Gandril Madraga 25.05.2013 - 13:59
la source

8 réponses

44

Cette commande a fonctionné pour moi (1 est le nombre de secondes à attendre après avoir appuyé sur la dernière touche avant de réactiver le pavé tactile, modifiez-la en fonction de la valeur souhaitée):

syndaemon -i 1 -K -d

Ajoutez-le simplement aux applications de démarrage pour le faire fonctionner après le redémarrage / l'arrêt. Pour voir plus d'options, tapez cette commande dans un terminal:

syndaemon --help or man syndaemon
    
réponse donnée Marco 08.05.2014 - 05:22
la source
22

Comme d’autres, l’utilitaire syndaemon a résolu mon problème. Pour moi, le syndaemon fonctionnait déjà.

Après avoir joué avec et lu certaines des autres réponses ici, j'ai déterminé que la cause était l'option -t .

L'option doit avoir un bogue car quand il est spécifié, je peux toujours faire défiler et appuyer pendant la frappe. Cependant, si vous omettez complètement l'option, tout fonctionne correctement. le pavé tactile entier est désactivé comme prévu lors de la saisie lorsque vous n'incluez pas l'option -t . Je lance simplement ce qui suit pour redémarrer syndaemon sans -t .

  

$ killall syndaemon
  $ syndaemon -i 1 -KRd

  • -i vous permet de spécifier combien de temps syndaemon doit attendre après l'arrêt de la frappe avant de réactiver le pavé tactile. Une seconde est ce qui était déjà en marche et semble aller bien pour moi.
  • -K dit à syndaemon d'ignorer les touches de modification et les combinaisons de modificateurs + lors de la surveillance de la saisie au clavier.
  • -R demande à syndaemon d'utiliser l'extension "XRecord" au lieu d'interroger la saisie au clavier. J'imagine qu'il l'utilise pour des raisons de performance; L'extension indique probablement que l'activité de saisie s'arrête au lieu de dépendre de syndaemon pour interroger continuellement le clavier pour voir s'il y a des entrées.
  • -d dit simplement à syndaemon de s'exécuter en arrière-plan lorsque vous le lancez, sans bloquer l'entrée de votre terminal. Si vous n'incluez pas cette option, syndaemon s'arrête lorsque vous fermez votre terminal.

En fin de compte, c'est l'option -t qui est le coupable ici. Il suffit de faire fonctionner syndaemon sans et tout va bien.

PS - Ma machine est un Lenovo Yoga 13 original au cas où quelqu'un s’interrogerait. J'ai complètement détruit mon installation Windows et remplacé par Ubuntu 14.04.

    
réponse donnée Chev 06.10.2014 - 17:45
la source
19

Essayez d'installer des périphériques de pointage à partir du centre logiciel Ubuntu. En tapant "dispositifs de pointage" puis en cliquant sur installer. Une fois installé, ouvrez le programme à partir de Dash. Une fois le programme ouvert, le pavé tactile doit afficher (avec tous les autres souris branchées). Cliquez sur votre pavé tactile et l'option appelée palm detection devrait apparaître. Définissez range sur low et pressure sur high . Puis fermez-le. Si cela ne résout pas le problème, répondez.

    
réponse donnée Unitybuntu user 28.05.2013 - 01:24
la source
6

J'ai essayé toutes les options mentionnées mais aucune n'a fonctionné. Ensuite, j'ai trouvé cette commande magique qui a fait l'affaire pour moi. Essayez ceci et peut-être que cela fonctionnera pour vous

syndaemon -i 1 -K -d
    
réponse donnée codegeek 06.05.2014 - 02:18
la source
1

J'avais le même problème - même si l'option était cochée, cela ne fonctionnait pas. Je l'ai corrigé en installant Synaptics Touchpad depuis le centre du logiciel Ubuntu (il semble que ce ne soit pas installé par défaut).

Après l'avoir installé, je l'ai accédé au tableau de bord, puis je l'ai utilisé pour désactiver le pavé tactile lors de la frappe. Vous pouvez également définir l'heure à laquelle il doit rester inactif lorsque l'activité du clavier est détectée.

    
réponse donnée dwcoder 25.07.2013 - 19:23
la source
1

L'option " Désactiver en tapant " dans Paramètres système - & Souris et Touchpad ne fonctionne pas à cause d'un bogue dans Ubuntu comme décrit dans ce rapport de bogue confirmé . C'est un vieux bogue, depuis 12.04 et qui affecte tous les utilisateurs indépendamment des ordinateurs portables qu'ils utilisent .

Ce qui fonctionne, c'est d'ajouter le snipet

syndaemon -i 4 -K -d

dans les applications de démarrage.

"- i 4" fonctionne bien pour moi, "-i 1" comme le suggèrent certaines sources.

Veuillez ne pas utiliser l'option "-t" que vous pouvez trouver dans certains exemples sur le web. Ceci est la cause de problèmes car il ne désactive pas le touchpad lors de la frappe sur le clavier.

Au démarrage, syndaemon ne fonctionne pas, il n’ya donc pas besoin de "killall syndaemon". Si toutefois syndaemon avait été démarré, vous devriez utiliser:

killall syndaemon
syndaemon -i 4 -K -d

Vous pouvez expérimenter la frappe avec une main et essayer de déplacer le courseur avec le pavé tactile en utilisant les doigts de la trotteuse pour confirmer que cela fonctionne pour vous.

    
réponse donnée Robert Jakubowski 02.10.2014 - 13:44
la source
1
  1. Décochez "Désactiver en tapant" dans les paramètres du pavé tactile, comme indiqué ci-dessous (oui, cela est nécessaire même si cela semble contre-intuitif, sinon le Touchpad sera désactivé après avoir effectué les étapes "permanentes" suivantes, puis redémarrage, puisque le syndaemon précédent / mauvais sera démarré au démarrage et au conflit)

  2. tuez le processus syndaemon en cours (s’il en a déjà démarré au démarrage), qui contrôle cette fonctionnalité:

    pkill syndaemon
    
  3. redémarrer le processus syndaemon:

    syndaemon -i 2 -d -K
    

    où: 2 est la quantité de temps de retard, en secondes, vous voulez qu'il attende après que vous arrêtez de taper et avant active à nouveau le pavé tactile; Notez que toute valeur de temps inférieure à 1.5 ~ 2 sec (plus comme n'importe quoi & lt; 2 sec en fait) est glitchy / buggy, et ne semble pas garder le touchpad complètement désactivé pendant la frappe

  4. Pour rendre ce correctif permanent: lancez l'application "Startup Applications" depuis la barre de recherche → cliquez sur "Ajouter" → et tapez la commande suivante dans la section "Commande": syndaemon -i 2 -d -K . Le nom et le commentaire peuvent être n'importe quoi. Cliquez sur "Ajouter" lorsque vous avez terminé, puis fermez-le. Voici à quoi ça ressemble:

  5. Redémarrez l'ordinateur pour vérifier qu'il fonctionne. Notez que cette fonctionnalité ne démarrera que lorsque vous vous connecterez à votre compte d'utilisateur. Pendant l'écran de connexion, il n'est pas encore activé.

En savoir plus sur ce bogue dans Ubuntu 14.04 ici: lien

Cette réponse a été postée ici: lien

    
réponse donnée Gabriel Staples 14.12.2017 - 08:12
la source
-1

Pour ajouter une extension à toutes les réponses déjà fournies ...

Principalement: syndaemon -i 1 -K -d

Le seul problème avec cette commande est qu'une fois le système réinitialisé, le code sera essentiellement annulé.

Par conséquent, je vous recommande de créer un Alias en utilisant cette commande, même si le système redémarre, il vous suffit de taper une commande dans le terminal et d'exécuter automatiquement le code à partir de l'invite.

Je l'ai personnellement fait en utilisant "keystop" comme nom de commande pour implémenter ce code. Cependant, vous pouvez utiliser le nom que vous choisissez, suivez simplement les étapes ci-dessous. (En remplaçant keystop par le nom choisi pour la commande)

** Gardez à l’esprit que le nom de commande que vous choisissez ne doit PAS être utilisé!

Voici comment vous le faites:

  1. Terminal ouvert
  2. Tapez alias keystop='syndaemon -i 1 -K -d'

C'est ça! A partir de maintenant, chaque fois que vous redémarrez votre système - Ouvrez simplement le terminal et tapez keystop et le code s'exécutera!

    
réponse donnée dlundy1 25.06.2015 - 07:53
la source

Lire d'autres questions sur les étiquettes