Son uniquement sur des haut-parleurs internes, jamais sur des écouteurs (ordinateur portable Alienware, Ubuntu 15.10)

10

Alienware 17 r3 portable, les haut-parleurs internes fonctionnent bien, les prises casque semblent être ignorées, donc je ne peux pas obtenir de son à un haut-parleur externe. (Le Alienware a une seconde prise "microphone", qui peut apparemment aussi servir de prise casque supplémentaire.) En outre: je l’ai double-amorcé sous Windows 10 et les écouteurs fonctionnent correctement sous Windows.

J'ai vu qu'un autre utilisateur avait essentiellement le même problème Écouteurs Ubuntu 15.10 No Sound mais il ne semble pas avoir été résolu. Mon système ne montre que de petites variations par rapport au rapport de bogue original, donc c'est sûrement le même problème.

inxi:

> inxi -Fxz
System:    Host: jakku Kernel: 4.2.0-25-generic x86_64 (64 bit gcc: 5.2.1)
           Desktop: Unity 7.3.2 (Gtk 3.16.7-0ubuntu3)
           Distro: Ubuntu 15.10 wily
Machine:   System: Alienware product: Alienware 17 R3 v: 1.2.3
           Mobo: Alienware model: Alienware 17 R3 v: A00
           Bios: Alienware v: 1.2.3 date: 11/11/2015
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20726
           clock speeds: max: 3500 MHz 1: 2600 MHz 2: 3294 MHz 3: 3355 MHz
           4: 3369 MHz 5: 3381 MHz 6: 2600 MHz 7: 3183 MHz 8: 3207 MHz
Graphics:  Card-1: Intel Device 191b bus-ID: 00:02.0
           Card-2: NVIDIA GM204M [GeForce GTX 980M] bus-ID: 01:00.0
           Display Server: X.Org 1.17.2 driver: nvidia
           Resolution: [email protected], [email protected]
           GLX Renderer: GeForce GTX 980M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 352.63 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.2.0-25-generic
Network:   Card-1: Qualcomm Atheros Device e0a1
           driver: alx port: d000 bus-ID: 3b:00.0
           IF: enp59s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 3c:00.0
           IF: wlp60s0 state: down mac: <filter>
           Card-3: Atheros usb-ID: 001-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1128.2GB (33.5% used)
           ID-1: /dev/sda model: SanDisk_X300_M.2 size: 128.0GB
           ID-2: /dev/sdb model: HGST_HTS721010A9 size: 1000.2GB
Partition: ID-1: / size: 33G used: 6.4G (21%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 16.38GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A gpu: 0.0:57C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 244 Uptime: 1:34 Memory: 1293.5/15947.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.2.1
           Client: Shell (tcsh 6.18.01) inxi: 2.2.16 

dmesg:

> dmesg | grep snd
[    2.350920] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    2.351041] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    2.376447] snd_hda_codec_ca0132 hdaudioC0D0: autoconfig for CA0132: line_outs=1 (0xb/0x0/0x0/0x0/0x0) type:speaker
[    2.376449] snd_hda_codec_ca0132 hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.376450] snd_hda_codec_ca0132 hdaudioC0D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.376451] snd_hda_codec_ca0132 hdaudioC0D0:    mono: mono_out=0x0
[    2.376452] snd_hda_codec_ca0132 hdaudioC0D0:    inputs:
[    2.376453] snd_hda_codec_ca0132 hdaudioC0D0:      Mic=0x12
[    2.376454] snd_hda_codec_ca0132 hdaudioC0D0:      Line=0x11

lspci:

> sudo lspci -v | grep -A7 -i "audio"
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    Subsystem: Dell Device 0708
    Flags: bus master, fast devsel, latency 32, IRQ 136
    Memory at dd128000 (64-bit, non-prefetchable) [size=16K]
    Memory at dd100000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Kernel driver in use: snd_hda_intel

aplay:

> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pacmd:

> pacmd
Welcome to PulseAudio 6.0! Use "help" for usage information.
>>> list-sinks
1 sink(s) available.
  * index: 0
    name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9959
    volume: front-left: 19986 /  30% / -30.95 dB,   front-right: 19986 /  30% / -30.95 dB
            balance 0.00
    base volume: 46396 /  71% / -9.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 341.33 ms
    card: 0 <alsa_card.pci-0000_00_1f.3>
    module: 6
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "CA0132 Analog"
        alsa.id = "CA0132 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xdd128000 irq 136"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1f.3"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a170"
        device.product.name = "Sunrise Point-H HD Audio"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Intel Skylake HDMI"
        alsa.components = "HDA:11020011,10280708,00100918 HDA:80862809,80860101,00100000"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: yes)
            properties:

    active port: <analog-output-lineout>

fichiers de configuration pulseaudio:

> cd /usr/share/pulseaudio/alsa-mixer/paths/
> ls
analog-input-aux.conf              analog-output-headphones-2.conf
analog-input-dock-mic.conf         analog-output-headphones.conf
analog-input-fm.conf               analog-output-lineout.conf
analog-input-front-mic.conf        analog-output-mono.conf
analog-input-headphone-mic.conf        analog-output-speaker-always.conf
analog-input-headset-mic.conf          analog-output-speaker.conf
analog-input-internal-mic-always.conf  analog-output.conf
analog-input-internal-mic.conf         analog-output.conf.common
analog-input-linein.conf           hdmi-output-0.conf
analog-input-mic-line.conf         hdmi-output-1.conf
analog-input-mic.conf              hdmi-output-2.conf
analog-input-mic.conf.common           hdmi-output-3.conf
analog-input-rear-mic.conf         hdmi-output-4.conf
analog-input-tvtuner.conf          hdmi-output-5.conf
analog-input-video.conf            hdmi-output-6.conf
analog-input.conf              hdmi-output-7.conf
analog-input.conf.common           iec958-stereo-output.conf

test du haut-parleur: (lit bien les haut-parleurs intégrés, ignore les écouteurs)

> speaker-test -t wav -Dplug:front

speaker-test 1.0.29

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
Time per period = 1.195038
 0 - Front Left
Time per period = 1.450744
 0 - Front Left
La sortie de

alsa-info.sh peut être trouvée ici: lien

Tout fonctionne bien avec les haut-parleurs internes intégrés. Mais je ne peux pas sortir de son des écouteurs. Quelqu'un a des idées? Merci!

Modifier

Au cas où cela aiderait quelqu'un, Windows 10 liste la carte son sous le nom "Sound Blaster Recon3Di" (où le casque fonctionne correctement).

    
posée Don Geddis 25.01.2016 - 06:51
la source

8 réponses

2

J'ai trouvé la solution quelque part. Procédez comme suit:

  • Dans le terminal, entrez la commande "alsamixer".

  • Une interface utilisateur ASCI s’ouvre, utilisez les touches fléchées pour trouver l’élément: "Détection auto HP / haut-parleur". il dira "Off" à côté de lui.

  • Appuyez sur M et l’étiquette "Off" disparaîtra.

  • Rebranchez vos écouteurs.

  • Profitez!

réponse donnée Matt A. 03.08.2016 - 21:48
la source
1

J'ai eu exactement le même problème. Apparemment, Alienware 17 r3 est un nouveau modèle qui sortira en septembre dernier, ce qui fait qu’il ya beaucoup de problèmes de pilotes.

FAQ:

Q.Wifi ne fonctionne pas?

A.Suivez ce lien pour réparer la carte sans fil Broadcom ath10k (killer wifi). lien (Remarque: votre noyau doit être supérieur à l'image officielle d'ubuntu 15.10)

Q.Ce ne peut pas démarrer et aller à initramfs?

R.Si c'est le problème i915 Guc, pas de solution pour le moment puisque j'ai déjà essayé de mettre à jour le dernier firmware d'Intel (noyau 4.3.3) mais que le problème "firmware-4.bin" n'est toujours pas résolu. Si c'est le problème de SSD introuvable, essayez d’ajouter 'nvme' à: / etc / initramfs-tools / modules et lancez 'update-initramfs -a' (noyau 4.4.0)

Q.Ce ne peut pas être monté !!! Ubuntu se fige quand il revient à l’unité de connexion de l’unité à cause de la désinsertion du disque dur du système. Problème très ennuyant puisque je dois déplacer mon ordinateur portable avec le couvercle ouvert ou choisir l'option «ne rien faire» dans le réglage de puissance.

A.Pas encore d'indice.

Q. Seul le haut-parleur interne fonctionne?

Pas encore de solution. Je lance maintenant Ubuntu 16.04 et la version 4.4 du noyau mais toujours pas de son de mon casque. À propos du noyau 4.4 rc6 diff, Voir la ligne 772: lien Il semble que ce problème ne soit pas urgent ou qu’il n’y ait pas encore de solution rapide car aucun code source de pilote n’est fourni par Creative. Espère que n'importe qui puisse contacter Creative pour résoudre ce problème.

Autres questions:

- Lumières imprévisibles allumées / éteintes chaque fois que vous démarrez dans Ubuntu, pas encore de logiciel de commande de commutateur d'éclairage actif.

- "L'erreur BTRFS n'a pas pu trouver la racine 8" si vous utilisez le système de fichiers btrfs au lieu de ext4.

    
réponse donnée Frank Wang 28.01.2016 - 02:04
la source
1

J'ai récemment obtenu le Alienware 17 R3, et j'ai eu le même problème, j'ai résolu en mettant à jour le pilote alsa sur this site:

Téléchargez le fichier * .deb correspondant à votre système basé sur Ubuntu et, avant d’installer le package .deb, assurez-vous que vous exécutez:

sudo apt-get install dkms

Après cela, redémarrez et activez les options de découverte automatique avec la commande alsamixer pour accéder à votre pilote alsa à partir de votre interface de ligne de commande, et cela fonctionne pour moi.

    
réponse donnée Karly 18.01.2017 - 01:29
la source
1

J'ai trouvé une solution de contournement:

J'ai acheté cet adaptateur audio USB

Cela n'a pas fonctionné, même après avoir manipulé les paramètres du système. Il a été détecté, mais quand j'ai changé de voix à la valeur par défaut, j'ai toujours le son de mon ordinateur portable. J'ai essayé de changer l'ordre du chargement du périphérique audio (périphérique USB en premier), toujours pas de résultat.

Il s’est avéré que tout ce que je devais faire était d’ouvrir pavucontrol (installez-le si vous ne l’avez pas) et réglez le son sur le périphérique audio USB. Cela doit être fait pour tous les programmes audio séparément (Firefox, Spotify, Audacity, etc.). Après cela, brancher un casque ou des haut-parleurs externes permet de commuter automatiquement la sortie vers eux.

Voici un fil de discussion plus détaillé à ce sujet

    
réponse donnée Mike 01.02.2017 - 20:36
la source
0

Essayez de changer le périphérique de sortie en "Sortie numérique" et voyez si le casque fonctionne.

Dans les ordinateurs portables modernes, la sortie numérique et analogique peut partager la prise casque, ce qui empêche le noyau de déduire le but de la sortie à partir des informations de codec de broche.

C'est toujours un bug mais au moins vous pourriez utiliser les écouteurs.

    
réponse donnée carlinux 28.06.2016 - 18:09
la source
0

J'ai Alienware 17 R3 et le même problème.

Lorsque je choisis un autre appareil dans alsamixer, puis que je sélectionne par défaut HDA Intel PCH, mon «HP / Speaker Auto Detect» est toujours désactivé. Je peux l'allumer en appuyant sur M, mais cela n'aide pas. La seule réaction est que lorsque vous branchez des haut-parleurs / des écouteurs sur l’une des prises, le son des haut-parleurs internes s’éteint, mais les haut-parleurs / le casque sont silencieux. Par défaut, rien ne se produit lorsque vous utilisez des prises.

De plus, le paramétrage ne se fait pas après le prochain démarrage 'HP / Speaker Auto Detect' est à nouveau désactivé.

Jusqu'à présent, je n'ai trouvé aucun correctif universel et correct, bien que certains affirment que les conseils ci-dessus ont fonctionné pour eux (dans alienware 15, pas sûr de R).

Cependant, j'ai pu trouver une solution à la mauvaise qualité sonore par défaut. Dans Windows, le son était BEAUCOUP mieux que dans Linux où la musique était comme dans une boîte, juste horrible. Au cas où quelqu'un voudrait réparer cela, voici la solution (lisez la fin du sujet):

lien

    
réponse donnée Mike 03.09.2016 - 16:52
la source
0

Cette ligne de commande fonctionne pour moi:

amixer -c 0 sset "HP/Speaker Auto Detect" on

Ajoutez-le à /etc/rc.local pour qu'il s'exécute au démarrage.

    
réponse donnée Drew Gulino 11.09.2016 - 04:55
la source
0
La solution de Karly a fait l'affaire. Je ai aussi un extraterrestres 17 R3 avec Ubuntu 16.04 4.4.0-59-kernal générique, j'ai attendu un correctif depuis trop longtemps. L'équipe de développement audio d'ubuntu a mis à jour le son des impulsions (merci mon Dieu). Je vais élaborer la solution de Karly pas à pas.

  1. wget https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+files/oem-audio-hda-daily-dkms_0.201702030732~ubuntu16.04.1_all.deb
  2. sudo dpkg -i oem-audio-hda-daily-dkms_0.201702030732~ubuntu16.04.1_all.deb
  3. amixer -c 0 sset "HP/Speaker Auto Detect" on
  4. amixer -c 0 sset "HP/Speaker" on
  5. Rebranchez le casque / la prise
  6. Enjoy

pour les autres versions d'ubuntu, vous pouvez accéder à Launch Pad et changez le lien à l’étape 1 et le nom du fichier à l’étape 2

    
réponse donnée M.Harris 03.02.2017 - 12:07
la source

Lire d'autres questions sur les étiquettes