phpStorm perdre la saisie au clavier

51

De temps en temps, phpStorm perdra la saisie de mon clavier. Je peux toujours cliquer, mais cela n'enregistre aucune clé. Les autres fenêtres sont bien. Il faut un redémarrage de phpStorm pour les ramener. Cela semble se produire surtout lorsque je contrôle + Tab entre les onglets ouverts

Je cours: Ubuntu 13.10 phpStorm 7.1 JRE 1.7.0_51

    
posée neolaser 04.02.2014 - 22:44
la source

5 réponses

48

Vous devriez regarder ce bug ici: lien

C'est exactement votre problème et il existe une solution de contournement potentielle:

sudo ibus restart

J'espère que ça aide!

    
réponse donnée Mark Mandel 13.02.2014 - 00:30
la source
5

On dirait que le problème / bogue correct pour OP est bien celui-ci: IDEA-78860

Ce n'est pas une version spécifique à Ubuntu, mais un problème avec X Window / IBus et cela se produit toujours dans Ubuntu 14.04 avec IBus & lt; 1.5.11

Option 1:
Mettre à jour IBus pour 1.5.11 ou supérieur Consultez cette réponse sur comment mettre à jour ibus sur Ubuntu

Option 2:
Solution de contournement officielle, consiste à ajouter la ligne suivante à votre ~ / .profile

export IBUS_ENABLE_SYNC_MODE=1

N'oubliez pas que vous devez redémarrer votre session (déconnexion) pour que cela prenne effet.

Option 3:
La solution de contournement la plus universelle est toujours ibus restart , mais je pense qu'il convient de citer le cessionnaire du problème:

  

Le redémarrage d'IBus n'est pas recommandé (peut provoquer un blocage de l'EDI ultérieurement)

Oui, cela peut arriver tôt ou tard. Cela réinitialise également la disposition de votre clavier à la valeur par défaut (principalement l'anglais). Vous avez donc changé cela chaque fois que vous redémarrez ibus.

Une autre option consiste à désactiver ibus, mais ce n’est pas une solution pour les personnes n’ayant pas de disposition US kb.

    
réponse donnée ruuter 09.02.2016 - 10:57
la source
0
ibus restart && sleep 1 && ibus engine xkb:se::swe

a travaillé pour moi

    
réponse donnée ali moradi 18.11.2015 - 21:31
la source
0

J'évite ce problème en modifiant "Système de saisie du clavier" (Paramètres système & gt; prise en charge linguistique) de "IBus" à "Aucun".

lien

    
réponse donnée Rudger 28.11.2015 - 20:12
la source
0

vous pouvez essayer de supprimer le dossier .idea à la racine de votre projet, puis essayez Fichier → Invalider le cache et redémarrer .

    
réponse donnée Shobi P P 16.10.2017 - 19:35
la source

Lire d'autres questions sur les étiquettes