L'hibernation est toujours absente du menu 13.10 après avoir activé via polkit. Comment activer?

51

Je sais que depuis le 12.04, nous devons ajouter une règle de policykit pour activer l'hibernation (voir la question Comment activer l'hibernation? et la documentation officielle ).

Je parviens à mettre mon ordinateur en mode veille prolongée avec sudo pm-hibernate ou sudo s2disk , de sorte que la règle est en place et fonctionne, mais que l'entrée d'hibernation manque toujours dans le menu.

Je peux voir en regardant à travers la source du paquet indicateur-session (mais ne comprenant pas tout le code) qu'il y a toujours une entrée du menu d'hibernation dans le code et qu'il doit s'afficher lorsque le système est capable d'hiberner. S'il vous plaît, calmez-vous si cela vous rend furieux. Il est très improbable que ce soit un complot , mais plutôt un bogue / une régression à un niveau plus profond, ce qui peut se produire lorsque vous déplacez le code ou le remplacez.

Question : que faut-il faire en 13.10 pour indiquer correctement à indicator-session que le système peut hiberner?

Possibilité de duplication: Hibernation toujours indisponible - Aucune activité, car Sarky était en développement à cette fois, donc hors de portée pour AskUbuntu.

Rapport de bogue associé: lien

    
posée LiveWireBT 19.10.2013 - 13:18
la source

4 réponses

63

14.04 et au-delà

Mitch indique dans sa réponse pour 14.04 et 16.04 que vous devriez vérifier 10-vendor.d/com.ubuntu.desktop.pkla avant de modifier quoi que ce soit. Vérifiez également que Secure Boot est désactivé et que cela ramène l'option de menu.

Réactivation de l’option hibernation dans le menu

Pour réactiver l’option hibernation dans le menu, vous devez modifier votre /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla pour qu’il ressemble à ceci dans saucy (13.10):

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Puis redémarrez ou exécutez killall indicator-session-service dans votre session et vous devriez avoir votre option / menu de mise en veille prolongée. Créez le fichier s'il n'existe pas déjà.

Enquête à partir du rapport de bogue

Citation du post de Jeffery To sur Launchpad Rapport de bogue n ° 1232814 :

  

Pour Saucy, l'indicateur-session a été mis à jour pour utiliser logind   (org.freedesktop.login1) au lieu de upower.

     

Si vous vérifiez   /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla,   vous verrez que la mise en veille prolongée est désactivée par défaut dans les deux   logind.

     

La première étape pour réactiver l’option Hibernate consiste à modifier   /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla   à quelque chose comme:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes
     

Après le redémarrage, le menu de session de l’écran de connexion doit avoir un Hibernate   option.

     

[...]

Tous mes remerciements et remerciements vont à Jeffery!

Pourquoi le mode veille prolongée a-t-il été désactivé?

Il existe un rapport de bogue sur le tableau de bord qui suggère de désactiver la suspension / mise en veille prolongée au lieu de suivre le matériel "certifie" pour quels modes d'alimentation. Elle prétend être une approche plus évolutive.

Une autre chose à mentionner est qu'utiliser UEFI Secure Boot et l'hibernation semble être possible, mais peut constituer un risque pour contourner le premier. ( 1 , 2 ) Pour rappel, lorsque vous utilisez l'hibernation, vous stockez tout dans la RAM sur le disque sans chiffrement, cela inclut les mots de passe pour les systèmes de fichiers et les conteneurs chiffrés.

À un moment donné avec 16.04, j'ai dû désactiver le démarrage sécurisé pour pouvoir mettre en veille prolongée mes ordinateurs portables. Dans mon cas, j'ai utilisé uswsusp et le test avec s2disk a renvoyé le message ci-dessous. Cela peut vous donner une idée que votre problème, vous ne pouvez pas rester en veille même si tout le reste est en place, est lié au démarrage sécurisé:

s2disk: Could not open the snapshot device. Reason: Operation not permitted 

Cependant, comprenez s'il vous plaît que ce n'est pas un endroit pour se plaindre et s'il vous plaît soyez gentil.

Questions connexes

réponse donnée LiveWireBT 20.10.2013 - 16:52
la source
2

Si vous rencontrez toujours des problèmes lors de la mise en veille prolongée, consultez commentez # 58 sur ce rapport de bogue. :

  

J'ai trouvé une solution de contournement sur Ubuntu Gnome 13.10: installez simplement hibernate:

sudo apt-get install hibernate
     

Le seul problème est que la mise à jour émettra trois erreurs au démarrage   up après mise hors tension normale. Pour cela, vous pouvez désactiver le classement:

sudo -H gedit /etc/default/apport
     

Puis changez enabled=0 .

     

Pour modifier les paramètres des fichiers d'édition de mise en veille prolongée dans /etc/hibernate .

L'installation du paquet Hibernate semble faire les bons changements et cela a très bien fonctionné pour moi dans Ubuntu GNOME 13.10 x64

    
réponse donnée cyberalex4life 29.12.2013 - 10:37
la source
1

Si vous avez suivi les étapes précédentes et que cela n'a toujours pas fonctionné, Je suggère que vous modifiez votre /etc/pm/sleep.d/20_custom-ehci_hcd à:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

pour que cela fonctionne, puis suivez les étapes mentionnées ci-dessus pour activer l'option hibernation. Cela a vraiment fonctionné pour moi.

A la fin, vous aurez deux fichiers édités avec " [Re-enable hibernate ... ] " Essayez celui-ci. Cela fonctionnera à coup sûr si vous utilisez Ubuntu 13.10

    
réponse donnée nba-crash 16.02.2014 - 06:19
la source
1

Une chose que je voudrais ajouter ici, à savoir AFAICR, est la partition de swap non montée. Si la partition de swap n'est pas montée, l'option Hibernation ne sera pas affichée / activée quelle que soit la configuration de l'hibernation.

Et si la partition de swap ne se monte pas automatiquement, la session hibernée serait perdue.

    
réponse donnée Bleeding Fingers 29.05.2014 - 19:05
la source

Lire d'autres questions sur les étiquettes