Impossible de localiser le paquet lib32bz2-1.0

46

J'essaie d'installer Simplicity studio sur Ubuntu 15.04 (64 bits) et j'obtiens cette erreur

E: Unable to locate package lib32bz2-1.0
E: Couldn't find any package by regex 'lib32bz2-1.0'

J'ai essayé d'installer le paquet lib32bz2-1.0, encore une fois j'ai la même erreur. Comment installer le paquet lib32bz2-1.0 sur Ubuntu 15.04 (64-bit)

    
posée Rao 16.06.2015 - 13:35
la source

5 réponses

36

Essayez de l’installer manuellement en tapant:

sudo apt-get update
sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

Mise à jour:

si vous supprimez lib32bz2-1.0 , il sera installé avec succès.

sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6

Sinon:

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 libstdc++6:i386 libfontconfig1:i386 libxext6:i386 libxrender1:i386 libgstreamer-plugins-base0.10-0:i386
    
réponse donnée Bilal 16.06.2015 - 13:53
la source
43

Le paquet (32 bits) que vous recherchez est libbz2-1.0:i386 , sa version 64 bits est libbz2-1.0:amd64 .

D'abord, activez le support multi-arch (si ce n'est déjà fait):

sudo dpkg --add-architecture i386

Maintenant, exécutez:

sudo apt-get update

Vous pouvez maintenant installer le package par:

sudo apt-get install libbz2-1.0:i386
    
réponse donnée heemayl 16.06.2015 - 14:17
la source
34

Est-ce que vous essayez d'installer Android Studio sur Ubuntu?

Si vous dites: oui !! Cette réponse est pour vous: -).

Peut-être essayez-vous d'installer Android Studio avec ce tutoriel? . Il a des dépendances obsolètes sur Ubuntu 16.04.

Cette commande a des problèmes:

  

sudo apt-get installer lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc ++ 6

Après quelques recherches sur Google, j'ai trouvé une solution possible dans cet article: Mauvaise dépendance à l'installation commande .

Cette commande spécifie la version 32 bits des bibliothèques supplémentaires dont vous avez besoin pour configurer Android Studio. Cela fonctionne pour moi sur Ubuntu 16.04:

sudo apt-get install libz1 libncurses5 libbz2-1.0:i386 libstdc++6 libbz2-1.0

J'espère que ça aide: -).

    
réponse donnée mrroot5 31.05.2016 - 15:22
la source
7

Cela fonctionne pour moi sur mon Ubuntu 15.04 (64 bits)

sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0:i386 lib32stdc++6
    
réponse donnée Clock ZHONG 15.04.2016 - 20:43
la source
2
sudo apt-get install libz1 libncurses5 libbz2-1.0 libstdc++6

sans 32

    
réponse donnée adri 10.09.2016 - 23:15
la source

Lire d'autres questions sur les étiquettes