L'unité ne se charge pas, pas de lanceur, pas de tiret

533

Lorsque je me connecte, rien ne se passe.

Je suis présenté avec mon fond d'écran.

Pas de tiret, pas de lanceur, rien.

    
posée jrg 14.12.2010 - 18:24
la source

34 réponses

464
  

Cette réponse s’applique aux versions d’Ubuntu exécutant Compiz.

     

Cette réponse suppose qu'Unity est exécuté via Compiz. Si vous n'avez pas compiz installé cette réponse ne vous concerne pas.

Il vous suffit de réactiver le plug-in Unity. Le problème est que c'est une douleur dans le fond parce que vous n'avez plus de méthode graphique pour le faire. Donc:

  1. Essayez d’ouvrir un terminal avec Ctrl + Alt + T .
    Cela peut ne pas fonctionner, mais vous pouvez essayer de cliquer avec le bouton droit de la souris sur le bureau et sélectionner "Ouvrir le terminal ici". Sinon, vous devrez peut-être changer de terminal en appuyant sur Ctrl + Alt + F1 et connectez-vous.

  2. Installez compizconfig-settings-manager en exécutant

    sudo apt-get install compizconfig-settings-manager
    
  3. Ensuite, lancez-le avec ceci:

    DISPLAY=:0 ccsm &
    

    La première partie indique au terminal l’affichage sur lequel vous souhaitez le charger (sinon il n’aura pas d’indice).

  4. Si vous êtes passé à un TTY à l’étape 1, revenez au serveur graphique en appuyant sur Ctrl + Alt + F7 (ou Ctrl + Alt + F8 parfois).
    Un gestionnaire de paramètres CompizConfig devrait vous y attendre.

  5. Trouvez le plug-in Unity. Activez-le On vous demandera "Ubuntu Unity Plugin requiert le plugin OpenGL. Activer le plugin Ubuntu Unity / Activer OpenGL"

  6. Tout devrait entrer en jeu mais si ce n’est pas le cas, vous devrez peut-être redémarrer. Vous pouvez le faire en revenant au terminal et en exécutant sudo reboot .

réponse donnée Oli 08.11.2011 - 00:23
la source
165

Une solution qui me convient (a résolu le même problème):

dans un terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

puis

setsid unity
    
réponse donnée user155373 04.05.2013 - 02:50
la source
72

en 13.04 et 14.04:

unity --replace est obsolète. Utilisez plutôt les éléments suivants:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Redémarrez si cela ne fonctionne pas tout de suite.

    
réponse donnée Brandon Bertelsen 27.04.2013 - 04:39
la source
60

Pour 12.10 et ci-dessous:

Appuyez sur Ctrl + Alt + T pour un terminal et exécutez ccsm , puis réactivez votre plug-in 'Unity'.

Vous devrez peut-être également exécuter unity --replace .

    
réponse donnée xyzzyman 02.10.2011 - 04:33
la source
51

Il est conseillé de vérifier que votre pilote graphique est configuré pour utiliser l’accélération matérielle et qu’il est configuré pour utiliser OpenGL. Essayez de rechercher Ask Ubuntu et Ubuntu Forums pour obtenir des informations spécifiques à vos GPU et à votre saveur Ubuntu. Pour les utilisateurs de graphiques hybrides, voir la dernière section "Graphiques hybrides" ci-dessous.

Vous pourriez vouloir lancer compizconfig-settings-manager et assurez-vous que le plug-in Unity est coché (voir Quels sont les problèmes rencontrés avec CCSM et pourquoi les éviter? ).

pour 12.04 et plus récent

  1. Passez à tty1 en appuyant sur Ctrl + Alt + F1 et connectez-vous.

  2. Installez compizconfig-settings-manager en exécutant

    sudo apt-get install compizconfig-settings-manager
    
  3. Ensuite, lancez-le en faisant ceci:

    export DISPLAY=:0
    ccsm
    

    La première partie indique au terminal l’affichage sur lequel vous souhaitez le charger (sinon il n’aura aucun indice).

  4. Appuyez sur Ctrl + Alt + F7 (ou Ctrl + Alt + F8 parfois) pour revenir à l’affichage graphique sur lequel devrait figurer un écran CompizConfig Settings Manager.

  5. Trouvez le plug-in Unity. Activez-le

  6. Tout devrait entrer en jeu mais si ce n’est pas le cas, vous devrez peut-être redémarrer. Vous pouvez le faire en revenant à tty1 et en exécutant sudo reboot .

Si l'unité ne charge toujours pas, essayez:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Redémarrez si cela ne fonctionne pas tout de suite.

pour 11.10 et plus

Si vous espérez dans un TTY ( Ctrl + Alt + F1 via F6 ) et exécutez:

DISPLAY=:0 unity --replace

Il réinitialisera Unity sur TTY 7 ( Ctrl + Alt + + F7 ).

Vous pouvez aussi essayer simplement:

DISPLAY=:0 unity

Mais cela ne fonctionnera pas si un gestionnaire Windows est déjà en cours d’exécution sur l’écran 0 (cela vous donnera une erreur, utilisez simplement unity --replace dans ce cas).

Si Unity absolument refuse de redémarrer, essayez ceci:

Installer gnome-panel :

sudo apt-get install gnome-panel

Ensuite, lancez-le sur l'affichage 0:

DISPLAY=:0 gnome-panel

Vous devriez alors avoir des panneaux de style Gnome 2 sur votre bureau, que vous pouvez utiliser pour vous déconnecter.

Graphiques hybrides

Vous trouverez des informations très utiles et des lectures supplémentaires pour les utilisateurs de graphiques hybrides ici .

Une fois les GPU configurés correctement pour l’accélération 3D et OpenGL, vous pouvez:

  1. Installez les pilotes Nvidia à partir de lien :

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    ou:

    Je préférerais vraiment le PPA stable , mais ne semble pas avoir de paquets pour 13.04 encore . Mise à jour: celles-ci semblent être disponibles à partir du 25 septembre. Je voudrais installer ce PPA stable - vous pouvez essayer mais je ne l'ai pas testé.

    Les pilotes Nvidia fournis par Ubuntu étaient déjà installés et je me suis simplement installé à partir de ce PPA en l’ajoutant et en effectuant une mise à jour du package en utilisant update-manager .

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installez Bumblebee à partir de lien

    MISE À JOUR: Au 6 octobre, ppa:xorg-edgers/ppa semble contenir également des bourdons. Donc, si vous installez à partir de ce PPA, vous pouvez essayer de sauter l’ajout du PPA Bumblebee et de l’installer à la place.

    Si vous avez choisi le PPA stable à l’étape 1, installez le PPA stable Bumblebee comme suit:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. MISE À JOUR: Après avoir ajouté les PPA, mettez à jour vos listes de paquets:

    sudo apt-get update
    

    Si vous aviez déjà des pilotes nvidia installés à partir des référentiels standard d'Ubuntu, mettez simplement à niveau pour obtenir la nouvelle version du référentiel choisi à l'étape 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Exécutez les commandes suivantes pour "réparer" Unity (de la réponse de brandon-bertelsen à Unity ne se charge pas, pas de lanceur, aucun tableau de bord n'apparaît ):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    
réponse donnée Mark Shuttleworth 27.12.2010 - 13:45
la source
32

La méthode la plus simple consiste à appuyer sur Ctrl + Alt + T pour obtenir un terminal puis émettre:

rm -rf ~/.compiz-1 ~/.config/compiz-1

et votre session d’unité reviendra sous vos yeux ..

Cette technique est préférable à la relance de ccsm, car vous pouvez entrer dans les conditions d'erreur des OP sans même désélectionner accidentellement l'unité dans le ccsm; vous pouvez l'obtenir simplement en appuyant accidentellement sur le bouton "préférences" dans ccsm.

    
réponse donnée achiang 10.11.2011 - 06:55
la source
24

J'ai aussi eu ce problème. Je l'ai résolu en supprimant le contenu du fichier ~ / .config / compiz-1 / compizconfig et le reloger.

rm -rf ~/.config/compiz-1/compizconfig/*
    
réponse donnée dome cs 30.10.2011 - 07:23
la source
21

J'ai eu exactement le même problème.

Si Compiz Config Settings Manager est installé, il se peut que le plug-in Unity Desktop soit désactivé.

Connectez-vous à un bureau 2D Unity et vérifiez qu’il est activé dans CCSM comme celui-ci,

Unity Shell ne se charge pas sur le bureau par défaut si la case à cocher n’est pas cochée et que vous obtenez la session dans votre image.

    
réponse donnée Mark Rooney 22.10.2011 - 09:09
la source
19

Les développeurs corrigent toujours les bogues, donc une alternative consiste à attendre et à suivre les progrès de la correction des bogues ( s'abonner). au développement d'Unity dans Launchpad ).

  1. Appuyez sur Ctrl + Alt + F2 .

  2. Connectez-vous.

  3. Exécutez sudo shutdown -r now dans un terminal.

  4. Sur l’écran de connexion après le redémarrage du système, choisissez Unity 2D (pour l’instant) en cliquant avec le bouton droit sur l'icône du pignon.

  5. Attendez un correctif pour Unity 3D / Ubuntu 11.10 (par exemple une semaine).

  6. Mettez à jour votre système pour obtenir le correctif; dans un terminal tapez sudo apt-get update && sudo apt-get upgrade .

MISE À JOUR: J'ai pu résoudre ce problème en utilisant ccsm , à partir de la connexion Unity 2D.

(Ceci est adapté de cet article sur les forums Ubuntu .)

  1. Dans l'écran de connexion, sélectionnez Unity 2D et connectez-vous.

  2. Installez ccsm (Gestionnaire de paramètres CompizConfig) en exécutant un terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra .

  3. Démarrez ccsm et sélectionnez la catégorie Bureau . Activer le plugin Ubuntu Unity ; Si vous êtes invité à résoudre des conflits, sélectionnez le bouton MIDDLE pour tous les conflits. Fermez ccsm lorsque vous avez terminé.

  4. Redémarrez, sélectionnez Unity (3D) et connectez-vous.

réponse donnée david6 15.10.2011 - 23:47
la source
13

J'ai un Asus U36SD utilisant un "Optimus" (processeurs Intel + Nvidia). Ubuntu 12.04 fonctionnait très bien, mais à 12.10, ce problème est apparu et persiste en 13.04. J'ai réussi à le réparer en suivant les étapes suivantes:

  1. Installez les pilotes Nvidia à partir de lien .

    OU:

    Je préférerais vraiment le PPA stable à lien , mais il ne semble pas y avoir de paquet pour 13.04 encore . Mise à jour: celles-ci semblent être disponibles à partir du 25 septembre. Je voudrais installer ce PPA stable - vous pouvez essayer mais je ne l'ai pas testé.

    Les pilotes Nvidia fournis par Ubuntu étaient déjà installés et je me suis simplement installé à partir de ce PPA en l’ajoutant et en effectuant une mise à jour du package en utilisant update-manager . MISE À JOUR:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    (ce que j'ai fait) ou

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    

    (version stable pour 13.04 maintenant - non testée par moi).

  2. Installez Bumblebee à partir de lien

    MISE À JOUR: Au 6 octobre, ppa: xorg-edgers / ppa semble également contenir des bourdons. Donc, si vous installez à partir de ce PPA, vous pouvez essayer de sauter l’ajout du PPA Bumblebee et de l’installer à la place.

    Si vous avez choisi le PPA stable à l’étape 1, installez le PPA stable Bumblebee comme suit:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. MISE À JOUR: Après avoir ajouté les PPA, mettez à jour vos listes de paquets:

    sudo apt-get update
    

    Si vous aviez déjà des pilotes nvidia installés à partir des référentiels standard d'Ubuntu, mettez simplement à niveau pour obtenir la nouvelle version du référentiel choisi à l'étape 1.:

    sudo apt-get upgrade
    

    Installer Bumblebee

    sudo apt-get install bumblebee
    
  4. Exécutez les commandes suivantes pour "réparer" Unity (à partir de la réponse de brandon-bertelsen à Unity ne se charge pas, pas de lanceur, aucun tableau de bord n'apparaît ):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
    
réponse donnée Thomas Arildsen 02.05.2013 - 12:45
la source
12

L'affiche originale de la question en double, résolue en éditant sa propre question:

  

Solution trouvée: Supprimer .Xauthority chez moi (ou le renommer)

    
réponse donnée mateo_salta 08.08.2012 - 22:41
la source
10

Pour 13.10:

Juste pour être sûr que tout est installé:

sudo apt-get install --reinstall unity ubuntu-desktop

Ensuite, rechargez tout:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

Je viens d’essayer et ça marche!

Source:

lien

Si tout le reste échoue:

Rappelez-vous, faites toujours des sauvegardes! Cependant, parfois une nouvelle installation est bonne, réinstallez Ubuntu?

    
réponse donnée Jared Burrows 06.12.2013 - 01:07
la source
10

Cela m’est arrivé aussi dans Ubuntu 16.04 après une mise à jour des packages unit et compiz. Aucune de ces réponses n'a fonctionné.

La seule façon de retrouver des lanceurs et des tirets était de supprimer (sans être connecté à Unity) le répertoire .cache de ma maison.

    
réponse donnée lorenzo-bettini 20.09.2016 - 09:27
la source
9

Il semble qu'il y ait un problème avec 12.04 Unity 3D et les pilotes Nvidia actuels.

Voir cet article (Unity 3d ne fonctionne plus après l'installation) 12.04) pour savoir comment contourner le problème.

J'ai un Compaq D520SFF Pentium 4 3.06 GHz 32 bits, avec une Nvidia GeForce 6200, exécutant le noyau 3.2.0-24-generic-pae, et qui avait exactement le même problème (travaux 2D, 3D pas) et rétrograder les pilotes Nvidia a permis à la 3D de fonctionner en quelques minutes.

    
réponse donnée Heimdall 01.05.2012 - 01:38
la source
8

Pour les icônes, il est dû à Nautilus. Ecrivez nautilus & dans un terminal, ne le fermez pas et les icônes seront de retour.

EDIT 10/10/2013 : pour Nautilus, vous pouvez également taper Alt + F2 pour ouvrir l’invite de la ligne de commande Unity et écrire nautilus dans la CLI de recherche / invite globale. Un explorateur de fichiers s'ouvrira. Vous pouvez le fermer si vous voulez.

    
réponse donnée air-dex 26.12.2012 - 16:14
la source
8

J'ai eu un problème similaire:

L'unité avec 14.04 en combinaison avec IBM Notes9 a entraîné un comportement étrange (les clics de souris cesseraient de fonctionner). Ma solution de contournement pour cela était d'ouvrir un terminal et de redémarrer l'unité en tapant unity & .

La dernière fois que j'ai fait ça, ça a totalement corrompu l'unité - le pas de tiret, pas de lanceur, rien. Je pense que j'ai essayé chaque suggestion qui est répertorié sur cette page - rien n'a aidé.

Mais un collègue a finalement eu la réponse qui a fonctionné pour moi:
J'ai installé l'outil d'unité-tweak; que j'ai couru unity-tweak-tool --reset-unity et redémarré.

Après, l’unité est revenue en vie. Evidemment, tous les changements de configuration antérieurs à l'unité ont disparu, mais c'est ce que --reset-unity représente.

Et le gros avantage de cette solution: vous n’aurez besoin que d’ajouter un seul paquet et de refaire vos modifications de configuration unitaires - mais vous n’avez pas à réinitialiser compiz, installer ccsm ou suivre toutes les autres activités longues.

Mise à jour:

La autre solution que je trouve très utile de nos jours provient de ici - le point : parfois vous devez supprimer (ou même mieux: insérer une sauvegarde "de travail") de votre fichier ~ / .config / dconf / user.

    
réponse donnée GhostCat 04.06.2014 - 12:21
la source
6

Si vous espérez dans un tty ( Ctrl + Alt + F1 via F6 ) et exécutez:

DISPLAY=:0 unity --replace

Il réinitialisera Unity sur tty 7 ( Ctrl + Alt + + F7 ).

Vous pouvez aussi essayer simplement:

DISPLAY=:0 unity

Mais cela ne fonctionnera pas si un gestionnaire Windows est déjà en cours d’exécution sur l’écran 0 (cela vous donnera une erreur, utilisez simplement unity --replace dans ce cas).

Si Unity absolument refuse de redémarrer, essayez ceci:

Installer gnome-panel :

sudo apt-get install gnome-panel

Ensuite, lancez-le sur l'affichage 0:

DISPLAY=:0 gnome-panel

Vous devriez alors avoir des panneaux de style Gnome 2 sur votre bureau, que vous pouvez utiliser pour vous déconnecter.

Je trouve que Unity est vraiment bogué le 13.04 avec ma carte Nvidia .. YMMV.

    
réponse donnée Seth 19.05.2013 - 20:07
la source
5

J'ai eu environ 3 fois où j'avais besoin de Ctrl + Alt + F1 pour ne pas perdre le travail et ça a foiré ... J'ai aussi nvidia. Je voudrais suggérer ceci:

Ctrl + Alt + F1 (ok, écran vide) Tapez votre identifiant, appuyez sur Entrée, puis sur mot de passe (tout est vide) tapez ceci maintenant:

sudo startx -- :1

devra taper à nouveau le mot de passe et Enter cela ouvrira une session X à Ctrl + Alt + F8 créez maintenant un nouveau fichier texte vide appelé runBash.sh et tapez-le:

bash

sauvegardez-le, changez ses permissions en exécutable, et lancez-le, vous obtiendrez un terminal vraiment relaxant qui vous rappellera pourquoi Linux est bon! : D

après avoir terminé, souvenez-vous de Ctrl + Alt + F1 , appuyez sur Ctrl + C (mettra fin à la nouvelle session X), tapez exit, Enter, mettra fin à la session du terminal (écran vide). Si vous pensez que vous avez manqué la frappe, tapez simplement sur Ctrl + C et tapez à nouveau, ne le faites pas trop vite.

pour que vous puissiez l’améliorer, créez un script pour vous permettre de taper le moins possible, mais vous devrez quand même taper beaucoup pendant que l’écran est vide, mais il vaut mieux que rien:)

Toujours à la recherche de Ctrl + Alt + F1 solution correcte Ubuntu 12.04 + nvidia.

    
réponse donnée Aquarius Power 28.05.2012 - 01:39
la source
4

Si vous utilisez une carte graphique d’accélération avec la carte graphique par défaut, cela est probablement dû à l’installation de leurs pilotes. Quelques mises à jour de pilotes de cartes graphiques d'accélération dans des systèmes dotés de deux cartes graphiques ont tendance à présenter un comportement instable dans certains systèmes. J'ai une carte Nvidia et une carte Intel. Cela arrivait avec moi lorsque j'ai installé des pilotes Nvidia. Le lanceur et le panneau disparaissent du bureau. Si vous utilisez une carte Nvidia, l'installation de Bumblebee pourrait être une solution temporaire: lien

    
réponse donnée user153634 01.05.2013 - 12:46
la source
4

La première réponse fonctionne correctement, sauf que je devais installer Unity lui-même:

sudo apt-get install unity

puis lancez:

ccsm

et activer Unity:)

    
réponse donnée sobi3ch 26.11.2013 - 02:22
la source
4

J'ai eu à peu près le même problème sous 12.04. L'unité était lente avec mon ancien GPU, alors j'utilisais Unity 2d comme bureau pendant des mois. Pour aucune raison apparente, il a soudainement refusé d'afficher le tableau de bord et la barre de titre (pour tous les utilisateurs). Réactiver Unity dans CCSM comme suggéré ici faisait partie de la solution, mais aucune des autres mesures suggérées ici, là ou dans plusieurs autres threads connexes, y compris, mais sans s'y limiter:

  • Réinstallation de l'unité

  • Réinstallation du bureau ubuntu

  • Suppression de toutes les informations de configuration pertinentes (par exemple, compiz, gconf, etc.)

m'a aidé à résoudre complètement ces symptômes sous 12.04 (64 bits).

unity --reset

ne fonctionnerait pas pour moi. Après avoir envoyé divers messages d’erreur et d’information, il s’arrêtait toujours à:

Setting Update "run_key"

comme indiqué dans le journal publié dans le sujet intitulé "L'unité a disparu" pour l'unité exécutée sans arguments .

J'ai remarqué que le message d'erreur envoyé par:

/usr/lib/nux/unity_support_test -p

était similaire à certaines des erreurs signalées par unity --reset :

erreur lors du chargement des bibliothèques partagées: libGL.so.1: impossible d'ouvrir le fichier objet partagé: aucun fichier ou répertoire de ce type.

Après des recherches approfondies, j'ai trouvé la solution suivante:

  • Obtenez le chemin d'accès de libGL.so.1 en utilisant la commande locate libGL.so.1 .

  • Ajoutez un lien vers la bibliothèque dans / usr / lib / comme indiqué dans l'exemple suivant:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib
    

    (avec la permission de JD Bartlett )

  • Redémarrez l'ordinateur.

Cela permettait non seulement à la fois unity_support_test-p et unity --reset de s'exécuter, mais cela permettait également à Unity 2D de démarrer. Je n'ai aucune idée de ce qui a causé mes problèmes, mais depuis la création des liens ci-dessus (plusieurs semaines maintenant), je n'ai plus eu de problèmes.

    
réponse donnée R B 20.12.2013 - 11:42
la source
4

Lorsque je suis accidentellement passé de 12.04 LTS Ubuntu à 13.04, je devais moi aussi faire face aux mêmes problèmes tels que la barre de menu latérale manquante, aucune option de fenêtre, ne pas pouvoir basculer entre les applications ( alt - tab ) et je ne pouvais même pas faire glisser des fenêtres à l’écran. Après avoir suivi autant d'options, j'ai fini avec les commandes suivantes pour résoudre ces problèmes.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

redémarrer (vous pouvez utiliser sudo reboot )

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

redémarrer (vous pouvez utiliser sudo reboot )

dconf reset -f /org/compiz/
unity --reset-icons & disown

En fait, j'ai supprimé aspell en raison d’une dépendance conflictuelle. Cela n'a peut-être aucune corrélation entre ce problème. Je pense que réinstaller lightdm et réinitialiser compiz m'a aidé à résoudre ce problème.

    
réponse donnée Bunti 16.05.2014 - 18:20
la source
4

Cela se produit lorsque vous vous connectez avec un autre tty et essayez, en tant que même utilisateur, de démarrer X (avec startx ou initx).

Par exemple, Ubuntu s'exécute dans tty7. Avec Ctrl + Alt + F1 tty1 s'ouvre. Connectez-vous en tant que même utilisateur et exécutez startx. Revenez à tty7, déconnectez-vous et connectez-vous. Vous obtenez uniquement le papier peint de bureau.

Pour résoudre le problème, choisissez tty1, connectez-vous, supprimez le fichier .Xauthority de votre répertoire personnel, déconnectez-vous, connectez-vous. Résolu

    
réponse donnée user85164 27.04.2013 - 08:59
la source
2

J'ai eu le même problème après avoir fait sudo apt-get install kubuntu-desktop qui a cassé mon installation lightdm pour une raison quelconque. Je cours 16.04 ici.

Appuyez sur ctrl - alt - F1 pour accéder au terminal, puis:

sudo service lightdm stop
sudo apt-get remove lightdm
sudo apt-get update && sudo apt-get install lightdm
sudo reboot

Cela m'a réparé après des heures de retrait des cheveux.

    
réponse donnée localhost 07.10.2016 - 17:29
la source
2

Travaillé pour Ubuntu 16.04:

Je réinitialise compizconfig en supprimant son cache (en fait, la commande effectue une sauvegarde pour pouvoir la restaurer).

Exécutez les commandes et déconnectez les mots suivants:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-backup

setsid unity

Attention: cela supprime votre configuration Unity personnalisée.

    
réponse donnée Oleksandr Shpota 09.03.2018 - 00:49
la source
1

J'ai le même problème et résolu en utilisant pycharm's terminal .

 - Go to my-computer -> user -> share ->  
 - open pycharm and its terminal
 - sudo apt-get update
 - sudo apt-get upgrade 
 - sudo apt-get install --reinstall ubuntu-desktop
    
réponse donnée Muhammad Taqi 02.06.2015 - 14:26
la source
1

Apparemment, le fait de débrancher mon deuxième moniteur était le correctif, puis j'ai pu installer et mettre à jour les bons pilotes.

    
réponse donnée user2580915 27.07.2015 - 20:08
la source
1

J'ai essayé plusieurs des solutions mentionnées dans ce fil ainsi que d’autres. Finalement cela a fonctionné pour moi:

dconf reset -f /org/compiz/

alors

setsid unity

Merci à tous pour votre contribution.

    
réponse donnée Ashu 17.01.2016 - 02:00
la source
1

Aujourd'hui, j'ai rencontré une situation où l'utilisateur de mon script a décidé de le lancer en plaçant l'appel au script dans son fichier $HOME/.profile . En conséquence, Unity n'a pas pu lancer.

Les scripts par nature sont séquentiels, donc .profile attendait essentiellement que le script se termine, et Unity ne pouvait pas démarrer si .profile n'avait pas terminé son exécution.

J'ai fait la même chose, j'ai appelé le script de .profile , et j'ai reçu le même résultat - mon fond d'écran de connexion est resté là, aucun tiret ou lanceur n'est apparu, Connectez-vous à TTY1.

La solution consistait à supprimer la ligne appropriée du .profile . Il est possible de détacher une commande de .profile à l'aide de l'esperluette, <command> & , mais le problème est que chaque fois que l'utilisateur ouvre un terminal ou se connecte à TTY, une nouvelle instance de cette commande est générée. Par conséquent, je vous recommande fortement de ne lancer aucun programme de .profile à moins de savoir ce que vous faites.

Lien vers le script original et discussion ici: lien

    
réponse donnée Sergiy Kolodyazhnyy 28.02.2016 - 04:10
la source
1

J'ai eu ce problème, j'ai essayé un tas de choses et même activé l'unité, mais rien n'a fonctionné. Tout d'abord, vous devez ouvrir TTY (ctrl + alt + F1) et vous connecter. Maintenant, utilisez

    env DISLAY:=0 gnome-terminal        

Fermez TTY avec ctrl + alt + F7, puis utilisez (dans le terminal)

dconf reset -f /org/compiz/

Après ça, utilisez

sudo reboot
    
réponse donnée TheEpicstarlord 07.01.2017 - 14:09
la source

Lire d'autres questions sur les étiquettes