Apache ne peut pas redémarrer

50

Essayer de redémarrer apache depuis le terminal en utilisant la commande suivante:

 sudo service apache2 restart

lors de l’exécution de cette commande qui tombe en dessous de l’erreur:

Job for apache2.service failed. See "systemctl status apache2.service" and "journalctl -xe" for details.

Après avoir dépassé "systemctl status apache2.service", la sortie était inférieure à la sortie

apache2.service - (null)
   Loaded: loaded (/etc/init.d/apache2)
   Active: failed (Result: exit-code) since Sat 2015-05-30 02:22:41 IST; 12s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 4866 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

apache error.log

AH00489: Apache/2.4.12 (Unix) configured -- resuming normal operations
AH00094: Command line: '/usr/local/apache2/bin/httpd'
    
posée Gautam Savaliya 29.05.2015 - 22:48
la source

10 réponses

42

Peut-être que cela aidera à trouver la cause:

journalctl | tail

Dans mon cas, c'était une erreur dans le fichier de configuration:

AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/mydomain-wsf.lan.conf
    
réponse donnée Arek 18.08.2015 - 12:16
la source
29

Il y a une erreur de syntaxe dans le fichier apache2.conf

Dans le type de terminal:

  

cd / etc / apache2

alors:

  

apache2ctl configtest

Il vous montrera où est l'erreur dans le fichier apache2.conf à corriger.

    
réponse donnée rancho 01.08.2016 - 20:31
la source
14

Le problème est que certains fichiers de configuration sont supprimés, vous devez le réinstaller.

REINSTALL APACHE2:

Pour remplacer les fichiers de configuration qui ont été supprimés, sans purger le package, vous pouvez le faire:

sudo apt-get -o DPkg::Options::="--force-confmiss" --reinstall install apache2

Pour supprimer complètement les fichiers de configuration apache2, vous devez:

sudo apt-get purge apache2

qui vous permettra ensuite de le réinstaller de la manière habituelle avec:

sudo apt-get install apache2

Purger est nécessaire pour supprimer tous les fichiers de configuration - si vous supprimez les fichiers de configuration mais ne supprimez que le paquet, vous vous en souviendrez & amp; les fichiers de configuration manquants ne sont pas réinstallés par défaut.

Puis REINSTALL PHP5:

apt-get purge libapache2-mod-php5 php5 && \
apt-get install libapache2-mod-php5 php5
    
réponse donnée Rujika Rajan 15.03.2016 - 11:06
la source
2

J'ai reçu la même erreur après avoir supprimé un hôte virtuel. Le problème était que le fichier de configuration SSL persistant associé à cet hôte se trouvait dans /etc/apache2/sites-enabled . Le SSL était par Let 's Encrypt, donc le code à supprimer était:

sudo rm yourdomain.com-le-ssl.conf
    
réponse donnée iMarketingGuy 01.03.2017 - 20:47
la source
1

Problème:

Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details.

Solution:

  • Pour supprimer complètement les fichiers de configuration apache2, vous devez:

    1) sudo apt-get purge apache2

  • qui vous permettra ensuite de le réinstaller de la manière habituelle avec:

    2) sudo apt-get install apache2

== & gt; Ca marche bien ...

merci ....

    
réponse donnée Riyal Padhiyar 27.12.2016 - 08:12
la source
1

vous avez probablement une erreur de syntaxe. pour moi, c'était dans mon dossier "sites-enabled".

J'ai mal orthographié 'ServerAlias' sur 'ServerAlisa'.

    
réponse donnée Bruce Tong 15.09.2017 - 14:12
la source
0

Ceci est principalement une erreur de configuration. Je viens tout juste d'avoir un ancien site activé sur Apache, ce qui a causé cette erreur. Je devais donc le désactiver avant de recharger Apache.

sudo a2dissite <my-site>
sudo service apache2 reload

Problème résolu:)

    
réponse donnée Thomas Venturini 20.08.2016 - 08:15
la source
0

Merci pour votre aide! J'ai pu installer correctement avec Solution:

Pour supprimer complètement les fichiers de configuration apache2, vous devez:

  1. sudo apt-get purge apache2 qui vous permettra ensuite de le réinstaller de la manière habituelle avec:

  2. sudo apt-get install apache 2

Cela fonctionne maintenant très bien.

    
réponse donnée Renata Sembay 16.01.2017 - 02:41
la source
0

Je pense que le problème est que vous avez un site activé mais que vous avez supprimé son fichier de configuration. Essayez de désactiver le site avec     sudo a2dissite "nom" puis redémarrez le serveur apache. Au moins, c’était le problème pour moi et cette action l’a résolu.

    
réponse donnée Ilias Koritsas 16.05.2017 - 16:56
la source
0

J'ai les mêmes erreurs en travaillant avec .htaccess

Je viens de mettre cette commande

<Directory /var/www/html>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
</Directory>

dans /etc/apache2/sites-enabled/000-default.conf ce dossier

après avoir ajouté ceci, j'ai eu l'erreur

puis je supprime cette paix de commande du fichier et mon erreur a résolu.

    
réponse donnée Kaushikdjay 26.07.2017 - 07:48
la source

Lire d'autres questions sur les étiquettes