Comment désactiver toutes les animations Unity?

43

Si ce n'est pas possible, alors peut-être que les animations Dash show / hide. J'attends simplement des animations inutiles.

    
posée Bucic 17.05.2012 - 22:33
la source

5 réponses

26

1. Pourquoi vous ne pouvez pas désactiver cette animation Dash dans Unity 12.04

  • Malheureusement, l’animation de fondu / opacité et les temps associés sont codés en dur dans le code source Unity.
  • Le code actuel se trouve dans unity-5.12/plugins/unityshell/src/ShortcutController.cpp (c'est ce que vous devez modifier et recompiler pour vous débarrasser des animations)
  • Quelques exemples de lignes de ce fichier démontrant le codage en dur de l’animation lorsque vous utilisez la touche Super pour lancer le Dash:

    30:const unsigned int SUPER_TAP_DURATION = 650;
    31:const unsigned int FADE_DURATION = 100;
    39:  , fade_in_animator_(FADE_DURATION)
    40:  , fade_out_animator_(FADE_DURATION)
    65:  fade_in_animator_.animation_updated.connect(sigc::mem_fun(this, &Controller::OnFadeInUpdated));
    66:  fade_in_animator_.animation_ended.connect(sigc::mem_fun(this, &Controller::OnFadeInEnded));
    67:  fade_out_animator_.animation_updated.connect(sigc::mem_fun(this, &Controller::OnFadeOutUpdated));
    68:  fade_out_animator_.animation_ended.connect(sigc::mem_fun(this, &Controller::OnFadeOutEnded));
    120:    show_timer_ = g_timeout_add(SUPER_TAP_DURATION, &Controller::OnShowTimer, this);
    149:    self->fade_out_animator_.Stop();
    150:    self->fade_in_animator_.Start(self->view_window_->GetOpacity());
    213:    fade_in_animator_.Stop();
    214:    fade_out_animator_.Start(1.0 - view_window_->GetOpacity());
    244:  .add("timeout_duration", SUPER_TAP_DURATION + FADE_DURATION)
    246:  .add("about_to_show", (Visible() && !fade_out_animator_.IsRunning() && view_window_ && view_window_->GetOpacity() != 1.0f))
    247:  .add("about_to_hide", (Visible() && !fade_in_animator_.IsRunning() && view_window_ && view_window_->GetOpacity() != 1.0f))
    
  • Bien sûr, vous devrez corriger cela et reconstruire avec chaque nouvelle mise à jour d'Unity ...

  • Il n’est pas possible d’interférer avec Compiz car tout est codé en dehors du plugin Compiz.

2. Alternative A: Basculer vers Ubuntu 2D

Ubuntu 2D a un code Unity Shell différent, et le lancement du tableau de bord via Super est instantané et n’anime rien.

3. Alternative B: Utilisez un raccourci personnalisé pour lancer le Dash en cliquant sur le logo Ubuntu, contournant ainsi l'animation

Nous pouvons exploiter le fait que l’opacité / l’animation par fondu ne se produit pas lorsque vous lancez le Dash via le bouton "Démarrer", ou, si votre curseur est sur / autour de la barre de lancement, même si vous appuyez sur Super:

L’animation sera retardée jusqu’à ce que votre curseur se déplace réellement dans la zone de tiret.

  1. xdotool permet l'automatisation des clics / mouvements du clavier et de la souris; installez-le avec sudo apt-get install xdotool
  2. Ouvrir les paramètres ... Clavier et aller dans l'onglet Raccourcis. Créez un raccourci personnalisé, nommez-le comme vous voulez et définissez la "Commande" sur:

    xdotool mousemove --sync 25 60 click 1 --delay 100  mousemove restore
    

    • Vous devrez peut-être ajuster légèrement les coordonnées (25 60) si la résolution de votre écran est inférieure à 1024x768 ou plus.
  3. Cliquez sur Appliquer. La colonne de droite indique "Désactiver", cliquez dessus et vous verrez "Nouvel accélérateur": appuyez sur la combinaison de touches de raccourci. Vous ne pouvez pas choisir Super , même si vous le désactivez dans Compiz, car il est capturé par Unity. J'ai choisi Ctrl+Alt+Z car il est proche de la clé Super.

  4. Votre raccourci devrait maintenant lancer le Dash beaucoup plus rapidement.

    • Voici une vidéo de démonstration sur Youtube . Les premières fois (lorsque le lanceur à gauche est flou et s'assombrit) sont avec la touche SUPER; puis c'est avec le raccourci xdotool personnalisé (notez que le lanceur ne s'anime plus et que le tiret apparaît plus rapidement)
réponse donnée ish 29.07.2012 - 15:18
la source
23

Installez Compiz Configuration Manager.

Centre logiciel Ubuntu: Gestionnaire de configuration Compiz

ou

Terminal: sudo apt-get install compizconfig-settings-manager

Une fois installé, ouvrez-le et accédez à Ubuntu Unity Plugin - & gt; Experimental (Tab)

De là, vous pouvez définir Lauch Animation , Urgent Animation et Dash Blur sur "Aucun".

Définissez le Hide Animation sur Slide only .

Si vous le souhaitez, vous pouvez modifier la transparence du tableau de bord et du tiret pour qu’elle soit totalement opaque.

    
réponse donnée Angel Araya 17.05.2012 - 22:46
la source
6

Désolé, vous ne pouvez pas. À ce stade (le 25 juillet 2012), avec Ubuntu 12.04 LTS, il existe un moyen simple de désactiver les animations Unity. (au moins sans recompilation).

Et je ne pense pas, il y aura une option pour désactiver les animations dans les futures versions. Car, L'un des objectifs d'Unity est de fournir une expérience utilisateur agréable et les animations sont considérées comme l'un des meilleurs moyens d'y parvenir.

Une solution de contournement:

La solution de contournement possible pour vous est de changer l’animation de tiret en fondu (cause, à mon avis, les fondus sont plus rapides que le glissement). Vous pouvez également vous intéresser à la désactivation des animations pour toutes les fenêtres également. Pour ce faire,

  1. Téléchargez et installez compizconfig-settings-manager

    sudo apt-get install compizconfig-settings-manager  
    
  2. Ouvrez-le en recherchant ou en tapant ccsm dans le tiret. Accédez à l'onglet Unity plugin Experimental et modifiez les paramètres de Masquer les animations en Fondu uniquement .

Si vous souhaitez désactiver les animations dans toutes les fenêtres, vous pouvez désactiver le plug-in Animations dans ccsm. Si vous souhaitez désactiver le fondu, désactivez les plug-ins Fenêtres de fondu .

J'espère que cela vous aidera.

Modifier: Comme le montre izx dans sa réponse modifiée , vous voyez clairement que les options des animations de tiret sont codées en dur dans Unity, et celles-ci ne peuvent être modifiées avec aucune option de configuration, car ces durées ne sont pas variables et peuvent être modifiées. Donc, cela signifie que vous devez recompiler l'unité en modifiant ces durées à 0 ms pour désactiver complètement les animations.

    
réponse donnée Anwar 13.04.2017 - 14:23
la source
2

Pour ajouter à les instructions d’Angel Araya : J'ai pu désactiver toutes les animations en désélectionnant Animations et Fading Windows (essentiellement tout sauf Window Decoration sous la catégorie (tab) Effects dans le gestionnaire de paramètres CompizConfig.

    
réponse donnée Dune 17.06.2012 - 06:16
la source
1

Je pense que désactiver les fenêtres de fondu sous les effets dans le Gestionnaire de paramètres CompizConfig peut faire la différence dans Unity. (Une différence de vitesse subtile, mais toujours une différence.)

    
réponse donnée Rob 08.02.2013 - 18:53
la source

Lire d'autres questions sur les étiquettes