Comment forcer SSH à autoriser uniquement les utilisateurs avec une clé à se connecter?

46

J'ai essayé de suivre les instructions ici: lien

Autoriser uniquement les utilisateurs disposant d'une clé publique sur le serveur à s'authentifier, mais je ne peux pas empêcher SSH d'interdire la connexion avec uniquement un nom d'utilisateur / mot de passe.

Voici mon fichier sshd_config - est-ce que je manque quelque chose? J'ai déjà essayé de redémarrer SSH et l'ordinateur lui-même.

# Package generated configuration file
# See the sshd_config(5) manpage for details


# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes


# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768


# Logging
SyslogFacility AUTH
LogLevel INFO


# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes


RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile        %h/.ssh/authorized_keys


# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes


# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no


# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no


# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication no


# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes


# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes


X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no


#MaxStartups 10:30:60
#Banner /etc/issue.net


# Allow client to pass locale environment variables
AcceptEnv LANG LC_*


Subsystem sftp /usr/lib/openssh/sftp-server


# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM no
    
posée user193805 18.09.2013 - 00:35
la source

5 réponses

66

Par défaut, PasswordAuthentication est défini sur yes, même si vous le commentez. C'est le cas dans votre /etc/ssh/sshd_config .

Vous devez définir explicitement PasswordAuthentication no pour autoriser uniquement l’authentification par clé publique.

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

Et redémarrez sshd service ssh restart (migration pré-systemd) ou systemctl restart sshd.service .

    
réponse donnée Terry Wang 18.09.2013 - 00:51
la source
8

Selon cette page wiki sur les clés SSH et ce answer , vous devez modifier ces deux lignes dans votre sshd_config :

PasswordAuthentication no
ChallengeResponseAuthentication no
    
réponse donnée Andy J 25.11.2014 - 10:21
la source
4

Dans /etc/ssh/sshd_config , les paramètres ci-dessous fonctionnaient pour moi:

PasswordAuthentication no
UsePAM no

Enfin, redémarrez le démon sshd .

    
réponse donnée BTR Naidu 09.10.2015 - 10:27
la source
3

La ligne que vous souhaitez est anormalement mise en commentaire par défaut dans le fichier sshd_config.

# Change to no to disable tunnelled clear text passwords
--->#PasswordAuthentication yes

Pour désactiver les mots de passe, remplacez yes par no et supprimez le commentaire :

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no
    
réponse donnée Nolan Hergert 07.09.2015 - 21:30
la source
1

de lien : En général, le répertoire de base de l'utilisateur ou tout fichier ou répertoire contenant des fichiers de clés ne doit être accessible en écriture que par quiconque. Sinon, quelqu'un d'autre pourrait ajouter de nouvelles clés autorisées pour l'utilisateur et y accéder. Les fichiers de clés privées ne doivent être lisibles par personne d'autre.

Essayez avec sudo chmod go-rwx /home/username/ en remplaçant username selon le cas.

    
réponse donnée Diego Alonso Reyes Molina 07.11.2017 - 22:13
la source

Lire d'autres questions sur les étiquettes