Comment puis-je installer Adobe AIR?

153

Je suis un gros utilisateur de certaines applications construites sur AIR.

Il semble que AIR ait cessé de prendre en charge Linux. Même les anciennes versions des archives Adobe AIR semblent ne prendre en charge que les distributions Linux 32 bits et je suis actuellement sur 64 bits.

Y a-t-il même une légère possibilité que je puisse exécuter AIR dans ces conditions? Si oui, pouvez-vous s'il vous plaît me dire où puis-je obtenir une installation détaillée étape par étape pour cela?

    
posée Vamsi Emani 13.12.2011 - 15:51
la source

8 réponses

225

J'ai besoin d’Air pour environ trois programmes - YNAB, LongTailPro, Xtend:

  1. Téléchargez la dernière version Air 2.6.0 pour Linux sur votre bureau:

  2. Ctrl + Alt + T pour ouvrir le terminal

  3. sudo apt-get install ia32-libs - (32 bits si vous voulez l'exécuter dans Ubuntu x64; si vous avez des problèmes, consultez " ia32-libs-multiarch mais ce n'est pas installable "- Solution )

  4. cd Desktop (changez le répertoire dans le répertoire du bureau)

  5. chmod +x AdobeAIRInstaller.bin (changer de mode - exécuter la permission oui)

  6. ./AdobeAIRInstaller.bin (après avoir accepté la licence Adobe Air, il vous demandera votre mot de passe; il doit disposer d’un accès root pour pouvoir l’installer)

Peut-être aurez-vous une erreur après la dernière commande?

  

Désolé, une erreur est survenue. Adobe AIR n'a pas pu être installé. Installez Gnome Keyring ou KDE KWallet avant d'installer Adobe AIR.

Ceci peut être corrigé:

  • Dans un terminal (raccourci par défaut: Ctrl + Alt + T), tapez:

    locate libgnome-keyring.so
    
  • Ceci est mon résultat (le vôtre pourrait être différent):

    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0
    
  • Comme suggéré ci-dessous par @jmendeth, la manière la plus simple de dire à l'installateur où trouver ces fichiers est d'utiliser LD_LIBRARY_PATH:

    • Pour Ubuntu 32 bits (testé le 12.04):

      LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu ./AdobeAIRInstaller.bin
      
    • Pour Ubuntu 64 bits, la ligne de commande serait probablement:

      LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu ./AdobeAIRInstaller.bin
      

Si le truc LD_LIBRARY_PATH ne fonctionne pas, vous pouvez essayer ceci:

  • Créez un lien symbolique vers les chaînes d’emplacement que vous avez trouvées avec les commandes précédentes:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Utilisez les commandes suivantes pour les systèmes 32 bits:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Répétez ensuite l'étape 4 & amp; 6 (passez 5, car l'autorisation d'exécuter le fichier n'a pas changé).

  • Supprimez les liens symboliques après l'installation d'Adobe AIR 2.6.0:

    sudo rm /usr/lib/libgnome-keyring.so.0
    sudo rm /usr/lib/libgnome-keyring.so.0.2.0
    

Référence:

  • lien
réponse donnée bashpotato 09.04.2012 - 04:26
la source
43

Ubuntu 13.10, 14.04, 15.04 et 15.10 (64 bits)

  1. Installez les bibliothèques i386 nécessaires à l’installation et à l’exécution réussies des applications Adobe Air et air.

    sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386
    
  2. Installer le package libgnome-keyring0:i386 .

    sudo apt-get install libgnome-keyring0:i386
    
  3. Créez des liens symboliques vers gnome-keyring pour qu'Adobe Air puisse les voir.

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0 
    
  4. Téléchargez le programme d'installation d'Adobe Air depuis ici .

  5. Autorisez l'exécution, puis exécutez ce fichier .bin.

    sudo chmod +x AdobeAIRInstaller.bin
    sudo ./AdobeAIRInstaller.bin
    

Source

Note pour Ubuntu 16.04 (64 bit)

Pour Ubuntu 16.04 et versions ultérieures, installez le package libnss-mdns:i386 au lieu du package lib32nss-mdns . Cela résoudra le problème de "Package not found error" lié à ce package.

    
réponse donnée Avinash Raj 29.03.2014 - 00:36
la source
18

Vous pouvez également installer un fichier .deb

L’air 2.6 (dernier Linux pris en charge) est disponible ici pour les deux architectures (les deux utilisent 32 bits en dessous mais au moins cela fonctionne). Merci à prusswan de l’avoir signalé.

Assurez-vous d’avoir les librairies 32 bits dont il aura besoin:

sudo apt-get install ia32-libs

J'ai téléchargé celui d’AMD64 (adobeair_2.6.0.19170_amd64.deb) et installé sur mon ordinateur (am64 avec Precise Pangolin 12.04)

sudo dpkg -i adobeair_2.6.0.19170_amd64.deb

Ensuite, j'ai installé l'application qui nécessitait Adobe Air en premier lieu et cela a fonctionné.

Mise à jour pour Ubuntu 13:10 + ,

Essayer cette technique, j'obtiens "Le package ia32-libs-gtk n'est pas installé"

J'ai cherché le package et essayé d'installer ces dépendances et autres packages associés que je peux penser de directement:

sudo apt-get install gtk2-engines:i386 libart-2.0-2:i386 libcairo2:i386 libcanberra-gtk0:i386 libdatrie1:i386 libgail-common:i386 libgconf2-4:i386 libgtk2.0-0:i386 liblua5.1-0:i386 libpango1.0-0:i386 libpixman-1-0:i386 libqt4-network:i386 libqt4-test:i386 libqtcore4:i386 libthai0:i386 libbonobo2-0:i386 libglade2-0:i386 libgnomecanvas2-0:i386 libidl0:i386 liborbit2:i386 libwmf0.2-7:i386 gtk2-engines-murrine:i386

Mais cela n’a pas fonctionné pour les fichiers deb ou original .

    
réponse donnée yuvilio 29.05.2012 - 21:56
la source
13

Ubuntu 14.04 - 32 et 64 bits - installation facile de .deb

En raison de la façon dont fonctionne multiarch, vous pouvez maintenant simplement installer le fichier .deb i386 sur Ubuntu 64 bits plus récent et il installera automatiquement les bonnes dépendances. (De plus, le .deb 64 bits est juste le 32 bits reconditionné avec une dépendance sur ia32-libs)

  1. Téléchargez le 32 bits (oui même pour votre Ubuntu 64 bits) deb: lien (Merci à la réponse de yuvilio) Le paquetage 64 bits sur le même site est une version reconditionnée du 32 bits, vous aurez des problèmes si vous utilisez le package 64 bits à la place, utilisez le package 32 bits pour les systèmes 32 et 64 bits Ubuntu 13.10 +.

  2. Ouvrir dans le centre du logiciel, cliquez sur Installer

    Ignorer l'avertissement concernant la qualité du package

Alternativement, si vous avez un jeu Steam qui nécessite Air, installez et lancez simplement ce jeu et il installera Air sur la première partie du jeu.

Exemples de jeux utilisant Air:

  • Defenders Quest
  • Anodyne (se confond si vous avez déjà installé Air, lancez sudo apt-get remove adobeair et essayez à nouveau l’installateur de jeu car il est fourni avec Air)

Je les ai trouvés lors d’une vente hebdomadaire humble pour soutenir certains projets open source.

    
réponse donnée Mateo 30.03.2014 - 13:46
la source
6

Étape 1: Obtenez de l'air Ensuite, téléchargez le fichier .bin Adobe Air ( lien direct ici ).

Étape 2: installation

Ouvrez un terminal (applications & gt; Accessoires & gt; Terminal) et accédez à votre dossier Téléchargements (ou au dossier dans lequel vous avez enregistré le fichier .bin).

* cd Download/

Nous devons laisser le fichier .bin disposer des autorisations d’installation, entrez donc la commande suivante avec précaution: -

* chmod +x AdobeAIRInstaller.bin

Maintenant, installons-le:

* ./AdobeAIRInstaller.bin

L'installation devrait cependant se dérouler correctement et, si tout se passe bien, une nouvelle entrée de menu apparaîtra dans 'Applications & gt; Accessoires intitulé "Adobe Air Application Installer".

    
réponse donnée Rubyist 10.01.2012 - 05:14
la source
4

... enfin après quelques problèmes et après de nombreuses recherches sur ce forum, Google et les autres pages ont réussi à le faire. Je veux d'abord remercier la communauté qui m'a donné plus d'ambition de le faire, plutôt que de me laisser arrêter d'installer AdobeAir.

Tout le problème était le paquet ia32-libs ( Le paquet ia32-libs était un hack pour installer des paquets 32 bits sur une installation 64 bits. Depuis Ubuntu version 11.10 (Oneiric ), Multi Arch a été ajouté. L'un des objectifs pour cela est de supprimer le paquet ia32-libs ) ... que Canonical a décidé de mettre fin au support pour cela.

Tout ce que j'avais à faire pour installer le paquet ia32-libs était d'ajouter ce dépôt:

1 - '' deb lien source principale de multiversepackage de l'univers restreint ''

J'ai suivi les étapes de ce tutoriel simple et rapide:

lien

2 - puis cette page qui m'amène à cette belle procédure d'installation d'Adobe Air pour les systèmes 64 bits

www.thepowerbase.com/2013/06/how-to-install-adobe-air-in-ubuntu-13-04 /

----------------- documentation que j'ai utilisée: ----------- ----

www.askubuntu.com/questions/87447/how-can-i-install-adobe-air
helpx.adobe.com/air/kb/archived-air-sdk-version.html
www.wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10
www.ubuntuforums.org/showthread.php?t=2181649
www.askubuntu.com/questions/91815/how-to-install-software-or-upgrade-from-old-    unsupported-release  

P.S. --- comme l’a noté Alvar, Adobe Air pour Linux n'est plus pris en charge ---

    
réponse donnée Cester Nilap 06.11.2013 - 10:08
la source
1

Malheureusement, plusieurs années de retard "Adobe AIR pour Linux n'est plus pris en charge". suivant ce que dit la page adobe. L'utilisation de "l'archive AIR" est possible pour obtenir des versions non prises en charge, la version 2.6.0 étant la plus récente disponible. Si vous devez installer un programme nécessitant une version plus récente, vous pouvez accéder à Virtual box avec un invité Windows.

Les étapes recommandées pour Ubuntu 16.10:

pour une machine 32 bits

wget -O adobe-air_i386.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_i386.deb
sudo dpkg -i adobe-air_i386.deb
sudo apt-get install -f && rm adobe-air_i386.deb

pour une machine 64 bits

wget -O adobe-air_amd64.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_amd64.deb
sudo dpkg -i adobe-air_amd64.deb
sudo apt-get install -f && rm adobe-air_amd64.deb

Les étapes recommandées pour Ubuntu 16.04 / 14.04 / 12.04 / Linux Mint 18/17/13 (toutes deux extraites de ici ):

wget -O adobe-air.sh http://drive.noobslab.com/data/apps/AdobeAir/adobe-air.sh
chmod +x adobe-air.sh;sudo ./adobe-air.sh
    
réponse donnée Fábio 30.03.2017 - 19:53
la source
0

J'ai Ubuntu 14.04 64-bit. La seule façon d'installer Adobe Air qui fonctionnait pour moi était de suivre la première partie de ces instructions d'installation. Balsamiq sur Ubuntu , ce que j'essayais de faire en premier lieu.

Un bref résumé de ces instructions: - Téléchargez ce programme d'installation d'Adobe Air - Installation du paquetage libgtk 32 bits (mais j'ai ignoré cette étape, cela ne fonctionnait pas pour moi et ne semblait pas nécessaire) - Création de liens symboliques vers deux fichiers libgnome-keyring - Rendre l'exécutable du programme d'installation Adobe Air et l'exécuter avec sudo

    
réponse donnée Steve Saporta 29.01.2015 - 23:46
la source

Lire d'autres questions sur les étiquettes