16.04 Impossible d'installer quelque chose du centre logiciel Ubuntu [dupliquer]

46

Chaque fois que je clique deux fois sur un fichier deb, celui-ci est ouvert dans le centre du logiciel. Cependant, lorsque je clique sur le bouton "installer", il devient "installation" pendant une seconde, puis revient à "installer" et rien ne se passe. Il dit aussi "Ce logiciel provient d'un tiers et peut contenir des composants non-libres" en bas. J'ai activé toutes les options dans Software & amp; Mises à jour et également essayé de réinstaller le centre de logiciel mais rien n'a aidé.

    
posée Lixu 23.04.2016 - 14:46
la source

4 réponses

47

Si vous souhaitez installer des programmes via des fichiers .deb, je suggère d'utiliser Gdebi.

Il s’agit d’une application légère, mieux adaptée à l’installation des packages .deb et plus rapide. S'il y a des dépendances, cela le notifie également.

Dans le terminal, tapez:

sudo apt install gdebi

Vous pouvez cliquer avec le bouton droit sur le fichier .deb et choisir de l’ouvrir avec Gdebi.

Si vous aimez Gdeb, vous pouvez le faire par défaut pour qu’il ouvre tous les fichiers .deb à l’avenir.

Lisez ceci: lien

    
réponse donnée abhishek 24.04.2016 - 23:29
la source
12

Si vous avez besoin d’installer un logiciel qui n’est pas dans les référentiels et que le Software Center ne fonctionne pas, il existe une alternative, mais le terminal est nécessaire. Vous devez d'abord accéder au dossier dans lequel vous avez téléchargé le paquet Debian, qui se trouve généralement dans le dossier "Téléchargements".

Vous pouvez ouvrir le terminal à partir de ce dossier en cliquant avec le bouton droit de la souris et en appuyant sur "Open Terminal", ou vous pouvez y accéder via le terminal en:

cd /path/to/folder

Après cela, il vous suffit d'exécuter cette commande:

sudo dpkg -i nameofpackage.deb
    
réponse donnée Mario Kamenjak 23.04.2016 - 14:55
la source
0

Si vous devez installer un logiciel, vous avez deux options

  1. en utilisant Software Center
  2. utilisation du terminal

Si vous rencontrez un problème avec la première méthode, vous pouvez opter pour la seconde méthode.

  1. Ajoutez PPA en utilisant la commande suivante

    sudo add-apt-repository ppa:<ppa_name>
    

    Si la commande ci-dessus ne fonctionne pas, essayez la commande suivante

    sudo -E add-apt-repository ppa:<ppa_name>
    
  2. Ensuite, écrivez la commande suivante:

    sudo apt-get update
    

    alors

    sudo apt-get install <software-name>
    
réponse donnée Narendra 23.04.2016 - 16:03
la source
0

Ce n’est pas spécifiquement un bogue dans Ubuntu, c’est une chose APT. C'est juste le moment très regrettable pour la version 16.04 que le SHA1 a été retiré. SHA1 est largement utilisé par le système APT pour les packages de somme de contrôle, ce qui le rend obsolète au profit de SHA256 ou SHA512, qui est plus sûr.

Si vous remarquez qu’un paquet ne fonctionne pas, veuillez contacter le responsable de la mise à jour et leur demander de mettre à jour leur implémentation SHA.

L'écriture Debians des pensions effectuées et la mise à jour lien

Comment et pourquoi le système apt sécurise ses paquets et ses référentiels lien

Comme suggéré par d’autres, le travail consiste à télécharger manuellement le fichier et à le vérifier vous-même avant de l’installer avec un outil non compatible avec le référentiel tel que dpkg ou gdebi.

    
réponse donnée Amias 05.05.2016 - 17:42
la source

Lire d'autres questions sur les étiquettes