LibreOffice affiche toujours le processus de récupération au démarrage en raison des éléments de récupération défaillants

45

LibreOffice commence toujours par le processus de récupération pour moi maintenant. Il a un certain nombre de «documents à récupérer» pour lesquels la récupération échoue. Je n'ai plus besoin de ces documents. Comment dire à LibreOffice d'abandonner?

    
posée Jasper van den Bosch 18.01.2013 - 16:41
la source

9 réponses

56

Super! J'ai essayé de recréer ce problème et maintenant je ne peux pas supprimer l'écran de récupération en échec.

La solution consiste à frapper cancel sur l’écran de récupération, au lieu d’essayer (et d’échouer) la récupération ( source ). Fonctionne pour moi.

    
réponse donnée philshem 18.01.2013 - 17:45
la source
3

Ce problème semble apparaître dans Ubuntu 12.04.

Bien sûr, vous pouvez annuler le processus de récupération mais ce n’est pas une solution car vous devrez le faire chaque fois que vous démarrez LibreOffice, même après avoir fermé tous les documents correctement après la dernière session.

Le bug est causé par le package lo-menubar qui offre le HUD fonctionnalité pour LibreOffice.

La véritable solution du problème est donc sudo apt-get remove lo-menubar .

    
réponse donnée 0nickyet 12.02.2013 - 07:56
la source
3

Frapper Annuler comme le suggèrent d’autres affiches n’est pas une solution pour moi car la même boîte de dialogue continue d’être affichée chaque fois que je ferme et rouvre l’application.

Ubuntu 14.04.2 avec LibreOffice version 4.2.8.2

La solution simple pour moi était de faire ce qui suit:

  1. fermez toutes les fenêtres ouvertes de LibreOffice pour naviguer là où LibreOffice stocke registrymodifications.xcu
    • pour moi à partir d'une installation par défaut, il est stocké sous /.config/libreoffice/4/user
  2. faire une sauvegarde de registrymodifications.xcu
  3. éditer registrymodifications.xcu avec un éditeur de texte (tel que gedit)
  4. recherche de la chaîne RecoveryList
  5. supprime complètement toutes les balises contenant le chemin /org.openoffice.Office.Recovery/RecoveryList
    • delete from - sera une ligne mais peut apparaître comme plusieurs si le retour à la ligne est activé
    • REMARQUE: Supprimez uniquement les éléments RecoveryList que vous ne souhaitez PAS récupérer, en fait,
  6. Enregistrez vos modifications, fermez le fichier
  7. La prochaine fois que vous ouvrez un fichier LibreOffice avec LibreOffice, cela ne vous obligera pas à passer par le processus d’échec de la récupération de tedius

REMARQUE: LibreOffice écrit souvent dans le fichier registrymodifications.xcu pendant l’exécution - si vous modifiez le fichier alors que LibreOffice est en cours d’exécution, vos modifications seront écrasées / ignorées

Une réponse plus robuste (fournissant des emplacements de fichiers pour différents systèmes d'exploitation, etc.) peut être trouvée via ce lien: Question / Réponse du site d'aide de LibreOffice

    
réponse donnée William Crighton 25.03.2015 - 01:13
la source
2

Une meilleure solution, sans perturber la configuration, consiste à réécrire un fichier portant le même nom au même endroit .

  1. Ouvrez LibreOffice Writer (ou Calc ou n'importe quel programme LO) normalement et annulez le processus de récupération. Le programme devrait s'ouvrir avec un document "No title".

  2. Ecrivez quelque chose dans le nouveau document et enregistrez-le avec le nom exact du fichier que LO vous demande de récupérer. Si vous en avez plus d'un, vous devez recréer chacun. Le nom doit être EXACTEMENT identique, avec le même format et dans le même dossier et le même disque.

  3. Ouvrez le ou les faux fichiers et le problème doit être résolu.

Cela a fonctionné pour moi et maintenant je n'ai pas la fenêtre de récupération comme bienvenue !!!

    
réponse donnée user177723 23.07.2013 - 19:17
la source
1

Appuyez sur Echap lorsque l’avis de récupération apparaît pour vous permettre d’annuler la récupération. Puis cliquez sur annuler. Cela a fonctionné pour moi. Voir lien réponse # 2. Je ne sais pas pour la réponse # 6. Dans le passé, cela ne fonctionnait pas pour moi, donc je ne l'ai pas essayé cette fois.

    
réponse donnée user308829 24.07.2014 - 20:09
la source
0

Consultez: lien

Cela a fonctionné pour moi sur Ubuntu 12.04, LibreOffice 4.0.2.4.

Résumé de l’URL: appuyez sur "Annuler" ou supprimez le contenu de

<item oor:path="/org.openoffice.Office.Recovery/RecoveryList"> (se termine par </item> )

de registrymodifications.xcu .

Toutefois, cette solution semble ne représenter qu’une solution: elle ne désactivera pas la récupération pour les fichiers futurs.

    
réponse donnée PhilippeTig 07.02.2014 - 17:30
la source
0

Si vous essayez d’interrompre un "sauvetage" répétitif, même lorsque la fenêtre est devenue grise et semble ne pas répondre, vous pouvez toujours sortir avec la "fenêtre de fermeture" en haut à gauche. Le programme offre une chance de forcer à quitter. Cela peut être votre seule option si le programme tente d'ouvrir un fichier endommagé. À ce stade, vous penseriez avoir perdu tout travail non enregistré. Ensuite, une requête surprise s'ouvre et vous propose de sauvegarder tous les fichiers non enregistrés avec un nouveau nom ... et la fenêtre "rescue" ne revient pas!

    
réponse donnée Ron Salomon 22.08.2015 - 22:04
la source
0

J'ai donc cherché une réponse à la même chose et la meilleure solution que j'ai trouvée est de changer la commande ouverte pour chacune des applications Instructions naviguez vers / usr / share / applications trouver les fichiers pour les applications libreOffice pour moi ce sont ces quatre

Fichiers d'application LibreOffice

faites un clic droit et sélectionnez les propriétés et ajoutez --norestore à la commande

Ajouter à la commande

    
réponse donnée Chris9540 25.07.2018 - 09:52
la source
-1

Simplifiez les choses .. Veuillez choisir le bouton Annuler et fermez le fichier. Après cela, cela ne vous obligera pas à passer par le processus de récupération.

    
réponse donnée Pravin 26.08.2016 - 12:34
la source

Lire d'autres questions sur les étiquettes