Comment puis-je mettre à niveau le noyau vers la version 3.1?

8

Le PPA du noyau Ubuntu n’a pas de noyau 3.1. Existe-t-il un autre moyen sûr de mettre à niveau, car je ne souhaite pas réinstaller Ubuntu.

    
posée Sudo 27.10.2011 - 08:53
la source

6 réponses

9

En plus d’attendre que le noyau apparaisse dans le PPA (il a été publié il ya un jour?), une autre option consiste à télécharger une archive et à la compiler à partir de sources.

L'attente d'un PPA est sûre, la compilation à partir de sources est amusante. Vous choisissez:)

    
réponse donnée Sergey 27.10.2011 - 09:01
la source
3

Les noyaux

Un peu plus tôt, il y avait une question: Comment rétrograder le noyau sur 11.10 . La mise à niveau du noyau n'est pas plus difficile.

Vous pouvez télécharger les binaires du noyau à partir des anciennes et nouvelles versions d’Ubuntu 1 . Le Precise 2 a le 3.1. De plus, la construction du noyau Mainline 3 a la version 3.1.

Téléchargement depuis le réseau principal de linux-image-3.1.0-030100rc10-generic. L'installer Redémarrer avec elle et l’ubuntu (K) 11.10 fonctionne avec la version 3.1.

Liens

  1. lien
  2. lien
réponse donnée user26687 27.10.2011 - 10:06
la source
2

Je pense que l'équipe du noyau a téléchargé le noyau 3.1 ici lien

    
réponse donnée Salih Emin 02.11.2011 - 01:14
la source
0

Même xorg-edgers a le noyau 3.1.0-2.2. Si vous utilisez xorg-edgers, vous obtenez également les derniers pilotes graphiques. Cependant, l'unité rompt avec xorg-edgers.

    
réponse donnée razor 16.11.2011 - 19:38
la source
0

EDIT: trois packages doivent être installés.

  • linux-headers
  • linux-headers-generic
  • linux-image-generic

Les étapes ci-dessous installent uniquement deux . Cette réponse doit être améliorée.

Le noyau 3.1 est disponible. Voici comment l'installer:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/linux-headers-3.1.0-030100_3.1.0-030100.201110241006_all.deb

sudo dpkg -i linux-headers-3.1.0-030100_3.1.0-030100.201110241006_all.deb

Pour Ubuntu 11.10 / 11.04 (32 bits):

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/linux-headers-3.1.0-030100-generic_3.1.0-030100.201110241006_i386.deb

sudo dpkg -i linux-headers-3.1.0-030100-generic_3.1.0-030100.201110241006_i386.deb

Pour Ubuntu 11.10 / 11.04 (64 bits):

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/linux-headers-3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb

sudo dpkg -i linux-headers-3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb

Mais est-il sûr de mettre à niveau le noyau 3.1? Je me souviens quand je suis passé de la version 2.6 à la version 3.0 sur Ubuntu 11.04 et que mon pilote GPU ne fonctionnait pas et qu'il n'y avait pas d'unité. Je ne veux pas que cela se reproduise.

    
réponse donnée III.6 03.11.2011 - 08:52
la source
0

Je recommande de ne pas l'essayer.

Dernièrement, le nouveau noyau 3.x semble mauvais et chaque version introduit plus de bogues que les nouvelles fonctionnalités.
Depuis 3.10, NVidia se bloque à chaque fois et 3.11 introduit la nouvelle "fonctionnalité":

  

run-parts: exécuter /etc/kernel/header_postinst.d/dkms   3.1.1-030101-generic /boot/vmlinuz-3.1.1-030101- Erreur générique! Problèmes avec depmod détecté. Désinstaller automatiquement cette   module. DKMS: Échec de l'installation (problèmes de depmod). Module ramené à   état construit.

Je ne sais pas ce que cela signifie.

    
réponse donnée ike 12.11.2011 - 16:47
la source

Lire d'autres questions sur les étiquettes