Problèmes graphiques après / pendant l'installation d'Ubuntu 16.04 / 16.10 avec les graphiques NVIDIA

165

J'ai installé ou mis à niveau vers Ubuntu 16.04, mais j'ai quelques problèmes avec ma carte graphique.

  • L'affichage est vide
  • L'affichage scintille
  • Les éléments à l'écran ne s'affichent pas correctement
  • Certains programmes se plaignent de problèmes graphiques
  • L'ordinateur démarre en mode faible graphique

  • Votre problème spécifique n’est peut-être pas là, mais essayez quand même les solutions décrites dans les réponses.

Cette question est très vaste, mais chacun de ces problèmes a probablement une solution.

Si vous rencontrez une boucle de connexion, vérifiez la dernière partie de ma réponse.

Si vous rencontrez l'un des problèmes énumérés et que vous avez votre propre solution (la mienne ne fonctionnait pas ou que la solution est plus rapide), n'hésitez pas à poster une autre réponse POLITE décrivant votre problème et son correctif.

Ceux qui tentent d’installer Ubuntu, veuillez vous reporter à la section intitulée: If you are unable to enter a TTY or are trying to install Ubuntu .

    
posée TheWanderer 23.04.2016 - 02:01
la source

12 réponses

194

Veuillez noter que cette réponse peut devenir légèrement obsolète. Je ferai de mon mieux pour le mettre à jour régulièrement, mais je ne peux rien garantir. La version du pilote utilisée ci-dessous peut ne pas être la dernière. Veuillez vérifier la page Launchpad pour confirmer.

Chacun des problèmes décrits (et peut-être même davantage) peut être résolu en suivant les étapes ci-dessous.

Si vous installez Ubuntu, suivez la section 3.

1. Assurez-vous d'abord que vous pouvez entrer un ATS

Appuyez sur Ctrl + Alt + F1

Si cela vous amène à un écran noir avec une invite de connexion, continuez. Sinon, vous devrez probablement démarrer avec un indicateur spécial du noyau. Les instructions sont ci-dessous.

2. Maintenant pour le correctif

  1. Connectez-vous à votre compte dans le TTY.
  2. Exécuter sudo apt-get purge nvidia-*
  3. Exécutez sudo add-apt-repository ppa:graphics-drivers/ppa puis sudo apt-get update .
  4. Exécutez sudo apt-get install nvidia-375 .
  5. Redémarrez et votre problème graphique devrait être résolu.

3. Si vous ne pouvez pas entrer un ATS ou essayez d’installer Ubuntu

  1. Redémarrez dans GRUB.
  2. Sélectionnez l’option Ubuntu et appuyez sur E .
  3. Ajoutez nouveau.modeset=0 à la fin de la ligne commençant par linux .
  4. Appuyez sur F10 pour démarrer.
  5. Suivez les instructions ci-dessus.
    • (Si vous installez Ubuntu, ignorez cette étape, mais suivez le reste du didacticiel une fois l'installation terminée.)

Cette solution devrait résoudre de nombreux problèmes décrits par les utilisateurs après une mise à niveau vers 16.04. Si une nouvelle installation est affectée, la solution est la même.

Si vous rencontrez des problèmes par la suite, vous devriez poser une question différente. (Reportez-vous à cette question pour que nous sachions qu’il ne s’agit pas d’une copie.) Cependant, vous pouvez essayer quelques petites corrections avant de le faire.

  • Réinstaller Xorg

    • Retournez dans le TTY et exécutez sudo apt-get purge xorg-* xserver-xorg; sudo apt-get install xorg xserver-xorg; sudo dpkg-reconfigure xorg .
  • Réinstallez votre environnement de bureau

    • Si sous Unity, exécutez sudo apt-get purge ubuntu-desktop; sudo apt-get install ubuntu-desktop .
    • Si sous GNOME, exécutez sudo apt-get purge ubuntu-gnome-desktop gnome-desktop-environment; sudo apt-get install ubuntu-gnome-desktop .
    • Si sur MATE, exécutez sudo apt-get purge ubuntu-mate-desktop mate-desktop-environment; sudo apt-get install ubuntu-mate-desktop
    • Chaque DE Ubuntu a son propre nom de paquet. Si vous avez KDE ou autre chose, le nom devrait être similaire à ceux ci-dessus.
  • Nouvelle réinstallation
    • Ce n’est pas l’option la plus invitante, mais parfois c’est la meilleure chose à faire dans des cas comme celui-ci.

N'oubliez pas qu'il y a beaucoup de choses qui peuvent mal tourner et que n'est pas une solution garantie pour tout. Même si vous rencontrez quelque chose répertorié dans la question, la solution peut ne pas fonctionner entièrement pour vous.

Cette réponse concerne uniquement les problèmes de pilote avec 16.04 et nVIDIA. Votre problème peut aller plus loin qu'un mauvais pilote.

Autres problèmes après le correctif

  • Si vous obtenez un affichage fonctionnel, mais que vous vous connectez à une boucle de connexion (vous vous connectez et vous revenez à l'écran de connexion), prenez regardez ici .
réponse donnée TheWanderer 23.04.2016 - 02:01
la source
11

J'ai installé Ubuntu 16.04 et tout s'est bien passé jusqu'à ce que je passe au pilote NVIDIA. Après le redémarrage, je n'ai pas pu dépasser l'écran de connexion. La solution qui a fonctionné pour moi consistait à désactiver le démarrage sécurisé .

Alors que j'étais bloqué dans la boucle de connexion, je suis passé à la console Ctl+Alt+F1 , au redémarrage sécurisé et désactivé de UEFI . Maintenant, tout fonctionne avec le pilote nvidia installé.

    
réponse donnée Karhu 27.04.2016 - 22:34
la source
7

Pour L'affichage est vide & amp; L'affichage scintille

J'ai rencontré le même problème mais maintenant tout fonctionne bien.

Il existe deux solutions à cela:

  1. Utilisez le pilote NVIDIA version 364 à partir du pilote graphique PPA (meilleure option)

    • sudo add-apt-repository ppa:graphics-drivers/ppa
    • sudo apt update && sudo apt install nvidia-364
  2. Utilisez LightDM au lieu de GDM

    • sudo apt-get install lightdm
    • choisissez lightdm comme valeur par défaut lorsque vous y êtes invité.

REMARQUE Si cela n'a pas fonctionné pour vous, installez intel-microcode (si disponible) depuis l'application Drivers supplémentaires avant d'installer le pilote NVIDIA.

    
réponse donnée Independent Peculiar 24.04.2016 - 23:24
la source
6

Je suis passé d'Ubuntu GNOME 15.10 à 16.04 et j'ai été confronté à un écran noir. En utilisant systemctl status et en fouillant dans les journaux, j'ai constaté que les pilotes NVidia propriétaires étaient cassés.

En purgeant nvidia-* et en réinstallant gdm , je suis passé en mode graphique bas, mais la réinstallation des pilotes NVidia a ramené l’écran noir. En fait, le démarrage sécurisé avait été défini sur "Windows" dans les paramètres du BIOS. Je l'ai changé pour "Autre" et mon problème a été résolu.

Avant de trouver l'option Secure Boot, j'ai essayé de purger et de réinstaller nvidia-* , xorg* , xserver-xorg , ubuntu-gnome-desktop , gnome-desktop-environment . Je ne suis pas sûr que cela ait aidé ou non, mais il semble préférable de l'installer. En outre, l'outil de mise à niveau avait indiqué qu'il devrait désactiver le démarrage sécurisé pour réussir, mais qu'il le réactiverait par la suite. C'est ce qui m'a amené à le chercher.

    
réponse donnée kd8azz 27.04.2016 - 03:03
la source
4

J'ai vérifié le fichier journal X11 dans /var/log/Xorg.0.log pour les entrées d'erreur (EE):

[email protected]:/var/log# grep EE Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   156.124] (EE) No devices detected.
[   156.127] (EE) no screens found(EE) 

La carte graphique n’a donc pas été détectée par le pilote nouveau.

vérifier la carte installée avec lspci a donné le résultat suivant:

[email protected]:/usr/share/X11/xorg.conf.d$ lspci | grep NVIDIA 
02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210]    (rev a2)
02:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

Avec ce type de carte graphique, les réponses recommandant d'installer les pilotes NVIDIA fournis ici ne m'ont pas aidé car le dernier pilote NVIDIA ne prend pas en charge ma carte.

Par conséquent, après quelques recherches sur Internet, j'ai trouvé une suggestion pour aider le système X11 en spécifiant les détails de la carte dans un fichier

/usr/share/X11/xorg.conf.d/20-nouveau-conf et en utilisant les informations de la commande lspci:

# lspci | grep NVIDIA 
# 02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
Section "Device"
   Identifier  "NvidiaGraphics"
   Driver      "nouveau"
   VendorName "NVIDIA Corporation"
   BusID    "PCI:2:0:0"   
EndSection

Maintenant, les choses fonctionnent comme prévu et aucune ligne d’erreur (EE) ne s’affiche dans le fichier journal.

    
réponse donnée Wolfgang Fahl 11.08.2016 - 16:58
la source
4

Pour ceux qui suivent le guide mais le problème persiste, alors peut-être que cela a quelque chose à voir avec le pilote lui-même.

Certains GPU NVIDIA ne fonctionnent pas bien avec le pilote le plus récent. Si vous soupçonnez que vous êtes victime de ce problème, vous pouvez suivre mon guide ci-dessous.

Ci-dessous, il suffit de copier-coller des réponses à ma propre question ici .

Je l'ai fait !! C'était un problème avec le pilote lui-même!

Problème : ma carte (NVIDIA GTX980M) ne fonctionne pas correctement avec le nouveau pilote Linux propriétaire NVIDIA. Solution : utilisez l’ancien pilote qui prend en charge ma carte graphique.

Après quelques instants, certains ont dit que je pourrais peut-être essayer d’utiliser nvidia-352 au lieu de nouveaux pilotes.

Cependant, en regardant apt-cache search nvidia-352 , j'ai découvert que nvidia-352 était juste un pilote de transition pour nvidia-361 . pilote graphique.

Cependant, sur la base de mon test précédent, nvidia-361 jusqu'au plus récent (nvidia-370 au moment de la rédaction du présent rapport) est la source de mon problème.

Je dois donc télécharger le nvidia-352 au lieu de la transition nvidia-361 .

Si vous avez le même problème que le mien, voici les étapes à suivre pour le résoudre.

Étapes:

  1. Désinstallez tous les pilotes NVIDIA qui posent problème.

    sudo apt-get purge nvidia-* libcuda-* 
    

    .

  2. Créer un dossier temporaire pour stocker les fichiers nvidia-352 requis

    cd ~/Desktop
    mkdir nvidia-352
    cd nvidia-352
    

    .

  3. Téléchargez les fichiers requis pour le pilote graphique nvidia-352 .

    wget https://launchpad.net/ubuntu/+archive/primary/+files/libcuda1-352_352.63-0ubuntu3_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/nvidia-libopencl1-352_352.63-0ubuntu3_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/nvidia-opencl-icd-352_352.63-0ubuntu3_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/nvidia-352_352.63-0ubuntu3_amd64.deb
    

    Modifier 1:

    Si vous rencontrez des problèmes lors du téléchargement de nvidia-352_352.63-0ubuntu3_amd64.deb à partir du lien ci-dessus (qui m'est apparu), vous pouvez également le télécharger depuis différentes sources.

    Voici un autre lien pour ce fichier:

    http://mirrors.mit.edu/ubuntu/pool/restricted/n/nvidia-graphics-drivers-352/nvidia-352_352.63-0ubuntu0.15.10.1_amd64.deb
    

    Modifier 2:

    Les liens ci-dessus concernent le pilote NVIDIA 64 bits, pour ceux qui recherchent le format 32 bits, consultez le lien ci-dessous:

    https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-352
    

    Les étapes sont les mêmes, il vous suffit de télécharger des fichiers différents qui prennent en charge votre configuration 32 bits.

    .

  4. Installez tous les fichiers debs.

    sudo dpkg -i *.deb
    

    .

  5. Redémarrer

    .

Voila! Si vous avez démarré sur votre bureau sans avoir eu un seul crash, vous avez résolu ce problème graphique avec succès!

Profitez! : D

    
réponse donnée Mohd Shahril 29.08.2016 - 19:04
la source
1

Après avoir lutté contre ce problème pendant un jour et demi, il a finalement été résolu en désactivant le démarrage sécurisé dans les paramètres Bios. Au cours de l'installation du pilote, j'ai été invité à désactiver le démarrage sécurisé et je l'ai fait, mais de toute façon, peut-être parce que Windows est également installé, il n'a pas été désactivé (lors de l'installation). redémarrage et en appuyant sur F2 (sur Asus) je suis entré dans Bios, la sécurité, puis désactivé le démarrage sécurisé. redémarré, et le tour est joué! Bien que cela puisse être spécifique à certaines versions de bios ou à deux systèmes d’amorçage, personne n’a posté cette solution auparavant.

    
réponse donnée Yuval Harpaz 30.08.2017 - 13:55
la source
0

Chaque jour, je vérifie les mises à jour et les télécharge à l'aide de Software Updater. Mais hier soir, Ubuntu m'a demandé un téléchargement partiel (dit quelque chose qui n'était pas installé correctement - quelque chose comme ça), donc je suis le processus Téléchargement partiel . Fin du processus de téléchargement, il a demandé un redémarrage, alors je redémarre Ubuntu. Après le redémarrage, le logo de démarrage et la fenêtre de connexion sont sur basse résolution , la boucle de connexion et non. connexion internet (wifi + ethernet à la fois j'ai essayé) ! Donc, je ne peux même pas me connecter!

J'utilise Ubuntu 16.04.2 LTS dans Ordinateur portable ASUS X556UQ .

Après une longue expérience (essayer ci-dessus et une autre solution de Google), je constate que le problème se produit pour la dernière version de Linux Kernel 4.8.0-42 avec Nvidia 378 chauffeur! Donc, je bascule vers le pilote Nvidia 370 en utilisant TTY ( Ctrl + Alt + F1 ) et redémarre Ubuntu sous Linux < em> Noyau 4.8.0-41 (Utilisation du menu grub) et tous les problèmes résolus!

    
réponse donnée Mahmudul Hasan Shohag 16.03.2017 - 16:01
la source
0

J'ai essayé de nombreuses solutions et non travaillées. Enfin, j'ai essayé ceci et travaillé parfaitement, sans avoir besoin de faire des choses comme sudo service lightdm stop et ainsi de suite. Il suffit de lancer les opérations suivantes:

Cela vous montre la liste des pilotes compatibles pour vos appareils: sudo ubuntu-drivers list

Puis lancez pour installer les compatibles:

sudo ubuntu-drivers autoinstall

Enfin faites (ou redémarrez simplement votre machine):

sudo service lightdm restart

    
réponse donnée Amir 12.02.2018 - 06:20
la source
-1

Lorsque j'ai installé Ubuntu 16.04.1 pour la première fois, des problèmes graphiques ont été résolus en utilisant nvidia-304 (déjà mentionné ci-dessus comme solution). Je viens de mettre à jour mon système il y a environ une semaine et depuis, je me suis retrouvé dans le "problème de la connexion impossible", comme de nombreuses personnes l'ont déjà décrit. En se connectant via un tty, j'ai essayé d'installer nvidia-304, 324, 350 et 370. AUCUN d'entre eux ne fonctionnait. Finalement j'ai essayé quelque chose de très radical. J'ai installé Xubuntu 16.04.1. Cela a fonctionné immédiatement sans aucun effort spécifique de ma part. Il semble donc que le problème soit intimement lié au gestionnaire de bureau (Gnome). Donc, si vous pouvez passer à Xfce depuis une fenêtre shell, vous pourriez être bien avec votre version actuelle d'Ubuntu (désolé mais je ne sais pas comment faire). Sinon, installez Xubuntu.

Bonne chance!

    
réponse donnée Joe Berry 08.11.2016 - 03:42
la source
-1

J'ai eu ce problème de boucle de connexion depuis des mois maintenant sans fin. Maintenant, j'ai enfin une réponse et je veux vraiment la partager avec vous tous qui vous tirez la tête pour la solution. S'il existe un moyen plus simple de le faire, veuillez le faire.

Ceci est mon premier article, merci de supporter les erreurs que je pourrais commettre en premier temps:)

Je vais raconter tout le processus que j'ai fait depuis le début pour que vous sachiez quelles sont toutes les méthodes que j'ai essayées.

  1. Au début, lors de l’installation d’Ubuntu, l’écran était incroyablement lent et lent. La sortie provenait de la sortie graphique intégrée (le VGA intégré), puis, après l’installation des pilotes NVIDIA, elle montrait une boucle de connexion dans laquelle, lorsque l’utilisateur se connecte au PC, l’écran clignote et l’écran de connexion réapparaît dans une boucle infinie. La résolution était également faible mais cette fois-ci, la sortie provenait du HDMI du GPU.

  2. Pour essayer de corriger la situation, il y avait de nombreuses suggestions sur le Web, par exemple pour supprimer le fichier .Xauthority ou pour essayer de faire sudo chown user:user .Xauthority . J'ai essayé les deux mais en vain.

  3. Ensuite, il y avait une méthode pour essayer d'installer le gestionnaire lightdm au lieu du gestionnaire gdm habituel qui se trouvait dans ubuntu. J'ai ensuite changé le gestionnaire d'affichage à la même chose, mais cela ne fonctionnait pas non plus.

  4. La suggestion suivante consistait à installer l'environnement xubuntu-desktop , puis à essayer de l'utiliser. Lorsque j'ai supprimé ubuntu-desktop , puis installé le bureau xubuntu. Cela a effectivement résolu le problème mais c'était temporaire. La caméra à l'écran mais la GTX 980 n'était pas visible dans le paramètre du serveur Nvidia x. Mais à ce stade, après avoir installé CUDA qui détectait le GPU.

  5. Après un redémarrage, l’écran a cessé de fonctionner à nouveau et cette fois, le tty a également cessé de s’afficher, même après avoir utilisé individuellement les raccourcis Ctrl-Alt-F1 à F7.

  6. En pensant qu’il s’agissait d’un problème dans le système d’exploitation, j’ai alors commencé à expérimenter avec d’autres systèmes d’exploitation. J'ai téléchargé et essayé d'installer une version du serveur Ubuntu. Après avoir installé la version du serveur, j'ai essayé d'installer un environnement de bureau. Par conséquent, après avoir essayé d'installer l'environnement de bureau, le système d'exploitation s'est écrasé avec un message disant "Oh non! Quelque chose ne va pas!". Puis il a encore frappé.

  7. Suppression de la version du serveur Ubuntu Je me suis alors tourné vers Kubuntu 16.04 , pensant que son gestionnaire d’affichage pouvait apporter son aide. J'ai d'abord installé après avoir enlevé le GPU et l'installation s'est bien déroulée. Après cela, j'ai installé le pilote Nvidia après avoir remis le GPU et la boucle de connexion est revenue. C'était incurable à nouveau.

  8. Après cela, j'ai essayé d'installer différents pilotes Nvidia car c'était une autre suggestion. J'ai essayé nvidia-300, nvidia-340 et nvidia-367 propriétaire à l'époque, mais tout était en vain. Il y avait aussi des PPA avec des versions expérimentales (ppa xorg-edgers et quelque chose de similaire), mais eux aussi ne fonctionnaient pas.

  9. Ensuite, j'ai essayé d'installer Fedora. Mais à l'époque, une page parlait d'autres contrôleurs VGA parallèles pouvant se trouver dans le système. Donc, quand j'ai vérifié, j'ai remarqué qu'il y avait un pilote graphique intégré Matrox dans la carte mère. (MG 200e). Cela aurait pu être le problème car ils auraient pu être un conflit entre les pilotes tout ce temps. J'ai donc commencé à chercher comment désactiver le pilote.

  10. Ensuite, j'ai trouvé la méthode !! . Je suis allé dans la configuration du BIOS puis j'ai désactivé l'option "Onboard display". Cela a résolu le problème. Maintenant, lorsque j'ai ouvert Fedora, cela a commencé à fonctionner avec la carte GPU et le pilote n'était pas encore installé. C'était une grande amélioration par rapport à avant. Après l'installation du pilote Nvidia, le système d'exploitation commence à bien fonctionner.

réponse donnée Joe 12.11.2016 - 12:58
la source
-2

Voici mes solutions.

Ubuntu OS 16.04 nvidia driver avant 350, installé dans les mises à jour logicielles d'ubuntu

Je télécharge depuis nvidia le pilote 370 et j'exécute sh./path-to-driver dans le terminal enter to tty

ctrl alt f1

et tuer le processus lightdm

sudo service lightdm stop

avec cette commande ont des problèmes

solution

Tout d'abord redémarrer le PC et mon premier problème était que je ne peux pas entrer dans le bureau dans Ubuntu et ne peut pas entrer dans le terminal tty, j'entre en mode de récupération et aller au terminal racine et faire cela

nvidia-uninstall

Cela supprime le pilote nvidia que votre installation avec la commande ./nvidia.run

et redémarrez et regardez. vous devez installer le pilote de ubuntu avec

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt-get install nvidia-current

ou trouver dans le logiciel et les mises à jour et installer le pilote

Cette solution est ma solution du même problème avant. Je ne peux pas désinstaller le pilote lorsque je télécharge de la page Web de nvidia

    
réponse donnée Jonathan Rodriguez 29.08.2016 - 19:52
la source

Lire d'autres questions sur les étiquettes