Comment puis-je obtenir une carte sans fil Realtek RTL8723BE?

47

J'ai installé Ubuntu 15.04 sur mon ordinateur portable avec la carte Wi-Fi RTL8723BE. Mais il se déconnecte toujours du réseau. J'ai essayé echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf mais cela n'a pas aidé. Que puis-je faire pour empêcher le wifi de se déconnecter? Si je passe au noyau 4.X, cela aidera-t-il?

~$ lspci -knn | grep Net -A2

09:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company Device [103c:2231]
    Kernel driver in use: rtl8723be


~$ rfkill list
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


~$ ifconfig && iwconfig && route -n && ping -c 1 google.com
eth0      Link encap:Ethernet  HWaddr 38:63:bb:cd:4a:7e  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:752 (752.0 B)  TX bytes:8445 (8.4 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3870 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3870 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:314613 (314.6 KB)  TX bytes:314613 (314.6 KB)

wlan0     Link encap:Ethernet  HWaddr c0:38:96:6d:c4:83  
          inet addr:192.168.1.205  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c238:96ff:fe6d:c483/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15240 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14627 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14410285 (14.4 MB)  TX bytes:2192744 (2.1 MB)

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"DIR-615"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:90:4C:08:00:0D   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-22 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:186   Missed beacon:0

lo        no wireless extensions.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    400    0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
PING google.com.Dlink (172.26.136.19) 56(84) bytes of data.
64 bytes from 19.136.26.172.in-addr.arpa (172.26.136.19): icmp_seq=1 ttl=249 time=102 ms

--- google.com.Dlink ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 102.547/102.547/102.547/0.000 ms
    
posée PlugaruT 12.06.2015 - 17:22
la source

6 réponses

65

Tout d'abord, supprimez les paramètres que vous avez définis.

sudo rm /etc/modprobe.d/rtl8723be.conf

Si vous n’avez pas ce fichier, rien n’est faux.

Installez ensuite un bon pilote

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms

Redémarrer et profiter

Si vous avez toujours des problèmes (signal faible), vous devrez peut-être ajouter une option:

echo "options rtl8723be ant_sel=2"  | sudo tee /etc/modprobe.d/rtl8723be.conf

puis redémarrez à nouveau.

L’extension est effectuée par chili555 dans cette réponse .

Ceci est le même pilote que lien , rock.new_btcoex branch mais emballé en dkms.

Vous pouvez voir tout cela à lien

Si vous avez également besoin de Bluetooth, exécutez également:

sudo apt-get install rtl8723au-bt-dkms linux-firmware

Remarque: Le support des noyaux 4.2 et Ubuntu 15.10 a été ajouté au PPA. Pour le noyau 4.2, le pilote Bluetooth doit être non installé à partir du PPA. Il existe déjà un support natif de l’adaptateur Bluetooth dans le noyau 4.2.

Guide hors ligne

Si vous n’avez pas de connexion Internet, vous pouvez télécharger le package en utilisant un autre ordinateur, un téléphone, etc.

Le paquet est ICI

Vous aurez également besoin de DKMS installé. Vous pouvez trouver le paquet DKMS pour Ubuntu 16.04 ICI

Copiez ces deux fichiers dans le dossier Ubuntu Home (~ /) et exécutez-les dans le terminal

sudo dpkg -i dkms*.deb rtlwifi*.deb

Puis redémarrez.

Important: Pour les nouveaux noyaux Ubuntu installés sur un système avec Secure Boot sur UEFI, le module du noyau non signé peut ne pas se charger. Dans ce cas, consultez CETTE REPONSE pour y remédier.

Mise à jour: J'ai maintenant un ordinateur portable avec cet adaptateur. Il fonctionne parfaitement sur le noyau 4.8 disponible dans Ubuntu 16.10 et 16.04.2.

L'installation d'un pilote personnalisé est requise uniquement pour les noyaux antérieurs à 4.8.

Je suggère d'installer le noyau 4.8 sur Ubuntu 16.04 s'il n'est pas encore installé par

sudo apt install linux-generic-16.04

L'appareil devrait fonctionner correctement après un redémarrage.

Mais encore, si votre ordinateur portable ne possède qu’une antenne et qu’il est connecté à un "mauvais" connecteur, il peut être nécessaire de définir ant_sel=2 ou and_sel=1 .

    
réponse donnée Pilot6 12.06.2015 - 17:25
la source
5

Si votre Wifi tombe au bout d’un moment et que vous double-amorcez avec Windows

Sur HP 250 G4 (en utilisant rtl8723be), j'ai d'abord eu le bogue d'antenne : le signal wifi était trop bas:

Il a été résolu après l’installation d’un nouveau pilote et la configuration de ant_sel=2 , comme décrit ici.

Puis est venu le 2ème problème:
le wifi fonctionnait bien pendant un certain temps (parfois 2 heures) puis soudainement, il a ralenti et a fini par se déconnecter.
Changer les paramètres (ips, fwps ...) n'a pas aidé.
J'ai finalement trouvé que supprimer Windows 10 fastboot (dans les paramètres d’énergie Windows) résolvait le problème.

Cela a été confirmé par un autre utilisateur (voir RTL8723BE: le Wifi baisse toujours après 15/20 minutes

    
réponse donnée laugeo 02.07.2016 - 12:49
la source
4

Ce qui a fonctionné pour moi était d’activer le paramètre MSI (interruption du signal du message). J'ai un ordinateur portable lenovo Z50. Mon wifi fonctionnerait avec tous les fabricants d’ordinateurs portables wifi mais j’avais un problème avec un routeur wifi Lancorm dans un hôtel où j’ai déjà séjourné.

J'ai trouvé le fichier sw.c dans le chemin du dossier

/home/peter/rtlwifi_new/rtl8723be

Ensuite, dans le fichier sw.c , j'ai ajouté la variable .msi_support et l'ai initialisée à "false" sous le type de données

rtl_mod_params rtl8723be_mod_params

i.e

static struct rtl_mod_params rtl8723be_mod_params = {
.sw_crypto = false,
.inactiveps = true,
.swctrl_lps = false,
.fwctrl_lps = true,
.msi_support = false,
};

Comme msi_support est désactivé par défaut, nous devons l'initialiser de manière appropriée comme désactivé (donc faux),

J'ai ensuite respecté le code:

cd rtl8723be
make clean
sudo make install
sudo modprobe rtl8723be

Après cela, je mets le paramètre msi à 1 dans le fichier

/etc/modprobe.d/rtl8723be.conf

il devrait contenir

options rtl8723be fwlps=N ips=N swenc=Y msi=1

Vous devrez peut-être redémarrer l'ordinateur et attendre quelques minutes après le redémarrage du navigateur pour que le msi soit déclenché.

Cela a fonctionné pour un lenovo z50. Selon votre PC, vous pouvez basculer et choisir plutôt un msi de 0

    
réponse donnée Der Kabiri 15.11.2015 - 21:46
la source
2

Il suffit de prendre un HP Stream 13 et de l’essuyer, de mettre Ubuntu 15.10 sur la carte SD de 64 Go pour étendre le SSD de 32 Go, puis de résoudre le problème du redoutable Ordinateur portable de travail HP 430 avec une variante différente ....

Après beaucoup de désordre, je trouve finalement qu’il ya en fait 2 problèmes ici.

  1. Le pilote WiFi doit être échangé comme indiqué ci-dessus, afin de remédier aux problèmes d'abandon de la carte nécessitant le redémarrage du gestionnaire de réseau ou la resynchronisation de la carte avec le réseau. Mettez à jour le pilote comme indiqué.

    sudo add-apt-repository ppa:hanipouspilot/rtlwifi
    sudo apt-get update
    sudo apt-get install rtlwifi-new-dkms linux-firmware
    
  2. Une fois que vos abandons sont résolus, vous devez résoudre le problème de la faible intensité du signal ... Ceci est un peu plus invasif. Dévisser toutes les vis du bas, même celles situées sous les 2 pieds arrière en caoutchouc, centrer le petit couvercle en caoutchouc et les couvercles en caoutchouc de la charnière tout en bas.

Détachez doucement le haut en cliquant dessus pour l'éloigner de la base. Soulevez doucement. Localisez la carte réseau au centre, vers l'arrière. Retirez le câble coaxial fin de l'antenne connectée (principale) et replacez-le sur le connecteur situé à côté (aux). Remettez tout ensemble.

Le pilote pour Linux utilise l’autre antenne de cette carte à double antenne. Si vous ne l’échangez pas, vous subirez une perte de signal importante.

Maintenant, l’ordinateur portable dispose de beaucoup d’espace pour le stockage, se met rapidement en route et offre un signal complet sans perte de signal partout dans la maison. Super petit ordinateur portable pour le prix mais nécessite une planification si vous voulez mettre Linux dessus.

Merci à tous pour votre travail.

    
réponse donnée Paul 29.01.2016 - 00:41
la source
1

J'ai eu le même problème, j'ai mis à jour mon pilote comme expliqué dans Réponse de Pilot6 , mais il est toujours souvent déconnecté. Je cherchais désespérément une autre solution lorsque j'ai trouvé dans la réponse de laugeo que supprimer Windows 10 fastboot permet de résoudre le problème. Malheureusement, je n'ai que Ubuntu et pas de Windows. Cependant, j'ai trouvé que la simple désactivation de Legacy Support résout le problème!

J'ai dû désactiver le support Legacy dans Bios comme ceci:

Bios - & gt; Option de démarrage (Entrée) - & gt; Prise en charge héritée: désactivé

Maintenant, le WLAN fonctionne parfaitement - plus de déconnexion!

    
réponse donnée Adam 09.11.2016 - 19:12
la source
0

C'était le même cas avec moi. J'ai aussi essayé rfkill list all mais rien n'était bloqué. Pourtant, le Wi-Fi ne fonctionne pas correctement.

mon résultat rfkill list tous résultat

Pendant 2 jours depuis l’installation d’Ubuntu 14.04 LTS, j’ai essayé différents réglages. Était presque frustré et perdre espoir. Finalement, ça marche.

Solution possible : après avoir essayé différents réglages, je suis tombé sur un code qui semble fonctionner. Aller au terminal, copier-coller la commande suivante et l'exécuter -

echo "options rtl8723be fwlps = 0 swlps = 0" | sudo tee /etc/modprobe.d/rtl8723be.conf

Ensuite, vous devez redémarrer une fois. Maintenant, je peux accéder à Internet par Wi-Fi sans aucune baisse.

Bonne chance!

    
réponse donnée MIMO Rulz 31.01.2016 - 08:54
la source

Lire d'autres questions sur les étiquettes