Les associations d'applications Firefox ne fonctionnent pas dans la fenêtre 'Téléchargements'

9

Quelles que soient les modifications apportées aux associations de fichiers (actions) dans l'onglet "Applications" de Firefox, elles sont totalement ignorées.
Par exemple, j'ouvre les fichiers .wmv et .avi avec "smplayer", mais lorsque je télécharge un fichier et que je double-clique dessus (via la fenêtre "Téléchargements") ), il continue à s’ouvrir avec le lecteur Totem.

Les associations de fichiers par défaut via Nautilus (onglet "Ouvrir avec") fonctionnent correctement, c’est-à-dire que j’ai défini smplayer comme lecteur par défaut et lorsque je double-clique sur un fichier vidéo, il s’ouvre correctement.

J'ai essayé de supprimer et de recréer mimetypes.rdf mais cela n'a pas aidé.

Des idées sur les autres points à vérifier?

    
posée Pavlos G. 04.01.2011 - 16:18
la source

6 réponses

10

MISE À JOUR: Depuis Firefox 18, Firefox prend en charge GIO au lieu de GnomeVFS, , la solution de contournement ci-dessous ne devrait donc plus être nécessaire. Si quelqu'un frappe encore ce problème dans les versions récentes de Firefox, il est peu probable que ce problème soit résolu.

Alors, prenez le reste de cet article avec un grain de sel ...

Le correctif

Cela corrige pour moi:

cd .local/share/applications/
ln -s mimeapps.list defaults.list

et enfin, redémarrez Firefox. À son retour, son gestionnaire de téléchargement doit appeler le programme correct (comme spécifié dans les fichiers .list référencés ci-dessus).

Détails

Firefox (à travers les nightlies du trunk à partir de ce post) utilise actuellement l’API GnomeVFS pour demander "Quelle application dois-je utiliser pour ouvrir les fichiers avec ce type MIME?" Cependant, GnomeVFS est devenu obsolète en faveur de GIO.

Nautilus (je regarde le ver 2.32.2.1) utilise maintenant GIO pour enregistrer les applications de gestionnaire par défaut spécifiées par l'utilisateur (comme smplayer dans votre cas). GIO et GnomeVFS utilisent différents fichiers pour gérer leurs paramètres, mais les fichiers sont apparemment au même format (au moins assez similaire pour que le hack " ln " ci-dessus fonctionne pour moi.:))

(J'ai examiné cela un peu plus en détail sur un rapport de bogue Mozilla .

    
réponse donnée dholbert 31.07.2011 - 03:19
la source
1

Pour faire suite à la solution de Peterling, cela a fonctionné pour moi. J'étais en train de jouer avec mes fichiers de types MIME en essayant toujours de le comprendre. Il s'avère que l’installation de Nautilus sur mon système KDE Mint17 était la voie à suivre. Il me semble ridiculement compliqué que Firefox examine les paramètres de Nautilus sur un système qui ne l’a même pas, mais le tour est joué. J'utilise Firefox 33 BTW.

    
réponse donnée Lars 09.11.2014 - 06:45
la source
1

Curieusement, ce sujet semble encore d'actualité en 2018.

Certaines applications nouvellement installées reprennent le statut "par défaut" dans about:preferences de FF au lieu de l’application normale par type de fichier au niveau système (par exemple, Palemoon prend le relais au lieu de gwenview pour les fichiers jpeg, Inskape ou File Roller prend au lieu de Okular pour le fichier pdf.).

"Always ask" est le choix qui doit être utilisé dans ce cas, puis essayer de créer un fichier par utilisateur ~/.local/share/applications/mimeinfo.cache avec les lignes:

[MIME Cache]
application/pdf=okularApplication_pdf.desktop

L'inconvénient de ce qui précède est qu'il s'agit d'un paramètre de type par fichier. Pour avoir une solution pour tous les fichiers (comme indiqué dans cette réponse), exécutez:

cd .local/share/applications/
ln -s mimeapps.list defaults.list

Au cas où cela ne fonctionnerait plus: vérifiez que l'application indésirable n'est plus sélectionnée sous about:preferences : assurez-vous que l'option "Toujours demander" est sélectionnée. La configuration manuelle d'un programme différent (même la valeur par défaut pour votre type de fichier au niveau du système, mais qui n'est pas marquée comme "par défaut" dans la liste de votre fichier sous about:preferences ) peut ne pas fonctionner.

Testé sous Firefox 60.0 dans Kubuntu 18.04.

Quelque chose ne va pas avec les paramètres de Firefox. "Toujours demander" et "Enregistrer le fichier" n'ont pas de sens pour les fichiers déjà téléchargés. Par conséquent, les paramètres sous about:preferences ne doivent pas affecter la liste des téléchargements. Mais ils le font . Et ils le font de manière incohérente: en ne sélectionnant que l'application marquée par défaut, le passage à une autre application ne l'est pas. Pour inverser cela, il peut être nécessaire de sélectionner "Toujours demander", puis suivez les étapes mentionnées ci-dessus.

    
réponse donnée cipricus 22.05.2018 - 23:04
la source
0

Il n’ya rien à faire avec Firefox. Car le fichier est déjà téléchargé. Si vous voulez ouvrir les fichiers .wmv et .avi téléchargés avec smplayer , vous pouvez le faire comme ceci. Faites un clic droit sur n'importe quel fichier .wmv et sélectionnez 'Open With' --> 'Other Application...' et sélectionnez votre application préférée (dans ce cas smplayer ) dans la liste et cochez la case ' Remember this application for "WMV video" files '. Faites de même pour les fichiers .avi également.

Ou si vous voulez ouvrir les fichiers de la boîte de dialogue d’enregistrement de firefox avec l’application souhaitée, suivez simplement cet article: lien

J'espère que ça aide

    
réponse donnée aneeshep 04.01.2011 - 17:12
la source
0

L'onglet Applications des préférences de Firefox contrôle la manière de lire le contenu incorporé ou lié, et non les fichiers téléchargés. Pour modifier l'application qui ouvre un type MIME spécifique via le gestionnaire de téléchargement, fermez Firefox, puis supprimez le fichier mimeTypes.rdf de votre profil, puis ouvrez à nouveau Firefox et double-cliquez sur le fichier dans le gestionnaire de téléchargement. Il vous demandera d'utiliser l'application. Choisissez / usr / bin / smplayer , puis cochez l’option pour vous souvenir de votre choix.

    
réponse donnée lovinglinux 04.01.2011 - 23:48
la source
0

Je sais que cette question a maintenant plus d’un an mais j’ai maintenant le même problème avec Firefox et j’ai trouvé la solution après un long combat avec beaucoup de retouches et de modifications.

Et j'en suis si heureux que je veux le partager :)

La solution (dans mon cas) est assez simple:

Tous les fichiers téléchargés avec Firefox et ouverts en un clic dans la fenêtre de téléchargement semblaient être ouverts par ??? parce que cela n'a pas été géré avec les paramètres de firefox et pas avec mimeTypes.rdf ... Il est géré par Nautilus. (bien que je ne sache pas pourquoi)

Alors lancez simplement Nautilus ... recherchez un type de fichier qui n’est pas géré correctement par firefox - faites un clic droit dessus - propriétés - ouvrez avec - & gt; choisissez l'application avec laquelle vous souhaitez ouvrir ce type de fichier avec ... done.

À partir de maintenant, Firefox ouvrira tous les fichiers avec l’application voulue en cliquant dessus dans la fenêtre de téléchargement de Firefox.

    
réponse donnée Peterling 02.02.2013 - 13:29
la source

Lire d'autres questions sur les étiquettes