Comment puis-je basculer automatiquement sur le casque USB lorsqu'il est branché?

9

Chaque fois que je branchais mon ancienne oreillette audio, le son était immédiatement renvoyé de mes haut-parleurs vers les haut-parleurs du casque et le microphone était immédiatement disponible.

Lorsque je branche mon nouveau casque USB, je dois ouvrir les préférences sonores et basculer les entrées et les sorties vers le casque.

Y a-t-il un moyen de faire cela automatiquement?

J'utilise un ordinateur portable Fujitsu-Siemens Amilo Pi, Maverick et un casque USB Logitech H330.

    
posée d3vid 14.01.2011 - 09:28
la source

2 réponses

3

C'est en fait un bogue dans Pulseaudio.

Ici est un rapport de bogue récent sur la situation, mais il pourrait s'agir d'un dupe de cet plus ancien (mais apparemment fixe).

Voici une solution de contournement que vous pouvez éventuellement utiliser. Créez un fichier texte et collez-le dans:

#! /bin/bash

amixer cset iface=MIXER,name='Input Source' 1
amixer cset iface=MIXER,name='Output Source' 1
exit

S'il s'agit de votre troisième, vous devez remplacer les numéros de fin sur les commandes par le numéro "2". Si quatrième, alors "3". Et ainsi de suite.

Vous pouvez ensuite créer un lanceur sur le panneau et cliquer dessus chaque fois que vous branchez le casque. C'est une solution de contournement moche pour le moment mais jusqu'à ce qu'il soit corrigé (c'est-à-dire que Pulseaudio se souvient des périphériques préférés), je ne vois pas grand-chose d'autre que vous puissiez faire.

Vous pourriez faire une solution de rechange extrêmement délirante impliquant l’écriture de règles udev ... mais cela en vaut-il la peine? ;)

    
réponse donnée user6658 22.01.2011 - 16:46
la source
1

J'ai trouvé la réponse ici: lien

Vous pouvez faire l’une des deux choses suivantes (ou les deux):

ouvre alsamixer en utilisant la ligne de commande:

alsamixer

puis appuyez sur F6 et sélectionnez le périphérique par défaut pour alsa. Une fois cela fait, sauvegardez les paramètres alsa:

sudo alsactl store

Il peut également être nécessaire d’éditer le fichier de configuration alsa: ( /etc/modprobe.d/alsabase.conf ). Vous placez ensuite un «0» à côté du périphérique que vous voulez par défaut, donc si c'est un périphérique audio USB, vous aurez une ligne comme celle-ci:

options snd-usb-audio index=0

Puis redémarrez le système.

    
réponse donnée user273738 29.09.2014 - 03:20
la source

Lire d'autres questions sur les étiquettes