se connecter à archive.ubuntu.com prend trop de temps

50

J'ai un serveur Ubuntu 11.10 que je viens d'installer. Maintenant, si j'essaye de faire quelque chose avec apt-get , il essaie de se connecter à archive.ubuntu.com .. Il reste à la phase [Connecting to archive.ubuntu.com (2001:67c:1360:8c01::1a)] pendant 2 minutes, après quoi il commence à communiquer et à télécharger des choses ...

Finalement, il se connecte toujours, mais attend toujours la phase [Connecting to archive.ubuntu.com (2001:67c:1360:8c01::1a)] pendant environ 2 minutes!

Je n'avais pas ce problème auparavant sur Ubuntu 11.10, juste après la réinstallation du système d'exploitation.

Des idées sur ce que le problème pourrait être?

    
posée Ahmad 26.03.2013 - 21:25
la source

3 réponses

85

J'ai résolu cela le 12.10 en éditant /etc/gai.conf et en décommentant la ligne:

#
#    For sites which prefer IPv4 connections change the last line to
#
precedence ::ffff:0:0/96 100

Cela vous permet de garder IPv6 activé, mais définit l’ordre de priorité pour préférer IPv4 à IPv6.

    
réponse donnée UberSteve 07.10.2013 - 16:57
la source
17

Solution:

J'ai compris le problème. Je devais désactiver la connectivité IPv6, comme le soulignait The Lord Of Time.

L'exécution de la commande suivante dans Terminal indique si IPv6 est activé ou non:

cat /proc/sys/net/ipv6/conf/all/disable_ipv6

0 signifie qu'il est activé, tandis que 1 signifie qu'il est désactivé.

Pour désactiver IPv6 depuis Terminal, entrez les informations suivantes:

echo "#disable ipv6" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.default.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.lo.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
sudo sysctl -p

Réexécutez la première commande, qui devrait être 1 maintenant.

    
réponse donnée Ahmad 27.03.2013 - 22:31
la source
6

Si vous voulez seulement modifier apt-get, vous pouvez forcer IPv4 avec:

apt-get -o Acquire::ForceIPv4=true update

Pour rendre le paramètre persistant, créez le fichier 99force-ipv4 dans /etc/apt/apt.conf.d /.

sudoedit /etc/apt/apt.conf.d/99force-ipv4

Mettez-y le contenu suivant:

Acquire::ForceIPv4 "true";

Enregistrez le fichier et vous êtes prêt à partir. Si vous voulez forcer IPv6 à la place, changez le 4 à 6 dans le nom du fichier et les paramètres. Pour choisir entre l'une d'entre elles, testez avec la méthode rapide et voyez ce qui fonctionne le mieux.

    
réponse donnée Luke 12.07.2016 - 00:41
la source

Lire d'autres questions sur les étiquettes