Problèmes après la mise à niveau vers 14.04 (uniquement l'arrière-plan et le pointeur après la connexion) [dupliquer]

48

Après la mise à niveau de 12.04 à 14.04, je pouvais me connecter à ma session X (avec des graphismes vraiment faibles). En essayant de réparer les graphiques, j'ai réussi à casser la session X.

Maintenant, après avoir tapé mon mot de passe dans l'unité-greeter, les éléments disparaissent et je ne peux voir que l'arrière-plan du bureau et le pointeur. Cela se produit pour chaque utilisateur. Je peux toujours me connecter dans tty's. Comment puis-je résoudre ce problème?

De plus, je n'arrive pas à installer nvidia-current car il essaie d'installer nvidia-304 et cela dépend d'anciennes bibliothèques de vidéos-abi. Est-il possible de dire au gestionnaire de paquets que nvidia-current doit utiliser une version plus récente?

    
posée fabikw 18.04.2014 - 17:28
la source

9 réponses

47

Ce bogue dépend de plusieurs facteurs, y compris la carte vidéo et les fichiers de configuration personnalisés. Par exemple, certains utilisateurs ont résolu le problème en utilisant une ou plusieurs des "solutions" suivantes (tous ne fonctionnent pas, certains utilisateurs ont même besoin d’une combinaison en fonction de la configuration de la session et du matériel utilisé):

Correction 1 - Problèmes de Compiz (le module OpenGL ne se charge pas, le plug-in Unity ne se charge pas)

sudo rm -fr ~/.cache/compizconfig-1
sudo rm -fr ~/.compiz

Correction 2 - La session ne se charge pas (la session invité charge correctement)

sudo rm -fr ~/.Xauthority
sudo rm -fr ~/.config/autostart

Fix 3 - La session ne se charge pas (invité non chargé)

sudo apt-get install --reinstall ubuntu-desktop unity compizconfig-settings-manager upstart

Fix 4 - Launcher / Top Panel ne se charge pas (cartes Nvidia)

sudo add-apt-repository ppa:xorg-edgers/ppa -y
sudo apt-get update
sudo apt-get install nvidia-340
sudo reboot

Fix 5 - Effacer l’unité

dconf reset -f /org/compiz/
setsid unity

Fix 6 - Effacer le cache

sudo rm -fr .cache/*

ATTENTION - Ceci effacera le cache pour toutes les applications à l’intérieur du dossier .cache.

Dans la plupart des cas, si la session s'ouvre et que vous ne pouvez toujours pas voir le panneau supérieur ou le lanceur, essayez d’ouvrir un terminal CTRL + ALT + T et en tapant ccsm (en supposant que vous avez déjà installé le package compizconfig-settings-manager ), activez le plug-in OpenGL et le plug-in Unity. Si le pilote fonctionne correctement, cela devrait activer les deux panneaux en quelques secondes. Il existe même des cas où le plug-in Unity du gestionnaire de paramètres de configuration compiz n'est tout simplement pas activé.

    
réponse donnée Luis Alvarado 11.06.2014 - 03:19
la source
31

C'est ce qui a résolu mon problème. Une fois que vous avez démarré sur le bureau vide ... appuyez sur CTRL + ALT + F1.

apt-get install --reinstall ubuntu-desktop
apt-get install unity
apt-get purge nvidia* bumblebee*
apt-get install nvidia-prime
shutdown -r now

Lorsque l’ordinateur est revenu, mon écran de connexion était en haute définition. J'ai entré mon mot de passe. ATTENDRE pendant une minute, il y a un délai de démarrage et le bureau BAM est apparu et les popups là-bas, peu de temps au démarrage.

    
réponse donnée bbullis 21.04.2014 - 03:56
la source
6

J'utilisais un thème personnalisé avec mon ancienne version (12.04), donc je le réinitialise à la valeur par défaut. J'ai d'abord essayé de passer au thème Ambience (par défaut). Vous pouvez essayer en cliquant avec le bouton droit de la souris et en sélectionnant "Modifier l’arrière-plan du bureau. Vous pouvez y accéder via certains menus.

-ou -

vous pouvez réinitialiser Compiz. Vous devrez le faire en dehors de Unity. Déconnectez-vous, basculez vers une console ( CTRL + ALT + F1 ), puis supprimez vos paramètres Compiz et mettez en cache:

rm -r ~/.cache/compizconfig-1
rm -r ~/.compiz

Déconnectez-vous de la console, revenez à l'interface graphique ( CTRL + ALT + F7 ) et connectez-vous. sur ses valeurs par défaut, et vous aurez votre bureau de retour, moins toute personnalisation que vous avez pu faire.

J'ai redémarré et tout a fonctionné ... mieux que ça. encore quelques problèmes mais pas liés à celui-ci. c'est aussi mon premier post de réponse, soyez gentil.

    
réponse donnée XXmickeymoorexx 25.04.2014 - 04:50
la source
6

OK, j'ai réussi à résoudre mon problème en suivant cette procédure.

J'ai démarré Ubuntu dans des paramètres avancés et j'ai d'abord réparé tous les paquets détruits / corrompus. J'ai eu un total de 700 Mo de paquets corrompus à réparer après un crash pendant la mise à niveau 13.10- & gt; 14.04. Ensuite, j'ai démarré dans le terminal racine.

Je suis ensuite allé de l'avant pour supprimer tous les pilotes propriétaires par

sudo apt-get purge nvidia* bumblebee*

Et puis est allé de l'avant pour installer les «nouveaux» pilotes opensource qui en général ne sont pas recommandés (en termes de performances), mais puisque je n'ai pas besoin de graphiques 3D extensifs sur mon ordinateur de travail et tous les autres pilotes ont échoué moi, c'était la seule solution.

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core xserver-xorg-video-nouveau

Après avoir essayé de résoudre mes problèmes de différentes manières, je voulais m'assurer que je ne foirais pas les paquets Unity et Ubuntu, alors je les ai réinstallés

sudo apt-get install --reinstall ubuntu-desktop unity

J'ai redémarré mon ordinateur et tout fonctionne depuis. Je ne suis pas sûr si c'est mon ordinateur ou les pilotes, mais je n'étais pas tout à fait satisfait de la vitesse de Unity / Compiz, donc j'ai installé le Gestionnaire de paramètres Compiz Config et changé les effets visuels de "Bon" à "Rapide"

sudo apt-get install compizconfig-settings-manager
    
réponse donnée asgerbj 25.04.2014 - 22:08
la source
6

Si vous avez abandonné, vous ne pouvez pas confirmer si cette solution fonctionne pour vous ou non. Mais je posterai de toute façon dans l'espoir que quelqu'un d'autre puisse en bénéficier.

Version courte:

Veuillez essayer de renommer le répertoire /home/[user_name]/.config/dconf en /home/[user_name]/.config/dconf.original

Faites-le depuis un terminal texte ou si vous pouvez utiliser l'interface graphique (plus de ce dernier) à partir d'une session différente de celle définie par la session utilisateur. Puis reconnectez-vous en tant qu'utilisateur concerné. Le problème a-t-il été résolu?

Version longue:

Mon système a 4 utilisateurs. Deux utilisateurs sont membres du groupe admin et peuvent utiliser la commande sudo. Je suis passé de 13.10 à 14.04. Après un certain temps en utilisant 14.04 le deuxième utilisateur admin a commencé à avoir le même problème, de la connexion à l’hôte à une image d’arrière-plan avec un pointeur de souris et plus, pas de barre de menus en haut de aussi CTRL + ALT + L ne fonctionnait plus, fermer la session passer à un autre tty et utiliser sudo restart lightdm était nécessaire.

L'utilisateur concerné peut utiliser Gnome 3 sans problème, seule la session Unity a été affectée.

Comme tous les autres utilisateurs pouvaient se connecter avec Unity ou Gnome 3, il était évident que quelque chose était corrompu sur le côté de l'utilisateur concerné. Je voulais corriger cette session sans avoir à supprimer l'utilisateur et à le recréer. J'ai donc renommé son répertoire .config dans l’espoir qu’à l’intérieur de lui, un fichier de configuration provoquait tout cela. Et c'était exactement ça. La prochaine tentative de connexion à une session Unity était correcte (mais tous les programmes ont été réinitialisés). Si je mets le répertoire .config d'origine en place, le problème est réapparu. Ensuite, j'ai commencé à travailler dans le répertoire .config, j'ai tout d'abord renommé la moitié de ses sous-répertoires (il y avait environ 40 sous-répertoires) et, dans la première tentative, j'ai atteint le groupe contenant le coupable. Ensuite, j'ai mis en place la moitié de cette moitié et le problème est réapparu. Ensuite, j'ai renommé la moitié de ce dernier groupe et ... je pense que vous savez déjà comment cela se passe.

En utilisant cette méthode, j'ai finalement frappé le coupable. Renommer le répertoire dconf a résolu le problème.

Le contenu de

.config / dconf (en fait un fichier unique) ne doit pas nécessairement être corrompu. Peut-être que ce n'est pas corrompu (au niveau du système de fichiers, mon système de fichiers est propre) mais contient des données non valides qui se sont arrêtées là à cause d’un bogue qui sait quel composant du système.

J'ai également noté dans votre cas que tous les utilisateurs sont affectés, ce qui peut ne pas être la solution à votre problème. Mais je pense qu’il est possible que tous les utilisateurs rencontrent ce problème en même temps et qu’ils puissent toujours être provoqués par le même fichier (à chaque répertoire utilisateur .config).

    
réponse donnée Hatoru Hansou 06.05.2014 - 04:52
la source
3

J'ai eu le même problème!

j'ai purgé le fglrx

sudo apt-get purge fglrx-*

Je nettoie aussi le compiz et le cache

mkdir ~/backup
sudo mv ~/.compiz ~/backup
sudo mv ~/.cache ~/backup

après le redémarrage et la connexion, attendez quelques instants. Il est finalement apparu.

    
réponse donnée Yip Wai Peng 25.04.2014 - 07:12
la source
2

A partir du 3 juin 2014, j'ai eu ce problème sur plusieurs ordinateurs avec Intel VGA et aucune des solutions proposées n'a résolu le problème.

Après plusieurs jours de recherches et de tentatives, je suis tombé sur le paquetage xserver-xorg-video-intel trouvé dans le PPA de Xorg-edgers.

Pour résoudre le problème, lancez simplement ces deux commandes:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa

puis redémarrez.

    
réponse donnée Roberto Leinardi 06.06.2014 - 17:25
la source
0

Quelque chose comme:

sudo dpkg-reconfigure xserver-xorg

devrait reconfigurer X.

Une fois connecté, vous devriez pouvoir télécharger le pilote directement depuis le site de nVidia et l'installer de cette manière.

    
réponse donnée lbaile200 18.04.2014 - 17:58
la source
0

Le problème est la mise à jour de gnome-session. Après le redémarrage, exécutez ces deux commandes:

Ouvrir la ligne de commande CTRL + ALT + F1

Connectez-vous

sudo apt-get update
sudo apt-get install gnome-session
reboot your system

Le problème est résolu

    
réponse donnée Nuno 07.06.2014 - 12:40
la source

Lire d'autres questions sur les étiquettes