Comment faire fonctionner les touches F dans byobu, midnight commander (mc), htop, etc.?

44

J'utilise byobu avec le backend tmux sur mon serveur 12.04. Je voudrais utiliser les touches de raccourci du commandant de minuit avec lui, mais les touches F ne fonctionnent pas.

J'ai vu des articles sur les problèmes ici:

mais ils sont obsolètes et ne semblent pas fonctionner pour les nouvelles versions de byobu. Comment puis-je contourner ce problème ou utiliser MC d'une manière qui fonctionne mieux?

    
posée Jorge Castro 05.06.2012 - 04:37
la source

3 réponses

64

Vous pouvez facilement activer / désactiver l’utilisation des touches F dans Byobu (tmux) en appuyant sur:

  • shift - F12 (dans tmux)

  • ctrl - a - ! (dans l’écran)

Divulgation complète: je suis l'auteur et le responsable de Byobu.

    
réponse donnée Dustin Kirkland 08.06.2012 - 17:47
la source
8

Sur midnight commander pour déclencher la touche F, par exemple au lieu de F2 :

  • Appuyez sur Alt + 2 .
  • Appuyez sur ESC , 2 (l’un après l’autre).

Peut-être plus pratique que d’utiliser:

  • shift - F12 (dans tmux, par défaut sur byobu)

  • ctrl - a - ! (dans l’écran)

réponse donnée takeshin 06.10.2014 - 14:11
la source
3

Hah, un homme après mon cœur:)

Réponse courte: ajoutez mon ppa ( ppa:izx/private ) et update byobu (ou installez manuellement le deb). Byobu utilisera par défaut screen comme backend avec le comportement de la touche F restitué dans l'ancien style 4.x.

Réponse longue: Utilisez byobu-select-backend pour passer à screen si vous ne l’avez pas déjà et ajoutez la ligne $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen.disable après la ligne $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen in /usr/share/byobu/keybindings/common .

Tout le patch:

+++ byobu-5.17/usr/share/byobu/keybindings/common
@@ -1 +1,3 @@
 source $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen
+source $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen.disable
+
--- byobu-5.17.orig/etc/byobu/backend
+++ byobu-5.17/etc/byobu/backend
@@ -1,4 +1,4 @@
 # BYOBU_BACKEND can currently be "screen" or "tmux"
 # Override this on a per-user basis by editing "$BYOBU_CONFIG_DIR/backend"
 # or by launching either "byobu-screen" or "byobu-tmux" instead of "byobu".
-#BYOBU_BACKEND="tmux"
+BYOBU_BACKEND="screen"
    
réponse donnée ish 05.06.2012 - 05:30
la source

Lire d'autres questions sur les étiquettes