Comment exécuter un invité 64 bits dans VirtualBox?

43

Je voudrais avoir un environnement de test Ubuntu 11.04 64 bits. Lorsque j'essaie de démarrer le CD d'installation d'Ubuntu 11.04 64 bits dans VirtualBox, le message suivant est affiché par VirtualBox:

  

L'accélération matérielle VT-x / AMD-V a   été activé, mais n'est pas opérationnel.   Votre invité 64 bits ne pourra pas détecter   un processeur 64 bits et ne sera pas en mesure de   boot.

     

Veuillez vous assurer que vous avez activé   VT-x / AMD-V correctement dans le BIOS de   votre ordinateur hôte.

Qu'est-ce que je fais mal?

Détails:

  • VBox.log , test ubuntu. vbox et / proc / cpuinfo .
  • Noyau: Linux aux 2.6.38-8-generic # 42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU / Linux
  • Le paramètre de virtualisation du BIOS est défini sur Activé.
posée ændrük 09.05.2011 - 18:59
la source

9 réponses

43

Pour pouvoir exécuter un système 64 bits dans un VirtualBox, vous avez besoin d'un processeur prenant en charge la virtualisation. AMD appelle cette fonction AMD-V, Intel utilise VT-x. Le Wikipedia explique cela. Il existe deux processeurs Pentium-4 capables d’exécuter un système d’exploitation 64 bits, mais ne proposent pas cette technologie VT-x. Vous pouvez vérifier votre système en ...

$ egrep '(vmx|svm)' /proc/cpuinfo
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx cid cx16 xtpr lahf_lm
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx cid cx16 xtpr lahf_lm

Si vous n'obtenez aucune sortie, vous ne pouvez pas exécuter un système d'exploitation 64 bits en tant qu'invité dans votre VirtualBox. Mais n'oubliez pas de vérifier les paramètres de votre BIOS. Vous pouvez peut-être activer ces fonctionnalités AMD-V / VT-x dans le BIOS de votre ordinateur.

Et enfin, il y a une case à cocher dans les paramètres de VirtualBox. Démarrez VirtualBox, sélectionnez la machine virtuelle sur laquelle vous souhaitez exécuter votre système d'exploitation 64 bits et accédez aux paramètres de cette machine virtuelle. Recherchez "Settings - & gt; System - & gt; Acceleration" et assurez-vous que "Enable VT-x / AMD-V" est activé.

Bonne chance :) Christoph

    
réponse donnée Chrissss 09.05.2011 - 19:30
la source
15

Assurez-vous d'avoir sélectionné la version 64 bits de votre distribution Linux dans l'assistant lors de la création de l'invité. J'ai eu le même problème, mais il a été résolu en définissant l'option correcte à la "version" de la distribution.

Même lorsque vous démarrez une image ISO 64 bits, celle-ci ne fonctionnera pas tant que je n'aurai pas défini cette option ( Général - & gt; Basic - & gt; Version ).

Vous devriez alors pouvoir activer VT-x et I / O Apic.

    
réponse donnée erm3nda 26.06.2013 - 18:10
la source
7

Activer la virtualisation dans le BIOS.

Si cela ne fonctionne toujours pas, laissez la machine à l'arrêt pendant quelques minutes.

    
réponse donnée Sanjaya Balasuriya 05.06.2012 - 11:47
la source
5

Vous devez activer l’APIC IO pour démarrer un OS 64 bits. C'est du moins ce que disent les documents , regardez le texte dans le grand carré rouge;) .

Il ne semble pas activé dans votre fichier .vbox:

<IOAPIC enabled="false"/>
    
réponse donnée Javier Rivera 09.05.2011 - 19:37
la source
2

Ceci est un problème uniquement avec VirtualBox, pour moi c'est un bogue. Si vous installez le même système d'exploitation, disons en utilisant le VMWare Player sur le même ordinateur, cela fonctionne très bien. Sans mise à jour du BIOS.

Assez ennuyeux.

    
réponse donnée YAXAONE 28.12.2011 - 06:17
la source
1

Pour un mobo Asus M5A88-M équipé d’un processeur AMD FX6100, la sélection correcte du BIOS se trouve dans la "Configuration du processeur" (sous l’onglet Avancé), ENABLE " Mode de la machine virtuelle sécurisée " et déjà mentionné, assurez-vous que VBox " Paramètres - & gt; Système - & gt; Accélération " et assurez-vous que " Activer VT-x / AMD-V " est activé.

Pour autoriser plus d’un cœur avec cette configuration, vous devez déverrouiller les cœurs dans le BIOS (ou en appuyant sur 4 sur l’écran de démarrage Asus), mais je n’ai pas encore essayé le core unlocker.

    
réponse donnée Bill V 27.04.2012 - 07:30
la source
0

J'ai Virtual Box 4.1.12 avec le pack d'extension correspondant installé sur le système d'exploitation Linux Mint 13 Maya Xfce et Windows XP Home Edition installé.

Avec l’aide de mon fils, j’ai maintenant les clés USB activées. Pour activer les clés USB, appuyez sur les bonnes touches Ctrl + Accueil et sélectionnez Périphérique Installer les ajouts d'invité , exécutez-le. , il installe un certain nombre d'éléments dans Windows, ne cochez pas la case 3d.

Au redémarrage de Windows, assurez-vous qu’il démarre en mode sans échec, connectez-vous en tant qu’administrateur (Windows), puis réexécutez les ajouts d’invité, cochez cette case et redémarrez la session. Arrêtez la session Windows XP, fermez VirtualBox, arrêtez l'ordinateur. Redémarrez l'ordinateur, redémarrez la boîte virtuelle, redémarrez la session Windows XP, appuyez maintenant à droite Ctrl + Accueil , Périphérique USB devrait fonctionner, vous devriez voir tous les périphériques USB connectés dans le menu déroulant.

J'ai pu connecter ma calculatrice TI (qui a des fonctionnalités très limitées sous Linux (probablement plus que mes connaissances)). Windows XP dans VirtualBox sur PC hôte Linux est la voie à suivre avec Windows.

    
réponse donnée Bill V 30.09.2012 - 07:45
la source
0

si vous avez la capacité, l'activation de votre BIOS devrait être très simple, il suffit de démarrer dans le BIOS et de rechercher la "virtualisation" sous "Sécurité". Ensuite, activez simplement. :)

    
réponse donnée krypsy 04.05.2013 - 11:14
la source
0

Assurez-vous d'avoir activé VT-x / AMD-V correctement dans le BIOS de votre ordinateur hôte. Le paramètre Virtualiation du BIOS est défini sur Activé.

J'ai eu le même problème. J'ai modifié les paramètres du BIOS pour activer la virtualisation VT-x sur mon Lenovo. Après cela, la machine virtuelle a déclaré que même si elle était activée, je ne pouvais pas l'utiliser sur ma machine virtuelle. J'ai donc fini par supprimer ma machine virtuelle et en lancer une nouvelle dans l'interface graphique d'Oracle vm virtualbox. Celui-ci avait le VT-x activé dans l'onglet paramètres / système / accélération sous virtualisation matérielle.

    
réponse donnée user2962552 24.12.2015 - 01:01
la source

Lire d'autres questions sur les étiquettes