'indicateur-cpufreq' ne semble pas fonctionner le 14.10

8

J'ai un Dell XPS 12 et je viens d’installer Ubuntu 14.10 (en effaçant complètement l’ancienne installation 14.04).

Le menu d’indicateurs comporte 2 options, Performance et Powersave , à partir desquelles je choisis Performance .

Mais même lorsque le courant est branché et que le compilateur et le navigateur fonctionnent, les choses semblent ralentir et le ventilateur ne se déclenche presque jamais. En effet, voici le résultat de cat /proc/cpuinfo :

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 58
model name  : Intel(R) Core(TM) i7-3667U CPU @ 2.00GHz
stepping    : 9
microcode   : 0x15
cpu MHz     : 1454.785
cache size  : 4096 KB
physical id : 0
siblings    : 4
core id     : 0
cpu cores   : 2
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips    : 4988.72
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family  : 6
model       : 58
model name  : Intel(R) Core(TM) i7-3667U CPU @ 2.00GHz
stepping    : 9
microcode   : 0x15
cpu MHz     : 902.832
cache size  : 4096 KB
physical id : 0
siblings    : 4
core id     : 0
cpu cores   : 2
apicid      : 1
initial apicid  : 1
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips    : 4988.72
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 2
vendor_id   : GenuineIntel
cpu family  : 6
model       : 58
model name  : Intel(R) Core(TM) i7-3667U CPU @ 2.00GHz
stepping    : 9
microcode   : 0x15
cpu MHz     : 1026.562
cache size  : 4096 KB
physical id : 0
siblings    : 4
core id     : 1
cpu cores   : 2
apicid      : 2
initial apicid  : 2
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips    : 4988.72
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 3
vendor_id   : GenuineIntel
cpu family  : 6
model       : 58
model name  : Intel(R) Core(TM) i7-3667U CPU @ 2.00GHz
stepping    : 9
microcode   : 0x15
cpu MHz     : 1000.878
cache size  : 4096 KB
physical id : 0
siblings    : 4
core id     : 1
cpu cores   : 2
apicid      : 3
initial apicid  : 3
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips    : 4988.72
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

J'avais l'habitude de régler le CPU au maximum facilement avec cet indicateur dans Ubuntu 14.04 et 13.10. Comment puis-je faire cela dans le nouveau Ubuntu?

Merci beaucoup

    
posée Phil 24.10.2014 - 20:48
la source

1 réponse

10

Vous utilisez le système Intel Pstate par défaut dans Ubuntu 14.10. Pour utiliser l'ancienne méthode ACPI, vous devez modifier le fichier grub et redémarrer:

Ouvrez un terminal alt + ctrl + t et entrez les lignes suivantes:

sudo cp /etc/default/grub /etc/default/grub.backup

sudo nano /etc/default/grub

Dans l'éditeur Nano, recherchez la ligne commençant par GRUB_CMDLINE_LINUX_DEFAULT À la fin de la ligne ajoutez intel_pstate=disable La ligne entière doit maintenant ressembler à ceci

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable"

appuyez sur les touches ctrl + o pour écrire le fichier, et ctrl + x pour quitter Nano. Ensuite, dans le terminal, entrez la commande suivante pour mettre à jour Grub

sudo update-grub

Vous devriez maintenant redémarrer votre ordinateur et constater que vous êtes en mesure de définir les gouverneurs comme vous l’avez fait en 14.04

    
réponse donnée Charles Green 25.10.2014 - 14:53
la source

Lire d'autres questions sur les étiquettes