14.04 - 16.04 a échoué; apt (= 1.0.1ubuntu2.13) 'n'est pas installé

51

(Cette question n'a pas été résolue. En raison de contraintes de temps, l'ordinateur a été restauré aux paramètres d'usine.)

J'essayais de mettre à jour de 14.04 à 16.04, mais apt a lancé cette erreur:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

Qu'est-ce que cela signifie, et comment puis-je y remédier?

Lorsque je tape la commande apt-cache policy apt

[email protected]:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 
Packages

L’erreur se produit lorsque je lance la commande:

sudo do-release-upgrade -d

et il produit ce qui suit:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.
    
posée Shageenth Sandrakumar 24.05.2016 - 22:45
la source

3 réponses

45

J'ai eu exactement le même problème aujourd'hui. Assurez-vous que votre version est la dernière version d'Ubuntu 14.04 avant la mise à niveau. (Ubuntu 14.04.4 en ce moment)

Le mien était collé à Ubuntu 14.04.3 à cause d’un mauvais miroir.

Alors lancez-vous d'abord:

sudo apt update
sudo apt dist-upgrade

Assurez-vous que la version est maintenant Ubuntu 14.04.4 (mise à jour de septembre 2016: Ubuntu 14.04.5 ).

cat /etc/lsb-release

Et lancer l'installation d'Ubuntu 16.04 avec

sudo do-release-upgrade -d
    
réponse donnée cnxsoft 25.05.2016 - 08:56
la source
10

Mieux vaut toujours mettre à jour les procédures normales de:

sudo apt update
sudo apt dist-upgrade

Si ce qui précède échoue, vous pouvez effectuer manuellement les étapes suivantes. Cette question est obsolète, mais vous pouvez simplement modifier les numéros de version car les liens doivent toujours être les mêmes.

Pour mettre à niveau votre version de apt depuis une fenêtre de terminal, tapez ce qui suit:

sudo apt-get download apt

si ce qui précède ne fonctionne pas, vous pouvez également le télécharger avec wget en exécutant la ligne suivante:

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_amd64.deb

puis tapez

sudo dpkg -i apt*.deb

J'ai juste essayé ceci sur mon système ici. Voici la sortie:

[email protected]:~$ sudo apt-get download apt
[sudo] password for terrance: 
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt amd64 1.0.1ubuntu2.17 [954 kB]
Fetched 954 kB in 0s (1,127 kB/s)
[email protected]:~$ ls
apt_1.0.1ubuntu2.17_amd64.deb  Documents  examples.desktop  Pictures  Templates
Desktop                        Downloads  Music             Public    Videos
[email protected]:~$ sudo dpkg -i apt*.deb
(Reading database ... 168376 files and directories currently installed.)
Preparing to unpack apt_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.11) ...
Setting up apt (1.0.1ubuntu2.17) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...

Si après les étapes décrites, vous voyez un échec dû à une dépendance de dpkg manquante, vous pouvez simplement terminer en répétant les étapes avec dpkg et ..

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.18.24ubuntu1_amd64.deb
sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb

Tous les paquets disponibles pour Ubuntu sont disponibles ici:

lien

    
réponse donnée Terrance 25.05.2016 - 01:02
la source
0

Correction simple ... Ce qui a fonctionné pour moi ...

Ouvrez votre gestionnaire de paquets Synaptic de type "apt" dans le champ de recherche qui vous indiquera la version actuelle d’apt permet d’admettre "1.0.1ubuntu1.13". Haut.

après la mise à niveau ..

Assurez-vous de fermer le gestionnaire de paquets synaptic avant d’exécuter votre

commande finale

sudo do-release-upgrade  

et ça devrait marcher ..

    
réponse donnée jax 06.09.2017 - 12:49
la source

Lire d'autres questions sur les étiquettes