Impossible d'utiliser les raccourcis clavier IntelliJ IDEA sur Ubuntu

115

Je suis très nouveau sur Ubuntu et j'ai un problème que je ne sais pas comment le résoudre. J'ai même essayé de chercher des réponses sur le Web, mais peut-être que je ne connais pas les bons termes pour le rechercher.

Je travaille avec IntelliJ IDEA , une application de développement. Et je suis très habitué aux raccourcis clavier, mais lorsque je suis passé de Windows XP à Ubuntu 13.10, certains raccourcis ne fonctionnent plus. Par exemple, par exemple,

  • Ctrl + Alt + & lt; (flèche gauche)
  • Alt + F8

Y a-t-il une raison pour laquelle? et y a-t-il une solution pour cela? Ou peut-être juste quelque chose pour me guider dans mes recherches

Merci beaucoup à l'avance.

    
posée Rodrigo Sasaki 28.01.2014 - 13:01
la source

9 réponses

184

Un peu de lecture m'a appris que Intellij IDEA est un IDE centré sur le clavier. Ce que cela signifie, c'est qu'une utilisation peut fonctionner avec elle sans avoir à toucher la souris. Aussi, je gère les paramètres de recherche de keymap.

Pour Ubuntu

Voir comment modifier les raccourcis clavier?

Voici une liste de réglages que vous devez effectuer avec les raccourcis clavier par défaut afin qu’ils n’interfèrent pas avec les actions IntelliJ IDEA (listées entre parenthèses).

  
  • Désactiver l’action de la fenêtre Shade, assignée à Ctrl + Alt + S (Boîte de dialogue Paramètres)
  •   
  • Modifier ou désactiver l'action Verrouiller l'écran, assignée à Ctrl + Alt + L (reformater le code)
  •   
  • Modifier ou désactiver l’action du terminal de lancement, assignée à Ctrl + Alt + T (Surround avec)
  •   
  • Modifier ou désactiver l’action Passer à l’espace de travail, assignée à Ctrl + Alt + Touches fléchées (Navigation)
  •   
  • Désactiver l’action de la fenêtre Move, assignée à Alt + F7 (Rechercher des utilisations)
  •   
  • Modifier ou désactiver l’action de la fenêtre Redimensionner, affectée à Alt + F8 (évaluer l'expression)
  •   

J'espère que ça aide!

Remarque: Vous pouvez toujours rétablir les raccourcis Ubuntu à leur état par défaut. Il suffit de se référer à Comment restaurer les raccourcis clavier par défaut? , au cas où vous perdriez .

Source: - Plan du site d'Intellij IDEA

    
réponse donnée AzkerM 28.01.2014 - 13:39
la source
28

J'ai également rencontré ce problème, mais ma solution était différente.

Pas de piratage ou de modification de votre keymap système requise

IntelliJ a différents Keymaps, que vous pouvez modifier en fonction de votre système d'exploitation.

Vous pouvez modifier votre Keymap IntelliJ à partir des paramètres.

Accédez simplement à Settings -> Keymap et sélectionnez le keymap souhaité dans le menu déroulant. Dans mon cas, j'ai choisi "Default for GNOME" car j'utilise Ubuntu Gnome 16.04.

    
réponse donnée Francisco C. 25.06.2016 - 07:18
la source
9

Pour Ubuntu 18.04 LTS ctrl + alt + gauche (conflit de raccourci d’idée Intellij)

  • installez Dconf Editor dans le logiciel ubuntu
  • lancez Dconf Editor, allez à / org / gnome / desktop / wm / keybindings / switch-to-workspace-left

  • double-cliquez comme ci-dessous

  • utilise la valeur par défaut (cliquez sur Off) - & gt; Valeur personnalisée (comme moi ou autre)

  • vous pouvez l’utiliser avec intellij idea maintenant

    
réponse donnée think 06.05.2018 - 11:42
la source
5

J'ai créé ce script qui désactive tous les raccourcis entre Ubuntu (testé avec 15.10) et IntelliJ (et probablement plus de produits Jetbrains). Il les désactive dans Ubuntu.

Il crée également un fichier de sauvegarde pour vous permettre de restaurer vos paramètres précédents.

Pour ne pas avoir certains raccourcis désactivés, mettez-les en commentaire dans le tableau KEYS .

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Vous pouvez l'obtenir ici:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
réponse donnée Jonas Gröger 16.12.2015 - 22:40
la source
3

Consultez ici un moyen de désactiver les raccourcis Ubuntu par programmation et uniquement si les fenêtres de certaines applications sont actives.

Spécifiquement, utilisez ces valeurs (en supposant que vous utilisez la Toolbox JetBrains avec son chemin d’installation standard; adaptez le contraire):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Pendant que le script s'exécute, les raccourcis Ubuntu fonctionnent toujours, sauf lorsque IDEA et al. avoir le focus.

J'ai une collection de raccourcis spécifiques à JetBrains ici ; l'entrée est appréciée.

    
réponse donnée Raphael 22.12.2016 - 14:32
la source
2

Juste pour développer un peu l’excellente réponse d’AzkerM:

  
  • Désactiver l’action de la fenêtre Move, assignée à Alt + F7 (Rechercher des utilisations)           
    • de Paramètres - & gt; Clavier - & gt; Raccourcis - & gt; Windows - & gt; Déplacer la fenêtre
    •     
  •   
  • Modifier ou désactiver l’action de la fenêtre Redimensionner, assignée à Alt + F8 (évaluer l'expression)           
    • de Paramètres - & gt; Clavier - & gt; Raccourcis - & gt; Windows - & gt; Redimensionner la fenêtre
    •     
  •   
    
réponse donnée WillC 24.02.2016 - 12:15
la source
1

J'utilise Ubuntu 16.04 et ce qui s'est passé, c'est que lorsque j'ai utilisé ces touches (ctrl-alt-gauche / droite), la fenêtre se redimensionnait et se plaçait à droite ou à gauche de mon écran. J'ai essayé de désactiver ces raccourcis clavier dans: Paramètres / Clavier / Navigation, même si les espaces de travail ne sont pas activés. Cela n'a toujours pas empêché le comportement que je voyais.

Heureusement, j'ai ouvert Compiz et je suis tombé sur le plug-in Window Management / Grid qui mappait ces clés pour placer les fenêtres dans une position de grille. J'ai désactivé ce plugin et maintenant mes raccourcis clavier IntelliJ fonctionnent bien avec ctrl-alt-left / right.

    
réponse donnée Jason White 14.06.2016 - 00:08
la source
1

Juste une solution rapide:
Si vous avez une touche " Windows " sur votre clavier, vous pouvez simplement l'ajouter à la combinaison complète de raccourcis - cela devrait fonctionner. Par exemple:

  • Ctrl + Win + Alt + T (Surround with)
  • Win + Alt + F8 (Évaluez l'expression )
réponse donnée guzoff 28.11.2017 - 21:53
la source
0

Pour Ubuntu 16.04, accédez à Paramètres & gt; Clavier et trouvez la combinaison en conflit avec votre clic désiré et mettez-la à jour.

    
réponse donnée Cengkuru Michael 29.10.2017 - 10:22
la source

Lire d'autres questions sur les étiquettes